summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-04-28 10:20:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-04-28 10:20:13 +0000
commit8a1c134e682a55f6e8a1f848076a30c237634fbd (patch)
tree791913fbdb39f818d0773b6e3df28adcd5553b31 /app-admin/rsyslog/files
parentUse subslot on icu so it is rebuild automatically with icu update. (diff)
downloadgentoo-2-8a1c134e682a55f6e8a1f848076a30c237634fbd.tar.gz
gentoo-2-8a1c134e682a55f6e8a1f848076a30c237634fbd.tar.bz2
gentoo-2-8a1c134e682a55f6e8a1f848076a30c237634fbd.zip
Detect new json-c-0.11. Patch from Thomas D. <whissi@whissi.de>. Fixes bug #467338
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-admin/rsyslog/files')
-rw-r--r--app-admin/rsyslog/files/rsyslog-7.2.5-json-c-pkgconfig.patch105
1 files changed, 60 insertions, 45 deletions
diff --git a/app-admin/rsyslog/files/rsyslog-7.2.5-json-c-pkgconfig.patch b/app-admin/rsyslog/files/rsyslog-7.2.5-json-c-pkgconfig.patch
index 61cc38c5a3dc..3b000e868299 100644
--- a/app-admin/rsyslog/files/rsyslog-7.2.5-json-c-pkgconfig.patch
+++ b/app-admin/rsyslog/files/rsyslog-7.2.5-json-c-pkgconfig.patch
@@ -1,13 +1,20 @@
From edf9b718d3007bdb519b3d64cb1f8145bba8e15e Mon Sep 17 00:00:00 2001
From: Justin Lecher <jlec@gentoo.org>
Date: Tue, 12 Feb 2013 11:55:17 +0100
-Subject: [PATCH] Use pkg-config to detect json-c
+Subject: [PATCH] Use pkg-config to detect json or json-c
There was a typo in the configure.ac which prevented correct usage of pkg-config
to detect json-c.
This patch corrects this typo and removes all paths from json.h in source files.
+Moreover, since json-c-0.11 the pkgconfig was renamed to json-c so the
+configure.ac file was modified to check for the new one if the old one was
+not found.
+Reported-by: Thomas D. <whissi@whissi.de>
+Tested-by: Thomas D. <whissi@whissi.de>
Signed-off-by: Justin Lecher <jlec@gentoo.org>
+Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
+
---
action.c | 2 +-
configure.ac | 2 +-
@@ -21,10 +28,10 @@ Signed-off-by: Justin Lecher <jlec@gentoo.org>
template.h | 2 +-
10 files changed, 10 insertions(+), 10 deletions(-)
-diff --git a/action.c b/action.c
-index 07f3a6f..d5cf983 100644
---- a/action.c
-+++ b/action.c
+Index: rsyslog-7.2.7/action.c
+===================================================================
+--- rsyslog-7.2.7.orig/action.c
++++ rsyslog-7.2.7/action.c
@@ -98,7 +98,7 @@
#include <strings.h>
#include <time.h>
@@ -34,11 +41,22 @@ index 07f3a6f..d5cf983 100644
#include "dirty.h"
#include "template.h"
-diff --git a/configure.ac b/configure.ac
-index e9fce3f..cad0d57 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -758,7 +758,7 @@ if test "x$enable_rsyslogrt" = "xyes"; then
+Index: rsyslog-7.2.7/configure.ac
+===================================================================
+--- rsyslog-7.2.7.orig/configure.ac
++++ rsyslog-7.2.7/configure.ac
+@@ -34,7 +34,9 @@ PKG_PROG_PKG_CONFIG
+ # modules we require
+ PKG_CHECK_MODULES(LIBESTR, libestr >= 0.1.5)
+ PKG_CHECK_MODULES(LIBEE, libee >= 0.4.0)
+-PKG_CHECK_MODULES([JSON_C], [json])
++PKG_CHECK_MODULES([JSON_C], [json],, [
++ PKG_CHECK_MODULES([JSON_C], [json-c])
++])
+
+ case "${host}" in
+ *-*-linux*)
+@@ -764,7 +766,7 @@ if test "x$enable_rsyslogrt" = "xyes"; t
RSRT_LIBS1="\$(top_builddir)/runtime/librsyslog.la"
fi
AM_CONDITIONAL(ENABLE_RSYSLOGRT, test x$enable_rsyslogrt = xyes)
@@ -47,10 +65,10 @@ index e9fce3f..cad0d57 100644
RSRT_LIBS="\$(RSRT_LIBS1) \$(LIBESTR_LIBS) \$(JSON_C_LIBS)"
AC_SUBST(RSRT_CFLAGS1)
AC_SUBST(RSRT_LIBS1)
-diff --git a/plugins/imkmsg/kmsg.c b/plugins/imkmsg/kmsg.c
-index b771d68..1c3ae4d 100644
---- a/plugins/imkmsg/kmsg.c
-+++ b/plugins/imkmsg/kmsg.c
+Index: rsyslog-7.2.7/plugins/imkmsg/kmsg.c
+===================================================================
+--- rsyslog-7.2.7.orig/plugins/imkmsg/kmsg.c
++++ rsyslog-7.2.7/plugins/imkmsg/kmsg.c
@@ -35,7 +35,7 @@
#ifdef OS_LINUX
#include <sys/klog.h>
@@ -60,10 +78,10 @@ index b771d68..1c3ae4d 100644
#include "rsyslog.h"
#include "srUtils.h"
-diff --git a/plugins/mmjsonparse/mmjsonparse.c b/plugins/mmjsonparse/mmjsonparse.c
-index c47aceb..56db557 100644
---- a/plugins/mmjsonparse/mmjsonparse.c
-+++ b/plugins/mmjsonparse/mmjsonparse.c
+Index: rsyslog-7.2.7/plugins/mmjsonparse/mmjsonparse.c
+===================================================================
+--- rsyslog-7.2.7.orig/plugins/mmjsonparse/mmjsonparse.c
++++ rsyslog-7.2.7/plugins/mmjsonparse/mmjsonparse.c
@@ -36,7 +36,7 @@
#include <unistd.h>
#include <ctype.h>
@@ -73,10 +91,10 @@ index c47aceb..56db557 100644
#include "conf.h"
#include "syslogd-types.h"
#include "template.h"
-diff --git a/plugins/mmnormalize/mmnormalize.c b/plugins/mmnormalize/mmnormalize.c
-index fd2004a..45dde98 100644
---- a/plugins/mmnormalize/mmnormalize.c
-+++ b/plugins/mmnormalize/mmnormalize.c
+Index: rsyslog-7.2.7/plugins/mmnormalize/mmnormalize.c
+===================================================================
+--- rsyslog-7.2.7.orig/plugins/mmnormalize/mmnormalize.c
++++ rsyslog-7.2.7/plugins/mmnormalize/mmnormalize.c
@@ -40,7 +40,7 @@
#include <unistd.h>
#include <libestr.h>
@@ -86,10 +104,10 @@ index fd2004a..45dde98 100644
#include <liblognorm.h>
#include "conf.h"
#include "syslogd-types.h"
-diff --git a/plugins/ommongodb/ommongodb.c b/plugins/ommongodb/ommongodb.c
-index dd99741..64d501d 100644
---- a/plugins/ommongodb/ommongodb.c
-+++ b/plugins/ommongodb/ommongodb.c
+Index: rsyslog-7.2.7/plugins/ommongodb/ommongodb.c
+===================================================================
+--- rsyslog-7.2.7.orig/plugins/ommongodb/ommongodb.c
++++ rsyslog-7.2.7/plugins/ommongodb/ommongodb.c
@@ -33,7 +33,7 @@
#include <stdint.h>
#include <time.h>
@@ -99,10 +117,10 @@ index dd99741..64d501d 100644
/* For struct json_object_iter, should not be necessary in future versions */
#include <json/json_object_private.h>
-diff --git a/runtime/msg.c b/runtime/msg.c
-index 68577ad..664abb9 100644
---- a/runtime/msg.c
-+++ b/runtime/msg.c
+Index: rsyslog-7.2.7/runtime/msg.c
+===================================================================
+--- rsyslog-7.2.7.orig/runtime/msg.c
++++ rsyslog-7.2.7/runtime/msg.c
@@ -41,7 +41,7 @@
#endif
#include <netdb.h>
@@ -112,10 +130,10 @@ index 68577ad..664abb9 100644
/* For struct json_object_iter, should not be necessary in future versions */
#include <json/json_object_private.h>
#if HAVE_MALLOC_H
-diff --git a/runtime/msg.h b/runtime/msg.h
-index 564441b..caa825f 100644
---- a/runtime/msg.h
-+++ b/runtime/msg.h
+Index: rsyslog-7.2.7/runtime/msg.h
+===================================================================
+--- rsyslog-7.2.7.orig/runtime/msg.h
++++ rsyslog-7.2.7/runtime/msg.h
@@ -30,7 +30,7 @@
#include <pthread.h>
@@ -125,10 +143,10 @@ index 564441b..caa825f 100644
#include "obj.h"
#include "syslogd-types.h"
#include "template.h"
-diff --git a/template.c b/template.c
-index 1ccb375..974aba3 100644
---- a/template.c
-+++ b/template.c
+Index: rsyslog-7.2.7/template.c
+===================================================================
+--- rsyslog-7.2.7.orig/template.c
++++ rsyslog-7.2.7/template.c
@@ -34,7 +34,7 @@
#include <string.h>
#include <ctype.h>
@@ -138,10 +156,10 @@ index 1ccb375..974aba3 100644
#include "stringbuf.h"
#include "syslogd-types.h"
#include "template.h"
-diff --git a/template.h b/template.h
-index 018e2f5..c87e7a8 100644
---- a/template.h
-+++ b/template.h
+Index: rsyslog-7.2.7/template.h
+===================================================================
+--- rsyslog-7.2.7.orig/template.h
++++ rsyslog-7.2.7/template.h
@@ -30,7 +30,7 @@
#ifndef TEMPLATE_H_INCLUDED
#define TEMPLATE_H_INCLUDED 1
@@ -151,6 +169,3 @@ index 018e2f5..c87e7a8 100644
#include <libestr.h>
#include "regexp.h"
#include "stringbuf.h"
---
-1.8.1.2
-