summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-10-22 14:21:51 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-10-22 14:21:51 +0000
commit09f64317c5ca219bd7b78c47063448c9dba7eeba (patch)
tree7319547c27c1662d1b028cb15be6e1d02463438b /app-admin/phpsyslogng
parentadded LINGUAS support (#238245) (diff)
downloadgentoo-2-09f64317c5ca219bd7b78c47063448c9dba7eeba.tar.gz
gentoo-2-09f64317c5ca219bd7b78c47063448c9dba7eeba.tar.bz2
gentoo-2-09f64317c5ca219bd7b78c47063448c9dba7eeba.zip
Taking over as proxy committer, Matthias Schöffmann is going to be the proxy maintainer (adjusted metadata accordingly); version bump (by matthias, imported from php-experimental overlay), bug 240314
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'app-admin/phpsyslogng')
-rw-r--r--app-admin/phpsyslogng/ChangeLog10
-rw-r--r--app-admin/phpsyslogng/metadata.xml12
-rw-r--r--app-admin/phpsyslogng/phpsyslogng-2.9.8f.ebuild40
3 files changed, 57 insertions, 5 deletions
diff --git a/app-admin/phpsyslogng/ChangeLog b/app-admin/phpsyslogng/ChangeLog
index 8e9875e57814..a62d4fcc0ff3 100644
--- a/app-admin/phpsyslogng/ChangeLog
+++ b/app-admin/phpsyslogng/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/phpsyslogng
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/phpsyslogng/ChangeLog,v 1.7 2008/08/16 17:38:12 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/phpsyslogng/ChangeLog,v 1.8 2008/10/22 14:21:50 hoffie Exp $
+
+*phpsyslogng-2.9.8f (22 Oct 2008)
+
+ 22 Oct 2008; Christian Hoffmann <hoffie@gentoo.org> metadata.xml,
+ +phpsyslogng-2.9.8f.ebuild:
+ Taking over as proxy committer, Matthias Schöffmann <matthias@dsx.at> is
+ going to be the proxy maintainer (adjusted metadata accordingly); version
+ bump (by matthias, imported from php-experimental overlay), bug 240314
16 Aug 2008; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove strerror from metadata.xml (#89719)
diff --git a/app-admin/phpsyslogng/metadata.xml b/app-admin/phpsyslogng/metadata.xml
index 7dfbf76fcdf9..6b3daa76a158 100644
--- a/app-admin/phpsyslogng/metadata.xml
+++ b/app-admin/phpsyslogng/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
+<herd>no-herd</herd>
+<maintainer>
+ <email>hoffie@gentoo.org</email>
+</maintainer>
+<maintainer>
+ <email>matthias@dsx.at</email>
+ <name>Matthias Schöffmann</name>
+</maintainer>
</pkgmetadata>
diff --git a/app-admin/phpsyslogng/phpsyslogng-2.9.8f.ebuild b/app-admin/phpsyslogng/phpsyslogng-2.9.8f.ebuild
new file mode 100644
index 000000000000..48e4da0cdc9a
--- /dev/null
+++ b/app-admin/phpsyslogng/phpsyslogng-2.9.8f.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/phpsyslogng/phpsyslogng-2.9.8f.ebuild,v 1.1 2008/10/22 14:21:51 hoffie Exp $
+
+inherit webapp
+
+DESCRIPTION="php-syslog-ng is a log monitor designed to easily manage logs from many hosts."
+HOMEPAGE="http://php-syslog-ng.googlecode.com/"
+SRC_URI="http://php-syslog-ng.googlecode.com/files/php-syslog-ng-${PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc64 ~x86"
+IUSE="mysql"
+
+RDEPEND="virtual/httpd-php
+ mysql? ( >=virtual/mysql-4.1 )"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc php-syslog-ng/html/README php-syslog-ng/html/CHANGELOG \
+ php-syslog-ng/html/INSTALL-STEPS \
+ php-syslog-ng/html/TROUBLESHOOTING-INSTALL
+ rm php-syslog-ng/html/LICENSE php-syslog-ng/html/README \
+ php-syslog-ng/html/CHANGELOG php-syslog-ng/html/INSTALL-STEPS \
+ php-syslog-ng/html/TROUBLESHOOTING-INSTALL
+ dodoc php-syslog-ng/scripts/*
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r ./php-syslog-ng/html/{.htaccess,*}
+
+ webapp_configfile "${MY_HTDOCSDIR}/config/config.php"
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}/config/"
+ webapp_serverowned -R "${MY_HTDOCSDIR}/jpcache/"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+
+ webapp_src_install
+}