summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2013-09-10 21:40:15 +0000
committerJosé María Alonso <nimiux@gentoo.org>2013-09-10 21:40:15 +0000
commitf9eebcc9c9945ae094c8b558e4469124a82d6b5a (patch)
tree9a1eea755b5c11c62e4cbccdada7c6f284404c94 /app-admin/mktwpol
parentarm stable, bug #483250 (diff)
downloadgentoo-2-f9eebcc9c9945ae094c8b558e4469124a82d6b5a.tar.gz
gentoo-2-f9eebcc9c9945ae094c8b558e4469124a82d6b5a.tar.bz2
gentoo-2-f9eebcc9c9945ae094c8b558e4469124a82d6b5a.zip
Initial version thanks to Chuck Seyboldt <seyboldt@gmail.com>
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'app-admin/mktwpol')
-rw-r--r--app-admin/mktwpol/ChangeLog10
-rw-r--r--app-admin/mktwpol/metadata.xml41
-rw-r--r--app-admin/mktwpol/mktwpol-0.1.4.ebuild39
3 files changed, 90 insertions, 0 deletions
diff --git a/app-admin/mktwpol/ChangeLog b/app-admin/mktwpol/ChangeLog
new file mode 100644
index 000000000000..66a9e17d7e4a
--- /dev/null
+++ b/app-admin/mktwpol/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-admin/mktwpol
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mktwpol/ChangeLog,v 1.1 2013/09/10 21:40:15 nimiux Exp $
+
+*mktwpol-0.1.4 (10 Sep 2013)
+
+ 10 Sep 2013; Chema Alonso <nimiux@gentoo.org> +mktwpol-0.1.4.ebuild,
+ +metadata.xml:
+ New ebuild thanks to Chuck Seyboldt <seyboldt@gmail.com>
+
diff --git a/app-admin/mktwpol/metadata.xml b/app-admin/mktwpol/metadata.xml
new file mode 100644
index 000000000000..0602d9179e29
--- /dev/null
+++ b/app-admin/mktwpol/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nimiux@gentoo.org</email>
+ <name>Chema Alonso</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>c.cboldt@gmail.com</email>
+ <name>Chuck Seyboldt</name>
+ <description>Will reply to bug reports</description>
+ </maintainer>
+ <changelog>https://sourceforge.net/p/mktwpol/code/ci/master/tree/CHANGES</changelog>
+ <doc>https://sourceforge.net/p/mktwpol/code/ci/master/tree/README</doc>
+ <bugs-to>https://sourceforge.net/p/mktwpol/discussion/bugs/</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ mktwpol is a tool that aids system administrators in the
+ set-up and maintenance of tripwire (an Intrusion
+ Detection System). It contains a pair of bash scripts,
+ mktwpol.sh and twsetup.sh. mktwpol.sh generates a
+ tripwire policy file that is tailored to the packages
+ installed on any given sytem. twsetup.sh steps through
+ the initial set-up of tripwire, including the generating
+ of encryption keys and encrypting the files that are
+ necessary for tripwire to perform its function.
+ </longdescription>
+ <longdescription lang="es">
+ mktwpol es una herramienta que ayuda a los administradores
+ de sistemas en la configuración y el mantenimiento de
+ tripwire (un Sistema de Detección de Intrusos). Contiene
+ dos guiones bash: mktwpol.sh y twsetup.sh. mktwpol.sh
+ genera un fichero de directriz para tripwire ajustada
+ a los paquetes instalados en un sistema. twsetup.sh realiza
+ la configuración inicial de tripwire, incluyendo la
+ generación de las claves de cifrado y realiza el
+ cifrado de los ficheros necesitados por tripwire para
+ realizar su función.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/mktwpol/mktwpol-0.1.4.ebuild b/app-admin/mktwpol/mktwpol-0.1.4.ebuild
new file mode 100644
index 000000000000..9c7bcc88e235
--- /dev/null
+++ b/app-admin/mktwpol/mktwpol-0.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mktwpol/mktwpol-0.1.4.ebuild,v 1.1 2013/09/10 21:40:15 nimiux Exp $
+
+EAPI=5
+
+DESCRIPTION="Bash scripts to create and maintain tripwire database"
+HOMEPAGE="https://sourceforge.net/projects/mktwpol"
+SRC_URI="mirror://sourceforge/mktwpol/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-shells/bash"
+RDEPEND="app-admin/tripwire"
+
+src_install() {
+
+ dosbin mktwpol.sh twsetup.sh
+ fperms 750 /usr/sbin/mktwpol.sh /usr/sbin/twsetup.sh
+
+ local d
+ for d in README* ChangeLog AUTHORS NEWS TODO CHANGES THANKS BUGS \
+ FAQ CREDITS CHANGELOG ; do
+ [[ -s "${d}" ]] && dodoc "${d}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Installation and setup of tripwire ..."
+ elog " - Run: \`twsetup.sh\`"
+ elog
+ elog "Maintenance of tripwire as packages are added and/or deleted ..."
+ elog " - Run: \`mktwpol.sh -u\` to update tripwire policy"
+ elog
+}