summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-11 10:34:30 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-11 10:34:30 +0000
commit77476480b85acf9e0ead0fe1f02c8aad6c37b9bf (patch)
tree4405c6f96c91a12dfc33f56f6cf2265a30fbf45c /app-admin/lcap/lcap-0.0.6-r2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-77476480b85acf9e0ead0fe1f02c8aad6c37b9bf.tar.gz
gentoo-2-77476480b85acf9e0ead0fe1f02c8aad6c37b9bf.tar.bz2
gentoo-2-77476480b85acf9e0ead0fe1f02c8aad6c37b9bf.zip
Revision bump upgrading to latest Debian patch, also keywording ~amd64 wrt #198786.
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-admin/lcap/lcap-0.0.6-r2.ebuild')
-rw-r--r--app-admin/lcap/lcap-0.0.6-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/lcap/lcap-0.0.6-r2.ebuild b/app-admin/lcap/lcap-0.0.6-r2.ebuild
new file mode 100644
index 000000000000..930f3d4dc8d2
--- /dev/null
+++ b/app-admin/lcap/lcap-0.0.6-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lcap/lcap-0.0.6-r2.ebuild,v 1.1 2007/11/11 10:34:30 drac Exp $
+
+inherit eutils toolchain-funcs
+
+PATCH_LEVEL=3.1
+
+DESCRIPTION="kernel capability remover"
+HOMEPAGE="http://packages.qa.debian.org/l/lcap.html"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${P/-/_}.orig.tar.gz
+ mirror://debian/pool/main/l/${PN}/${P/-/_}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lids"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P/-/_}-${PATCH_LEVEL}.diff
+ use lids || sed -i -e "s:LIDS =:#\0:" Makefile
+ sed -i -e "s:-O3:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dosbin lcap
+ doman lcap.8
+ dodoc README debian/changelog
+}