summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-11-07 18:55:42 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-11-07 18:55:42 +0000
commitbf6f650e6c86a9876fb41a202de77a8dfe8e746f (patch)
tree16c356f8cd42a0eb8b92cd64ba1d22b1182cf4a2 /app-admin/keepassx
parentadding 1.3.2_rc2-r1; this is mainly a copy of 1.3.1, but including the securi... (diff)
downloadgentoo-2-bf6f650e6c86a9876fb41a202de77a8dfe8e746f.tar.gz
gentoo-2-bf6f650e6c86a9876fb41a202de77a8dfe8e746f.tar.bz2
gentoo-2-bf6f650e6c86a9876fb41a202de77a8dfe8e746f.zip
Fix qt checks, see bug #237928 and #244862.
(Portage version: 2.2_rc13/cvs/Linux 2.6.27-gentoo-r1 x86_64)
Diffstat (limited to 'app-admin/keepassx')
-rw-r--r--app-admin/keepassx/ChangeLog6
-rw-r--r--app-admin/keepassx/keepassx-0.2.2-r1.ebuild6
-rw-r--r--app-admin/keepassx/keepassx-0.3.3.ebuild10
3 files changed, 12 insertions, 10 deletions
diff --git a/app-admin/keepassx/ChangeLog b/app-admin/keepassx/ChangeLog
index 2e72ce2ed8d5..7c31fb8dbf27 100644
--- a/app-admin/keepassx/ChangeLog
+++ b/app-admin/keepassx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/keepassx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.30 2008/10/07 06:14:50 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.31 2008/11/07 18:55:42 tgurr Exp $
+
+ 07 Nov 2008; Timo Gurr <tgurr@gentoo.org> keepassx-0.2.2-r1.ebuild,
+ keepassx-0.3.3.ebuild:
+ Fix qt checks, see bug #237928 and #244862.
07 Oct 2008; Zac Medico <zmedico@gentoo.org> keepassx-0.3.3.ebuild:
Bug #239671 - Fix the distcc workaround so it also works when ccache is
diff --git a/app-admin/keepassx/keepassx-0.2.2-r1.ebuild b/app-admin/keepassx/keepassx-0.2.2-r1.ebuild
index 7e374a3c0bbd..07b200781816 100644
--- a/app-admin/keepassx/keepassx-0.2.2-r1.ebuild
+++ b/app-admin/keepassx/keepassx-0.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.2.2-r1.ebuild,v 1.6 2008/01/14 19:03:33 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.2.2-r1.ebuild,v 1.7 2008/11/07 18:55:42 tgurr Exp $
inherit eutils
@@ -18,9 +18,9 @@ RDEPEND="${DEPEND}"
pkg_setup() {
if ! built_with_use --missing true x11-libs/qt qt3support png; then
eerror
- eerror "You need to rebuild x11-libs/qt with USE=qt3support enabled"
+ eerror "You need to rebuild x11-libs/qt with USE=\"qt3support png\" enabled"
eerror
- die "please rebuild x11-libs/qt with USE=qt3support"
+ die "please rebuild x11-libs/qt with USE=\"qt3support png\""
fi
}
diff --git a/app-admin/keepassx/keepassx-0.3.3.ebuild b/app-admin/keepassx/keepassx-0.3.3.ebuild
index b593eb9df215..e3648d166983 100644
--- a/app-admin/keepassx/keepassx-0.3.3.ebuild
+++ b/app-admin/keepassx/keepassx-0.3.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.3.ebuild,v 1.3 2008/10/07 06:14:50 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.3.ebuild,v 1.4 2008/11/07 18:55:42 tgurr Exp $
-EAPI="1"
+EAPI="2"
inherit eutils qt4
@@ -17,11 +17,9 @@ IUSE="debug"
DEPEND="|| ( ( x11-libs/qt-core:4
x11-libs/qt-gui:4
x11-libs/qt-xmlpatterns:4 )
- >=x11-libs/qt-4.3:4 )"
+ ( =x11-libs/qt-4.3*:4[png,zlib] ) )"
RDEPEND="${DEPEND}"
-QT4_BUILT_WITH_USE_CHECK="zlib"
-
src_compile() {
cd "${S}/src"
lrelease src.pro || die "lrelease failed"
@@ -35,5 +33,5 @@ src_compile() {
src_install(){
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc changelog todo
+ dodoc changelog todo || die "dodoc failed"
}