summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 17:17:24 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 17:17:24 +0000
commit3c258344688deec85c9507ee3d54c02e9cc3d1fa (patch)
treeb2afafd6e120b13f616b303236d45ee1ec353562 /app-admin/integrit/integrit-4.0.ebuild
parentadd ClearType-style sub-pixel hinting patch from Arch Linux (diff)
downloadgentoo-2-3c258344688deec85c9507ee3d54c02e9cc3d1fa.tar.gz
gentoo-2-3c258344688deec85c9507ee3d54c02e9cc3d1fa.tar.bz2
gentoo-2-3c258344688deec85c9507ee3d54c02e9cc3d1fa.zip
QA: Use the user-chosen ar/cc instead of just running ar/gcc directly, quoted ${S} and removed broken versions
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-admin/integrit/integrit-4.0.ebuild')
-rw-r--r--app-admin/integrit/integrit-4.0.ebuild31
1 files changed, 21 insertions, 10 deletions
diff --git a/app-admin/integrit/integrit-4.0.ebuild b/app-admin/integrit/integrit-4.0.ebuild
index 8efd2ca4f091..674fb9c1312c 100644
--- a/app-admin/integrit/integrit-4.0.ebuild
+++ b/app-admin/integrit/integrit-4.0.ebuild
@@ -1,24 +1,35 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/integrit/integrit-4.0.ebuild,v 1.4 2008/01/14 19:51:28 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/integrit/integrit-4.0.ebuild,v 1.5 2008/12/30 17:17:24 angelos Exp $
+
+inherit autotools toolchain-funcs
DESCRIPTION="file integrity verification program"
HOMEPAGE="http://integrit.sourceforge.net/"
-SRC_URI="mirror://sourceforge/integrit/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE=""
-DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "/^CC/d" configure.in hashtbl/configure.in || die
+ sed -i -e "/^AC_PROGRAM_PATH/d" configure.in hashtbl/configure.in || die
+
+ eautoreconf
+}
src_compile() {
- econf --prefix=/usr || die
+ tc-export AR
+ econf
emake || die
emake utils || die
- cd ${S}/doc
+ cd "${S}"/doc
emake || die
- cd ${S}/hashtbl
+ cd "${S}"/hashtbl
emake hashtest || die
mv README README.hashtbl
}
@@ -28,22 +39,22 @@ src_install() {
dolib libintegrit.a
dodoc Changes HACKING README todo.txt
- cd ${S}/utils
+ cd "${S}"/utils
dosbin i-viewdb
dobin i-ls
- cd ${S}/hashtbl
+ cd "${S}"/hashtbl
dolib libhashtbl.a
insinto /usr/include
doins hashtbl.h
dobin hashtest
dodoc README.hashtbl
- cd ${S}/doc
+ cd "${S}"/doc
doman i-ls.1 i-viewdb.1 integrit.1
doinfo integrit.info
- cd ${S}/examples
+ cd "${S}"/examples
docinto examples
dodoc *
}