summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-01-26 19:34:16 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-01-26 19:34:16 +0000
commitc113db165d78b7c0d93bf49aec6abcdf0e70df14 (patch)
tree622fa4b89190c8319a50d09ffa25f882bde0f658 /app-admin/haskell-updater
parentVersion bump. (diff)
downloadgentoo-2-c113db165d78b7c0d93bf49aec6abcdf0e70df14.tar.gz
gentoo-2-c113db165d78b7c0d93bf49aec6abcdf0e70df14.tar.bz2
gentoo-2-c113db165d78b7c0d93bf49aec6abcdf0e70df14.zip
Add haskell-updater-1.0.0.0, that works with the soon committed dev-lang/ghc-6.12.1.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/haskell-updater')
-rw-r--r--app-admin/haskell-updater/ChangeLog9
-rw-r--r--app-admin/haskell-updater/haskell-updater-1.0.0.0.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/app-admin/haskell-updater/ChangeLog b/app-admin/haskell-updater/ChangeLog
index 0cb19f8cae37..501b94dec5c0 100644
--- a/app-admin/haskell-updater/ChangeLog
+++ b/app-admin/haskell-updater/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/haskell-updater
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/ChangeLog,v 1.3 2009/09/16 06:56:21 kolmodin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/ChangeLog,v 1.4 2010/01/26 19:34:16 kolmodin Exp $
+
+*haskell-updater-1.0.0.0 (26 Jan 2010)
+
+ 26 Jan 2010; <kolmodin@gentoo.org> +haskell-updater-1.0.0.0.ebuild:
+ Bump with a version that works with ghc 6.12.1.
16 Sep 2009; Lennart Kolmodin <kolmodin@gentoo.org>
haskell-updater-0.9.1.0.ebuild:
diff --git a/app-admin/haskell-updater/haskell-updater-1.0.0.0.ebuild b/app-admin/haskell-updater/haskell-updater-1.0.0.0.ebuild
new file mode 100644
index 000000000000..e5f17f788606
--- /dev/null
+++ b/app-admin/haskell-updater/haskell-updater-1.0.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/haskell-updater-1.0.0.0.ebuild,v 1.1 2010/01/26 19:34:16 kolmodin Exp $
+
+CABAL_FEATURES="bin nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
+HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86" # Add keywords as those archs have a binpkg
+IUSE=""
+
+DEPEND="=dev-lang/ghc-6.12*"
+
+# Need a lower version for portage to get --keep-going
+RDEPEND="|| ( >=sys-apps/portage-2.1.6
+ sys-apps/pkgcore
+ sys-apps/paludis )"
+
+src_compile() {
+ CABAL_CONFIGURE_FLAGS="--bindir=/usr/sbin"
+
+ cabal_src_compile
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc TODO
+}