summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-03-11 14:16:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-03-11 14:16:55 +0000
commitadd5c88048e35007e9ad2e5f58b7cd8bf06464a8 (patch)
tree73ad7ce07b644bdd67b1e6523f295f68926d12df /app-admin/gnome-system-tools
parentMarking rack-protection-1.2.0 ~ppc64 for bug 396291 (diff)
downloadgentoo-2-add5c88048e35007e9ad2e5f58b7cd8bf06464a8.tar.gz
gentoo-2-add5c88048e35007e9ad2e5f58b7cd8bf06464a8.tar.bz2
gentoo-2-add5c88048e35007e9ad2e5f58b7cd8bf06464a8.zip
Fix build failures due to atk underlinking.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/gnome-system-tools')
-rw-r--r--app-admin/gnome-system-tools/ChangeLog11
-rw-r--r--app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-libtool-intermediate-libs.patch92
-rw-r--r--app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-atk.patch24
-rw-r--r--app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-m.patch28
-rw-r--r--app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r3.ebuild59
5 files changed, 213 insertions, 1 deletions
diff --git a/app-admin/gnome-system-tools/ChangeLog b/app-admin/gnome-system-tools/ChangeLog
index 615c392111ca..60776fc5391e 100644
--- a/app-admin/gnome-system-tools/ChangeLog
+++ b/app-admin/gnome-system-tools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/gnome-system-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gnome-system-tools/ChangeLog,v 1.111 2012/03/05 21:50:58 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gnome-system-tools/ChangeLog,v 1.112 2012/03/11 14:16:54 eva Exp $
+
+*gnome-system-tools-2.32.0-r3 (11 Mar 2012)
+
+ 11 Mar 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-system-tools-2.32.0-r3.ebuild,
+ +files/gnome-system-tools-2.32.0-libtool-intermediate-libs.patch,
+ +files/gnome-system-tools-2.32.0-missing-atk.patch,
+ +files/gnome-system-tools-2.32.0-missing-m.patch:
+ Fix build failures due to atk underlinking.
05 Mar 2012; Brent Baude <ranger@gentoo.org>
gnome-system-tools-2.32.0-r2.ebuild:
diff --git a/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-libtool-intermediate-libs.patch b/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-libtool-intermediate-libs.patch
new file mode 100644
index 000000000000..65d7f74e0a91
--- /dev/null
+++ b/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-libtool-intermediate-libs.patch
@@ -0,0 +1,92 @@
+From 6ad900d99bbbe1fd5987c380835b907e51d41eda Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <gilles.dartiguelongue@esiee.org>
+Date: Sat, 10 Mar 2012 15:59:51 +0100
+Subject: [PATCH 1/3] Use libtool intermediate library instead of static
+ archive
+
+---
+ configure.in | 4 ++--
+ src/common/Makefile.am | 4 ++--
+ src/time/Makefile.am | 4 ++--
+ src/time/e-map/Makefile.am | 6 +++---
+ 4 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index c266d02..2d60648 100644
+--- a/configure.in
++++ b/configure.in
+@@ -237,12 +237,12 @@ GST_DEPRECATED_FLAGS=""
+ GST_LIBS="$GST_DEPENDS_LIBS $POLKIT_GTK_LIBS"
+ GST_CFLAGS="$GST_DEPENDS_CFLAGS $POLKIT_GTK_CFLAGS $GST_DEPRECATED_FLAGS"
+
+-GST_TOOL_LIBS="\$(top_builddir)/src/common/libsetuptool.a $GST_LIBS"
++GST_TOOL_LIBS="\$(top_builddir)/src/common/libsetuptool.la $GST_LIBS"
+ GST_TOOL_CFLAGS="-I\$(top_srcdir)/src/common $GST_CFLAGS"
+
+ GST_TOOL_CLEANFILES="\$(desktop) \$(desktop).in"
+ GST_TOOL_EXTRA_DIST="\$(toolpixmaps) \$(desktop).in.in"
+-GST_TOOL_DEPENDENCIES="\$(top_builddir)/src/common/libsetuptool.a"
++GST_TOOL_DEPENDENCIES="\$(top_builddir)/src/common/libsetuptool.la"
+
+ AC_SUBST(GST_LIBS)
+ AC_SUBST(GST_CFLAGS)
+diff --git a/src/common/Makefile.am b/src/common/Makefile.am
+index 6698b4d..c39c286 100644
+--- a/src/common/Makefile.am
++++ b/src/common/Makefile.am
+@@ -1,6 +1,6 @@
+ include $(top_srcdir)/DirsMakefile
+
+-noinst_LIBRARIES = libsetuptool.a
++noinst_LTLIBRARIES = libsetuptool.la
+
+ INCLUDES += \
+ $(GST_CFLAGS) \
+@@ -10,7 +10,7 @@ INCLUDES += \
+ -DPREFIX=\""$(prefix)"\" \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\"
+
+-libsetuptool_a_SOURCES = \
++libsetuptool_la_SOURCES = \
+ gst-dialog.c gst-dialog.h \
+ gst-tool.c gst-tool.h \
+ gst-platform-dialog.c gst-platform-dialog.h \
+diff --git a/src/time/Makefile.am b/src/time/Makefile.am
+index e9adaf4..6ff332f 100644
+--- a/src/time/Makefile.am
++++ b/src/time/Makefile.am
+@@ -15,8 +15,8 @@ INCLUDES += $(GST_TOOL_CFLAGS) $(DBUS_CFLAGS)
+ CLEANFILES = $(GST_TOOL_CLEANFILES)
+ EXTRA_DIST = $(GST_TOOL_EXTRA_DIST)
+
+-time_admin_LDADD = $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.a
+-time_admin_DEPENDENCIES = $(GST_TOOL_DEPENDENCIES) ./e-map/libemap.a
++time_admin_LDADD = $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.la
++time_admin_DEPENDENCIES = $(GST_TOOL_DEPENDENCIES) ./e-map/libemap.la
+ time_admin_SOURCES = \
+ time-tool.c time-tool.h \
+ tz.c tz.h \
+diff --git a/src/time/e-map/Makefile.am b/src/time/e-map/Makefile.am
+index 5828690..9d04963 100644
+--- a/src/time/e-map/Makefile.am
++++ b/src/time/e-map/Makefile.am
+@@ -20,13 +20,13 @@ e-map-marshal.c: e-map-marshal.list e-map-marshal.h
+
+ $(e_map_la_OBJECTS): e-map-marshal.h
+
+-noinst_LIBRARIES = libemap.a
++noinst_LTLIBRARIES = libemap.la
+
+-#libemap_a_CFLAGS =
++#libemap_la_CFLAGS =
+
+ BUILT_SOURCES= e-map-marshal.c e-map-marshal.h
+
+-libemap_a_SOURCES = \
++libemap_la_SOURCES = \
+ e-map.c e-map.h \
+ $(BUILT_SOURCES)
+
+--
+1.7.8.5
+
diff --git a/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-atk.patch b/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-atk.patch
new file mode 100644
index 000000000000..6d09fb43ad3b
--- /dev/null
+++ b/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-atk.patch
@@ -0,0 +1,24 @@
+From c0ca954710f83a9204ea01c2d6db717b728d0313 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <gilles.dartiguelongue@esiee.org>
+Date: Sat, 10 Mar 2012 16:00:12 +0100
+Subject: [PATCH 2/3] Add missing dependency for e-map intermediate library
+
+---
+ configure.in | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 2d60648..3a7d1a6 100644
+--- a/configure.in
++++ b/configure.in
+@@ -79,6 +79,7 @@ dnl =====================================================
+
+ PKG_CHECK_MODULES(GST_DEPENDS,[
+ gtk+-2.0 >= $GTK_REQUIRED
++ atk
+ gmodule-export-2.0
+ gio-2.0 >= $GLIB_REQUIRED
+ pango
+--
+1.7.8.5
+
diff --git a/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-m.patch b/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-m.patch
new file mode 100644
index 000000000000..c6bff375c9b1
--- /dev/null
+++ b/app-admin/gnome-system-tools/files/gnome-system-tools-2.32.0-missing-m.patch
@@ -0,0 +1,28 @@
+From d6cc84d452e4a7a194578eceb24eaf6e183e01d4 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <gilles.dartiguelongue@esiee.org>
+Date: Sun, 11 Mar 2012 14:52:40 +0100
+Subject: [PATCH 3/3] Add missing link to libm
+
+This used to cause problems for gold linker while libemap was a static
+library. Now libtool is smart enough to pick libm from the intermediate
+library but it is still better to be explicit.
+---
+ src/time/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/time/Makefile.am b/src/time/Makefile.am
+index 6ff332f..02c12db 100644
+--- a/src/time/Makefile.am
++++ b/src/time/Makefile.am
+@@ -15,7 +15,7 @@ INCLUDES += $(GST_TOOL_CFLAGS) $(DBUS_CFLAGS)
+ CLEANFILES = $(GST_TOOL_CLEANFILES)
+ EXTRA_DIST = $(GST_TOOL_EXTRA_DIST)
+
+-time_admin_LDADD = $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.la
++time_admin_LDADD = -lm $(GST_TOOL_LIBS) $(DBUS_LIBS) ./e-map/libemap.la
+ time_admin_DEPENDENCIES = $(GST_TOOL_DEPENDENCIES) ./e-map/libemap.la
+ time_admin_SOURCES = \
+ time-tool.c time-tool.h \
+--
+1.7.8.5
+
diff --git a/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r3.ebuild b/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r3.ebuild
new file mode 100644
index 000000000000..ebe355af0e92
--- /dev/null
+++ b/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r3.ebuild,v 1.1 2012/03/11 14:16:54 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Tools aimed to make easy the administration of UNIX systems"
+HOMEPAGE="http://www.gnome.org/projects/gst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="nfs policykit samba"
+
+RDEPEND="
+ >=app-admin/system-tools-backends-2.10.1
+ >=dev-libs/liboobs-2.31.91
+ >=x11-libs/gtk+-2.19.7:2
+ >=dev-libs/glib-2.25.3:2
+ dev-libs/dbus-glib
+ >=gnome-base/nautilus-2.9.90
+ sys-libs/cracklib
+ nfs? ( net-fs/nfs-utils )
+ samba? ( >=net-fs/samba-3 )
+ policykit? (
+ >=sys-auth/polkit-0.92
+ || ( gnome-extra/polkit-gnome:obsolete <gnome-extra/polkit-gnome-0.102 )
+ )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+pkg_setup() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable policykit polkit-gtk)"
+
+ if ! use nfs && ! use samba; then
+ G2CONF="${G2CONF} --disable-shares"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libtool-intermediate-libs.patch \
+ "${FILESDIR}"/${P}-missing-atk.patch \
+ "${FILESDIR}"/${P}-missing-m.patch
+ eautoreconf
+ gnome2_src_prepare
+}