summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-01-08 16:22:34 +0000
committerMarinus Schraal <foser@gentoo.org>2005-01-08 16:22:34 +0000
commit84c13ed587923aefea73e43ac834f038617097a3 (patch)
tree15fa7dcafba2023cdc96c0d9425e9d06465af49e /app-admin/gamin/gamin-0.0.20.ebuild
parentremoved src_clean (Manifest recommit) (diff)
downloadgentoo-2-84c13ed587923aefea73e43ac834f038617097a3.tar.gz
gentoo-2-84c13ed587923aefea73e43ac834f038617097a3.tar.bz2
gentoo-2-84c13ed587923aefea73e43ac834f038617097a3.zip
new release
Diffstat (limited to 'app-admin/gamin/gamin-0.0.20.ebuild')
-rw-r--r--app-admin/gamin/gamin-0.0.20.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/gamin/gamin-0.0.20.ebuild b/app-admin/gamin/gamin-0.0.20.ebuild
new file mode 100644
index 000000000000..b2045ed7db3b
--- /dev/null
+++ b/app-admin/gamin/gamin-0.0.20.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.0.20.ebuild,v 1.1 2005/01/08 16:22:33 foser Exp $
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390"
+IUSE="debug"
+
+RDEPEND="virtual/libc
+ >=dev-libs/glib-2
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_compile() {
+
+ econf \
+ --enable-inotify \
+ `use_enable debug` \
+ || die
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS
+
+}