summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-10 23:52:55 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-10 23:52:55 +0000
commit8196af43e5475cdfe4241951e22289b014f71396 (patch)
tree411a4c9b603a582b2966970c0957c2891ae972a3 /app-admin/eselect
parentAdd eurephia patch for bug #272079 (diff)
downloadgentoo-2-8196af43e5475cdfe4241951e22289b014f71396.tar.gz
gentoo-2-8196af43e5475cdfe4241951e22289b014f71396.tar.bz2
gentoo-2-8196af43e5475cdfe4241951e22289b014f71396.zip
Remove test for UID, in order not to suppress an eventual error message.
(Portage version: 2.2_rc44/cvs/Linux i686)
Diffstat (limited to 'app-admin/eselect')
-rw-r--r--app-admin/eselect/eselect-1.2.4.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/app-admin/eselect/eselect-1.2.4.ebuild b/app-admin/eselect/eselect-1.2.4.ebuild
index 6e513ac47b58..20b901eda63e 100644
--- a/app-admin/eselect/eselect-1.2.4.ebuild
+++ b/app-admin/eselect/eselect-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/eselect-1.2.4.ebuild,v 1.2 2009/10/09 15:53:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/eselect-1.2.4.ebuild,v 1.3 2009/10/10 23:52:55 ulm Exp $
DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
@@ -56,11 +56,9 @@ src_install() {
pkg_postinst() {
# fowners in src_install doesn't work for the portage group:
# merging changes the group back to root
- if [[ ${UID} == 0 ]] ; then
- [[ -z ${EROOT} ]] && local EROOT=${ROOT}
- chgrp portage "${EROOT}/var/lib/gentoo/news" \
- && chmod g+w "${EROOT}/var/lib/gentoo/news"
- fi
+ [[ -z ${EROOT} ]] && local EROOT=${ROOT}
+ chgrp portage "${EROOT}/var/lib/gentoo/news" \
+ && chmod g+w "${EROOT}/var/lib/gentoo/news"
if use bash-completion ; then
elog "In case you have not yet enabled command-line completion"