summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-07-27 11:06:13 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-07-27 11:06:13 +0000
commitb4f36b5dc0fe5f84207c4f983cedfa69dc52b461 (patch)
tree208e84a5636ba8beacfcce932f0ac119d9020111 /app-admin/eselect-php
parentRevbump providing preliminary systemd support (diff)
downloadgentoo-2-b4f36b5dc0fe5f84207c4f983cedfa69dc52b461.tar.gz
gentoo-2-b4f36b5dc0fe5f84207c4f983cedfa69dc52b461.tar.bz2
gentoo-2-b4f36b5dc0fe5f84207c4f983cedfa69dc52b461.zip
Removed unused files
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'app-admin/eselect-php')
-rw-r--r--app-admin/eselect-php/eselect-php-0.6.2.ebuild24
-rwxr-xr-xapp-admin/eselect-php/files/php-fpm49
2 files changed, 0 insertions, 73 deletions
diff --git a/app-admin/eselect-php/eselect-php-0.6.2.ebuild b/app-admin/eselect-php/eselect-php-0.6.2.ebuild
deleted file mode 100644
index 1ff0752ee820..000000000000
--- a/app-admin/eselect-php/eselect-php-0.6.2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-php/eselect-php-0.6.2.ebuild,v 1.8 2011/01/30 15:40:08 armin76 Exp $
-
-EAPI=3
-
-DESCRIPTION="PHP eselect module"
-HOMEPAGE="http://www.gentoo.org"
-SRC_URI="http://olemarkus.org/~olemarkus/gentoo/eselect-php-${PV}.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-DEPEND=">=app-admin/eselect-1.2.4
- !app-admin/php-toolkit"
-RDEPEND="${DEPEND}"
-
-src_install() {
- mv eselect-php-${PV} php.eselect
- insinto /usr/share/eselect/modules/
- doins php.eselect
-}
diff --git a/app-admin/eselect-php/files/php-fpm b/app-admin/eselect-php/files/php-fpm
deleted file mode 100755
index a7cd9bb80f39..000000000000
--- a/app-admin/eselect-php/files/php-fpm
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/sbin/runscript
-
-set_phpvars() {
- PHPSLOT=${SVCNAME#php-fpm-}
- [ ${PHPSLOT} = 'php-fpm' ] && PHPSLOT="$(eselect php show fpm)"
-
- PHP_FPM_CONF="/etc/php/fpm-${PHPSLOT}/php-fpm.conf"
- PHP_FPM_PID="/var/run/php-fpm-${PHPSLOT}.pid"
-
- [ ${PHPSLOT} = 'php-fpm' ] && PHP_FPM_PID="/var/run/php-fpm.pid"
-}
-
-extra_commands="depend"
-extra_started_commands="reload"
-
-depend() {
- need net
- use apache2 lighttpd nginx
-}
-
-start() {
- ebegin "Starting PHP FastCGI Process Manager"
- set_phpvars
- start-stop-daemon --start --pidfile ${PHP_FPM_PID} --exec \
- /usr/lib/${PHPSLOT}/bin/php-fpm -- -y "${PHP_FPM_CONF}" -g "${PHP_FPM_PID}"
- local i=0
- local timeout=5
- while [ ! -f ${PHP_FPM_PID} ] && [ $i -le $timeout ]; do
- sleep 1
- i=$(($i + 1))
- done
-
- [ $timeout -gt $i ]
- eend $?
-}
-
-stop() {
- ebegin "Stopping PHP FastCGI Process Manager"
- set_phpvars
- start-stop-daemon --signal QUIT --stop --exec /usr/lib/${PHPSLOT}/bin/php-fpm --pidfile ${PHP_FPM_PID}
- eend $?
-}
-
-reload() {
- ebegin "Reloading PHP FastCGI Process Manager"
- set_phpvars
- [ -f ${PHP_FPM_PID} ] && kill -USR2 $(cat ${PHP_FPM_PID})
- eend $?
-}