summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2012-03-02 16:10:31 +0000
committerLuca Barbato <lu_zero@gentoo.org>2012-03-02 16:10:31 +0000
commit64b4b5ea1f9211216d72d6c2ebfa9660ef59c577 (patch)
tree1d48ac1f0a26489796c52f82803f3deda8cccd98 /app-admin/eselect-opengl
parentAdd version 0.72.2 (diff)
downloadgentoo-2-64b4b5ea1f9211216d72d6c2ebfa9660ef59c577.tar.gz
gentoo-2-64b4b5ea1f9211216d72d6c2ebfa9660ef59c577.tar.bz2
gentoo-2-64b4b5ea1f9211216d72d6c2ebfa9660ef59c577.zip
Support GLES as well, fix bug #406501
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/eselect-opengl')
-rw-r--r--app-admin/eselect-opengl/ChangeLog9
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.2.5.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/app-admin/eselect-opengl/ChangeLog b/app-admin/eselect-opengl/ChangeLog
index 1b63ba44e508..e8aa05e988bf 100644
--- a/app-admin/eselect-opengl/ChangeLog
+++ b/app-admin/eselect-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/eselect-opengl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.90 2011/10/03 17:45:54 josejx Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.91 2012/03/02 16:10:31 lu_zero Exp $
+
+*eselect-opengl-1.2.5 (02 Mar 2012)
+
+ 02 Mar 2012; Luca Barbato <lu_zero@gentoo.org> +eselect-opengl-1.2.5.ebuild:
+ Support GLES as well, fix bug #406501
03 Oct 2011; Joseph Jezak <josejx@gentoo.org> eselect-opengl-1.2.4.ebuild:
Marked ppc/ppc64 stable for bug #380421.
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.2.5.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.2.5.ebuild
new file mode 100644
index 000000000000..1a2be259d9ec
--- /dev/null
+++ b/app-admin/eselect-opengl/eselect-opengl-1.2.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.2.5.ebuild,v 1.1 2012/03/02 16:10:31 lu_zero Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Utility to change the OpenGL interface being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+# Source:
+# http://www.opengl.org/registry/api/glext.h
+# http://www.opengl.org/registry/api/glxext.h
+GLEXT="67"
+GLXEXT="32"
+
+MIRROR="http://dev.gentooexperimental.org/~scarabeus/"
+SRC_URI="${MIRROR}/glext.h.${GLEXT}.xz
+ ${MIRROR}/glxext.h.${GLXEXT}.xz
+ http://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-admin/eselect-1.2.4"
+
+pkg_postinst() {
+ local impl="$(eselect opengl show)"
+ if [[ -n "${impl}" && "${impl}" != '(none)' ]] ; then
+ eselect opengl set "${impl}"
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/eselect/modules"
+ doins opengl.eselect
+ doman opengl.eselect.5
+
+ # Install global glext.h and glxext.h
+ insinto "/usr/$(get_libdir)/opengl/global/include"
+ cd "${WORKDIR}"
+ newins glext.h.${GLEXT} glext.h
+ newins glxext.h.${GLXEXT} glxext.h
+}