summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-04 02:45:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-04 02:45:07 +0000
commit2b0c3fa47dfb4a4220eabbc90c480a2704322339 (patch)
tree6e517619adb44a287d6ff2f445e22c7459455e78 /app-admin/eselect-opencl
parentMask jemalloc on dev-db/mysql and dev-db/mariadb bug #429708 (diff)
downloadgentoo-2-2b0c3fa47dfb4a4220eabbc90c480a2704322339.tar.gz
gentoo-2-2b0c3fa47dfb4a4220eabbc90c480a2704322339.tar.bz2
gentoo-2-2b0c3fa47dfb4a4220eabbc90c480a2704322339.zip
Bump of OpenCL headers for #496418, not keyworded as it may need more testing
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin/eselect-opencl')
-rw-r--r--app-admin/eselect-opencl/ChangeLog8
-rw-r--r--app-admin/eselect-opencl/eselect-opencl-1.1.0-r2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/app-admin/eselect-opencl/ChangeLog b/app-admin/eselect-opencl/ChangeLog
index 54f6afaec99f..e6bff961f383 100644
--- a/app-admin/eselect-opencl/ChangeLog
+++ b/app-admin/eselect-opencl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-opencl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opencl/ChangeLog,v 1.8 2014/03/24 16:15:09 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opencl/ChangeLog,v 1.9 2014/06/04 02:45:07 patrick Exp $
+
+*eselect-opencl-1.1.0-r2 (04 Jun 2014)
+
+ 04 Jun 2014; Patrick Lauer <patrick@gentoo.org>
+ +eselect-opencl-1.1.0-r2.ebuild:
+ Bump of OpenCL headers for #496418, not keyworded as it may need more testing
24 Mar 2014; Kacper Kowalik <xarthisius@gentoo.org> metadata.xml:
Drop maintainership
diff --git a/app-admin/eselect-opencl/eselect-opencl-1.1.0-r2.ebuild b/app-admin/eselect-opencl/eselect-opencl-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..fe5573a048f6
--- /dev/null
+++ b/app-admin/eselect-opencl/eselect-opencl-1.1.0-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opencl/eselect-opencl-1.1.0-r2.ebuild,v 1.1 2014/06/04 02:45:07 patrick Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Utility to change the OpenCL implementation being used"
+HOMEPAGE="http://www.gentoo.org/"
+
+# Source:
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/opencl.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_platform.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_ext.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_gl.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl_gl_ext.h
+# http://www.khronos.org/registry/cl/api/${CL_ABI}/cl.hpp
+
+# Using copy by Mario Kicherer #496418
+
+#MIRROR="http://dev.gentoo.org/~xarthisius/distfiles/"
+SRC_URI="https://github.com/anyc/opencl-headers/archive/opencl-headers-1.2.tar.gz
+ http://dev.gentoo.org/~xarthisius/distfiles/${P}-r1.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="" # for testing
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-admin/eselect-1.2.4"
+
+pkg_postinst() {
+ local impl="$(eselect opencl show)"
+ if [[ -n "${impl}" && "${impl}" != '(none)' ]] ; then
+ eselect opencl set "${impl}"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins opencl.eselect
+ #doman opencl.eselect.5
+
+ local headers=( opencl.h cl_platform.h cl.h cl_ext.h cl_gl.h cl_gl_ext.h cl.hpp )
+
+ # We install all versions of OpenCL headers
+ cd "${WORKDIR}/opencl-headers-opencl-headers-1.2"
+ for CL_ABI in 1.0 1.1 1.2; do
+ mkdir -p "${D}/usr/$(get_libdir)/OpenCL/global/include/CL-${CL_ABI}"
+ for f in ${headers[@]}; do
+ cp OpenCL-${CL_ABI}/${f} "${D}/usr/$(get_libdir)/OpenCL/global/include/CL-${CL_ABI}/${f}"
+ done
+ done
+ # Create symlinks to newest. Maybe this should be switchable?
+ for f in ${headers[@]}; do
+ dosym "${D}/usr/$(get_libdir)/OpenCL/global/include/CL-1.2/${f}" "/usr/$(get_libdir)/OpenCL/global/include/CL/${f}"
+ done
+}