summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-03-23 14:18:21 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-03-23 14:18:21 +0000
commit9daf6c61928863617b167792168d82aa74da67fa (patch)
treea440fea8459f7545fd0487e9957636af8967ff85 /app-admin/equo
parentversion bump (diff)
downloadgentoo-2-9daf6c61928863617b167792168d82aa74da67fa.tar.gz
gentoo-2-9daf6c61928863617b167792168d82aa74da67fa.tar.bz2
gentoo-2-9daf6c61928863617b167792168d82aa74da67fa.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-1.0_rc90.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index 55b4466d7c88..cab2404e25a0 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.18 2012/02/12 07:24:16 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.19 2012/03/23 14:18:21 lxnay Exp $
+
+*equo-1.0_rc90 (23 Mar 2012)
+
+ 23 Mar 2012; Fabio Erculiani <lxnay@gentoo.org> +equo-1.0_rc90.ebuild:
+ version bump
*equo-1.0_rc87 (12 Feb 2012)
diff --git a/app-admin/equo/equo-1.0_rc90.ebuild b/app-admin/equo/equo-1.0_rc90.ebuild
new file mode 100644
index 000000000000..01d41a7135be
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc90.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc90.ebuild,v 1.1 2012/03/23 14:18:21 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}