summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-04-26 21:06:55 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-04-26 21:06:55 +0000
commitf947852a58aa51ac7daad1c17dbf26b16276795a (patch)
treee3b02c708bbda5e3f347021134ff585d11ba4fb0 /app-admin/ec2-api-tools
parentBump. (diff)
downloadgentoo-2-f947852a58aa51ac7daad1c17dbf26b16276795a.tar.gz
gentoo-2-f947852a58aa51ac7daad1c17dbf26b16276795a.tar.bz2
gentoo-2-f947852a58aa51ac7daad1c17dbf26b16276795a.zip
Version bump to 1.6.7.2. Reported by Cleveland Flowe. Fixes bug #467398.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-admin/ec2-api-tools')
-rw-r--r--app-admin/ec2-api-tools/ChangeLog7
-rw-r--r--app-admin/ec2-api-tools/ec2-api-tools-1.6.7.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-admin/ec2-api-tools/ChangeLog b/app-admin/ec2-api-tools/ChangeLog
index 76e434621c2c..da00d4e7af49 100644
--- a/app-admin/ec2-api-tools/ChangeLog
+++ b/app-admin/ec2-api-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/ec2-api-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.17 2013/04/03 00:59:13 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.18 2013/04/26 21:06:55 tomwij Exp $
+
+*ec2-api-tools-1.6.7.2 (26 Apr 2013)
+
+ 26 Apr 2013; Tom Wijsman <TomWij@gentoo.org> +ec2-api-tools-1.6.7.2.ebuild:
+ Version bump to 1.6.7.2. Reported by Cleveland Flowe. Fixes bug #467398.
*ec2-api-tools-1.6.0.1-r1 (03 Apr 2013)
diff --git a/app-admin/ec2-api-tools/ec2-api-tools-1.6.7.2.ebuild b/app-admin/ec2-api-tools/ec2-api-tools-1.6.7.2.ebuild
new file mode 100644
index 000000000000..6e5e5c5f8b9b
--- /dev/null
+++ b/app-admin/ec2-api-tools/ec2-api-tools-1.6.7.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ec2-api-tools-1.6.7.2.ebuild,v 1.1 2013/04/26 21:06:55 tomwij Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service"
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=351&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${PV}.zip"
+
+S=${WORKDIR}/${PN}-${PV}
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror"
+
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+
+src_prepare() {
+ find . -name '*.cmd' -delete || die "Failed to remove redundant cmd files."
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/*
+
+ insinto /usr/lib
+ doins lib/*.jar
+
+ dodir /etc/env.d
+ echo "EC2_HOME=/usr" > "${T}"/99${PN} || die "Failed to write configuration variable."
+ doenvd "${T}"/99${PN}
+
+ dodoc THIRDPARTYLICENSE.TXT
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog ""
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full paths to your key and certificate."
+ elog ""
+ elog " export EC2_PRIVATE_KEY=/path/to/pk-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+ elog " export EC2_CERT=/path/to/cert-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+}