summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 13:34:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 13:34:26 +0000
commitbdf4dd2d8175c53ff8c09ddf17047d595109ecb6 (patch)
tree4762d5cbe8d56be14be54f29bae4e24958064b0e /app-admin/ec2-api-tools
parentBump to 3.1.2 (diff)
downloadgentoo-2-bdf4dd2d8175c53ff8c09ddf17047d595109ecb6.tar.gz
gentoo-2-bdf4dd2d8175c53ff8c09ddf17047d595109ecb6.tar.bz2
gentoo-2-bdf4dd2d8175c53ff8c09ddf17047d595109ecb6.zip
Version bump, also don't use version for the install path and don't use symlinks to /usr/bin. This means that you won't need to re-source the profile at each upgrade, but just after the first install. And it won't pollute your inode space.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/ec2-api-tools')
-rw-r--r--app-admin/ec2-api-tools/ChangeLog13
-rw-r--r--app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild57
2 files changed, 68 insertions, 2 deletions
diff --git a/app-admin/ec2-api-tools/ChangeLog b/app-admin/ec2-api-tools/ChangeLog
index 66f271e48ca3..82ad6d2ed7a0 100644
--- a/app-admin/ec2-api-tools/ChangeLog
+++ b/app-admin/ec2-api-tools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-admin/ec2-api-tools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.3 2009/09/27 12:36:32 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ChangeLog,v 1.4 2010/01/28 13:34:26 flameeyes Exp $
+
+*ec2-api-tools-1.3.46266 (28 Jan 2010)
+
+ 28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ec2-api-tools-1.3.46266.ebuild:
+ Version bump, also don't use version for the install path and don't use
+ symlinks to /usr/bin. This means that you won't need to re-source the
+ profile at each upgrade, but just after the first install. And it won't
+ pollute your inode space.
27 Sep 2009; Markus Meier <maekke@gentoo.org>
ec2-api-tools-1.3.36506.ebuild:
diff --git a/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild b/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild
new file mode 100644
index 000000000000..9c4464105cce
--- /dev/null
+++ b/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-api-tools/ec2-api-tools-1.3.46266.ebuild,v 1.1 2010/01/28 13:34:26 flameeyes Exp $
+
+inherit versionator
+
+EC2_VERSION=$(get_version_component_range 1-2)
+EC2_PATCHLEVEL=$(get_version_component_range 3)
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service."
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=351&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}.zip"
+
+S=${WORKDIR}/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}"
+ find . -name *.cmd -exec rm {} \;
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+EC2_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc THIRDPARTYLICENSE.TXT
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog ""
+ elog ""
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full paths to your key and certificate."
+ elog " "
+ elog " export EC2_PRIVATE_KEY=/path/to/pk-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+ elog " export EC2_CERT=/path/to/cert-HKZYKTAIG2ECMXYIBH3HXV4ZBZQ55CLO.pem"
+}