summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2006-07-11 15:52:03 +0000
committerBenjamin Smee <strerror@gentoo.org>2006-07-11 15:52:03 +0000
commitaa4a102a079dceaaae180c178e861ed61fad5d87 (patch)
tree768de5651c0801e76da7e570a2a5a02af017409d /app-admin/denyhosts
parentCleanup and DESCRIPTION change (diff)
downloadgentoo-2-aa4a102a079dceaaae180c178e861ed61fad5d87.tar.gz
gentoo-2-aa4a102a079dceaaae180c178e861ed61fad5d87.tar.bz2
gentoo-2-aa4a102a079dceaaae180c178e861ed61fad5d87.zip
Version bump
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'app-admin/denyhosts')
-rw-r--r--app-admin/denyhosts/ChangeLog8
-rw-r--r--app-admin/denyhosts/denyhosts-2.5.ebuild65
-rw-r--r--app-admin/denyhosts/files/denyhosts-2.5-gentoo.patch52
-rw-r--r--app-admin/denyhosts/files/digest-denyhosts-2.53
4 files changed, 127 insertions, 1 deletions
diff --git a/app-admin/denyhosts/ChangeLog b/app-admin/denyhosts/ChangeLog
index 0c9702a0a90c..f142ece0768d 100644
--- a/app-admin/denyhosts/ChangeLog
+++ b/app-admin/denyhosts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/denyhosts
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.12 2006/05/28 12:01:13 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.13 2006/07/11 15:52:03 strerror Exp $
+
+*denyhosts-2.5 (11 Jul 2006)
+
+ 11 Jul 2006; Benjamin Smee <strerror@gentoo.org>
+ +files/denyhosts-2.5-gentoo.patch, +denyhosts-2.5.ebuild:
+ Version bump
28 May 2006; Benjamin Smee <strerror@gentoo.org>
files/denyhosts-2.4b-gentoo.patch:
diff --git a/app-admin/denyhosts/denyhosts-2.5.ebuild b/app-admin/denyhosts/denyhosts-2.5.ebuild
new file mode 100644
index 000000000000..f8468884def4
--- /dev/null
+++ b/app-admin/denyhosts/denyhosts-2.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/denyhosts-2.5.ebuild,v 1.1 2006/07/11 15:52:03 strerror Exp $
+
+inherit distutils eutils
+
+my_PN="DenyHosts"
+my_P="${my_PN}-${PV}"
+DESCRIPTION="DenyHosts is a utility to help sys admins thwart ssh hackers"
+HOMEPAGE="http://www.denyhosts.net"
+SRC_URI="mirror://sourceforge/${PN}/${my_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3"
+S="${WORKDIR}/${my_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # changes default file installations
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e 's:#!/usr/bin/env python:#!/usr/bin/python:' \
+ denyhosts.py || die "sed failed"
+ sed -i -e 's:DENY_THRESHOLD_VALID = 10:DENY_THRESHOLD_VALID = 5:' \
+ denyhosts.cfg-dist || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc
+ insopts -m0640
+ newins denyhosts.cfg-dist denyhosts.conf
+
+ newinitd "${FILESDIR}"/denyhosts.init denyhosts
+
+ exeinto /usr/bin
+ newexe denyhosts.py denyhosts
+
+ dodoc CHANGELOG.txt README.txt
+
+ keepdir /var/lib/denyhosts
+}
+
+pkg_postinst() {
+ if [ ! -f /etc/hosts.deny ]
+ then
+ touch /etc/hosts.deny
+ fi
+
+ einfo "You can configure DenyHosts to run as a daemon by running:"
+ einfo
+ einfo "rc-update add denyhosts default"
+ einfo
+ einfo "or as a cronjob, by adding the following to /etc/crontab"
+ einfo "# run DenyHosts every 10 minutes"
+ einfo "*/10 * * * * root python /usr/bin/denyhosts -c /etc/denyhosts.conf"
+ einfo
+ einfo "More information can be found at http://denyhosts.sourceforge.net/faq.html"
+ einfo
+ ewarn "Modify /etc/denyhosts.conf to suit your environment system."
+}
+
diff --git a/app-admin/denyhosts/files/denyhosts-2.5-gentoo.patch b/app-admin/denyhosts/files/denyhosts-2.5-gentoo.patch
new file mode 100644
index 000000000000..559c5aef4e15
--- /dev/null
+++ b/app-admin/denyhosts/files/denyhosts-2.5-gentoo.patch
@@ -0,0 +1,52 @@
+--- DenyHosts-2.4/denyhosts.cfg-dist 2006-04-09 13:37:46.000000000 +0000
++++ DenyHosts-2.4-new/denyhosts.cfg-dist 2006-04-19 16:25:57.000000000 +0000
+@@ -9,20 +9,22 @@
+ # argument
+ #
+ # Redhat or Fedora Core:
+-SECURE_LOG = /var/log/secure
++#SECURE_LOG = /var/log/secure
+ #
+ # Mandrake, FreeBSD or OpenBSD:
+ #SECURE_LOG = /var/log/auth.log
+ #
+-# SuSE:
+-#SECURE_LOG = /var/log/messages
++# Gentoo/SuSE:
++SECURE_LOG = /var/log/messages
+ #
++# Metalog:
++#SECURE_LOG = /var/log/sshd/current
+ # Mac OS X (v10.4 or greater -
+ # also refer to: http://www.denyhosts.net/faq.html#macos
+ #SECURE_LOG = /private/var/log/asl.log
+ #
+ # Mac OS X (v10.3 or earlier):
+-SECURE_LOG=/private/var/log/system.log
++#SECURE_LOG=/private/var/log/system.log
+ #
+ ########################################################################
+
+@@ -150,7 +152,7 @@
+ # Note: it is recommended that you use an absolute pathname
+ # for this value (eg. /home/foo/denyhosts/data)
+ #
+-WORK_DIR = /usr/share/denyhosts/data
++WORK_DIR = /var/lib/denyhosts
+ #
+ #######################################################################
+
+@@ -192,10 +194,10 @@
+ # running at a time.
+ #
+ # Redhat/Fedora:
+-LOCK_FILE = /var/lock/subsys/denyhosts
++#LOCK_FILE = /var/lock/subsys/denyhosts
+ #
+-# Debian
+-#LOCK_FILE = /var/run/denyhosts.pid
++# Gentoo/Debian
++LOCK_FILE = /var/run/denyhosts.pid
+ #
+ # Misc
+ #LOCK_FILE = /tmp/denyhosts.lock
diff --git a/app-admin/denyhosts/files/digest-denyhosts-2.5 b/app-admin/denyhosts/files/digest-denyhosts-2.5
new file mode 100644
index 000000000000..514ea2b530aa
--- /dev/null
+++ b/app-admin/denyhosts/files/digest-denyhosts-2.5
@@ -0,0 +1,3 @@
+MD5 b33f0cdae6448ae559c5f22dbffe59f2 DenyHosts-2.5.tar.gz 42612
+RMD160 757d4b231bbf793ce0d1a2605de5a8f6cb87c27a DenyHosts-2.5.tar.gz 42612
+SHA256 1efa1a977d0341bc5c94dbc652f86f3834e12013d7dc19a4f6e7b4b4c0242ed4 DenyHosts-2.5.tar.gz 42612