summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-05-04 02:53:51 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-05-04 02:53:51 +0000
commit0af1a3eda48eec576447689eed870e073412377f (patch)
treeacc0271c00378320b3c4d8f20cd17618856baf64 /app-admin/denyhosts
parentVersion bump to 0.8.8, fixes bug 315851. (diff)
downloadgentoo-2-0af1a3eda48eec576447689eed870e073412377f.tar.gz
gentoo-2-0af1a3eda48eec576447689eed870e073412377f.tar.bz2
gentoo-2-0af1a3eda48eec576447689eed870e073412377f.zip
Revision bump to not install dupicate docs and install log rotate file, bug 274253 by Michael
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/denyhosts')
-rw-r--r--app-admin/denyhosts/ChangeLog11
-rw-r--r--app-admin/denyhosts/denyhosts-2.6-r2.ebuild76
-rw-r--r--app-admin/denyhosts/files/denyhosts.logrotate12
3 files changed, 97 insertions, 2 deletions
diff --git a/app-admin/denyhosts/ChangeLog b/app-admin/denyhosts/ChangeLog
index a1e68d17840f..c0fa59c5b237 100644
--- a/app-admin/denyhosts/ChangeLog
+++ b/app-admin/denyhosts/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/denyhosts
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.37 2009/12/20 04:13:49 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.38 2010/05/04 02:53:50 darkside Exp $
+
+*denyhosts-2.6-r2 (04 May 2010)
+
+ 04 May 2010; Jeremy Olexa <darkside@gentoo.org> +denyhosts-2.6-r2.ebuild,
+ +files/denyhosts.logrotate:
+ Revision bump to not install dupicate docs and install log rotate file,
+ bug 274253 by Michael
20 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
denyhosts-2.6-r1.ebuild:
diff --git a/app-admin/denyhosts/denyhosts-2.6-r2.ebuild b/app-admin/denyhosts/denyhosts-2.6-r2.ebuild
new file mode 100644
index 000000000000..5afa5d8e97c4
--- /dev/null
+++ b/app-admin/denyhosts/denyhosts-2.6-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/denyhosts-2.6-r2.ebuild,v 1.1 2010/05/04 02:53:50 darkside Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_PN="DenyHosts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DenyHosts is a utility to help sys admins thwart ssh hackers"
+HOMEPAGE="http://www.denyhosts.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="${MY_PN}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # changes default file installations
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-log-injection-regex.patch
+ sed -i -e 's:DENY_THRESHOLD_VALID = 10:DENY_THRESHOLD_VALID = 5:' \
+ denyhosts.cfg-dist || die "sed failed"
+}
+
+src_install() {
+ DOCS="CHANGELOG.txt README.txt PKG-INFO"
+ distutils_src_install
+
+ insinto /etc
+ insopts -m0640
+ newins denyhosts.cfg-dist denyhosts.conf || die
+
+ dodir /etc/logrotate.d
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN} || die
+
+ newinitd "${FILESDIR}"/denyhosts.init denyhosts || die
+
+ # build system installs docs that we installed above
+ rm -f "${D}"/usr/share/denyhosts/*.txt
+
+ keepdir /var/lib/denyhosts
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ if [[ ! -f "${ROOT}etc/hosts.deny" ]]; then
+ touch "${ROOT}etc/hosts.deny"
+ fi
+
+ elog "You can configure DenyHosts to run as a daemon by running:"
+ elog
+ elog "rc-update add denyhosts default"
+ elog
+ elog "or as a cronjob, by adding the following to /etc/crontab"
+ elog "# run DenyHosts every 10 minutes"
+ elog "*/10 * * * * root /usr/bin/denyhosts.py -c /etc/denyhosts.conf"
+ elog
+ elog "More information can be found at http://denyhosts.sourceforge.net/faq.html"
+ elog
+ ewarn "Modify /etc/denyhosts.conf to suit your environment system."
+}
diff --git a/app-admin/denyhosts/files/denyhosts.logrotate b/app-admin/denyhosts/files/denyhosts.logrotate
new file mode 100644
index 000000000000..4f1249d0125c
--- /dev/null
+++ b/app-admin/denyhosts/files/denyhosts.logrotate
@@ -0,0 +1,12 @@
+/var/log/denyhosts {
+ missingok
+ notifempty
+ create 0640 root root
+ sharedscripts
+ prerotate
+ /etc/init.d/denyhosts stop
+ endscript
+ postrotate
+ /etc/init.d/denyhosts start
+ endscript
+}