summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-04-07 19:05:02 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-04-07 19:05:02 +0000
commit6ea50c20d9e6c721877373384c3c50cb27396ffa (patch)
treed9ace9edf44b09087fda299eda726c6b2f31afe2 /app-admin/conky
parentMarking libcanberra-0.22 ppc for bug 305931 (diff)
downloadgentoo-2-6ea50c20d9e6c721877373384c3c50cb27396ffa.tar.gz
gentoo-2-6ea50c20d9e6c721877373384c3c50cb27396ffa.tar.bz2
gentoo-2-6ea50c20d9e6c721877373384c3c50cb27396ffa.zip
Fix building with ncurses disabled thanks to all involved in bug #313081. Remove old version and unused files.
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog9
-rw-r--r--app-admin/conky/conky-1.6.1.ebuild134
-rw-r--r--app-admin/conky/conky-1.8.0.ebuild6
-rw-r--r--app-admin/conky/files/conky-1.6.1-stdio.patch12
-rw-r--r--app-admin/conky/files/conky-1.7.1.1-comment.patch11
-rw-r--r--app-admin/conky/files/conky-1.8.0-ncurses.patch129
-rw-r--r--app-admin/conky/files/conky_no_x11.conf53
-rw-r--r--app-admin/conky/metadata.xml2
8 files changed, 142 insertions, 214 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index 3714c493819c..545522961f1e 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.131 2010/03/30 19:04:29 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.132 2010/04/07 19:05:02 billie Exp $
+
+ 07 Apr 2010; Daniel Pielmeier <billie@gentoo.org>
+ -files/conky-1.6.1-stdio.patch, -files/conky_no_x11.conf,
+ -conky-1.6.1.ebuild, -files/conky-1.7.1.1-comment.patch,
+ conky-1.8.0.ebuild, +files/conky-1.8.0-ncurses.patch, metadata.xml:
+ Fix building with ncurses disabled thanks to all involved in bug #313081.
+ Remove old version and unused files.
*conky-1.8.0 (30 Mar 2010)
diff --git a/app-admin/conky/conky-1.6.1.ebuild b/app-admin/conky/conky-1.6.1.ebuild
deleted file mode 100644
index df0a0dd0690d..000000000000
--- a/app-admin/conky/conky-1.6.1.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.6.1.ebuild,v 1.15 2010/01/25 18:14:23 billie Exp $
-
-EAPI="2"
-
-inherit eutils
-# used for epause
-
-DESCRIPTION="An advanced, highly configurable system monitor for X"
-HOMEPAGE="http://conky.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
-IUSE="audacious debug hddtemp ipv6 mpd nano-syntax nvidia rss truetype vim-syntax smapi wifi X"
-
-DEPEND_COMMON="
- X? (
- x11-libs/libICE
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libSM
- x11-libs/libXrender
- x11-libs/libXdamage
- x11-libs/libXft
- truetype? ( >=media-libs/freetype-2 )
- audacious? (
- || (
- >=media-sound/audacious-1.5
- =media-sound/audacious-1.4*[dbus]
- )
- )
- )
- rss? ( dev-libs/libxml2
- net-misc/curl
- )
- wifi? ( net-wireless/wireless-tools )
- nvidia? ( media-video/nvidia-settings )
- !ipv6? ( >=dev-libs/glib-2.0 )"
-RDEPEND="${DEPEND_COMMON}
- hddtemp? ( app-admin/hddtemp )
- vim-syntax? ( || ( app-editors/vim
- app-editors/gvim ) )
- nano-syntax? ( app-editors/nano )"
-DEPEND="
- ${DEPEND_COMMON}
- dev-util/pkgconfig
- X? (
- x11-libs/libXt
- x11-proto/xextproto
- x11-proto/xproto
- )"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-stdio.patch"
-}
-
-src_configure() {
- local myconf
- myconf="--enable-proc-uptime"
- if useq X; then
- myconf="${myconf} --enable-x11 --enable-double-buffer --enable-xdamage --enable-own-window"
- myconf="${myconf} $(use_enable truetype xft)"
- else
- myconf="${myconf} --disable-x11 --disable-double-buffer --disable-xdamage --disable-own-window"
- myconf="${myconf} --disable-xft"
- fi
- econf \
- ${myconf} \
- $(use_enable audacious) \
- --disable-bmpx \
- $(use_enable debug) \
- $(use_enable hddtemp ) \
- $(use_enable mpd) \
- $(use_enable nvidia) \
- $(use_enable rss) \
- $(use_enable smapi) \
- $(use_enable wifi wlan) \
- $(use_enable !ipv6 portmon) || die "econf failed"
-}
-
-src_compile() {
- local mymake
- if useq ipv6 ; then
- ewarn "You have the ipv6 USE flag enabled. Please note that using"
- ewarn "the ipv6 USE flag with Conky disables the port monitor."
- epause
- else
- mymake="MPD_NO_IPV6=noipv6"
- fi
-
- emake ${mymake} || die "compile failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog AUTHORS README || die
- dohtml doc/docs.html doc/config_settings.html doc/variables.html || die
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${S}"/extras/vim/ftdetect/conkyrc.vim
-
- insinto /usr/share/vim/vimfiles/syntax
- doins "${S}"/extras/vim/syntax/conkyrc.vim
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano/
- doins "${S}"/extras/nano/conky.nanorc
- fi
-}
-
-pkg_postinst() {
- elog "You can find the sample configuration file at"
- elog "/etc/conky/conky.conf. To customize it, copy"
- elog "/etc/conky/conky.conf to ~/.conkyrc and edit"
- elog "it to your liking."
- elog
- elog "For more info on Conky's new features,"
- elog "please look at the README and ChangeLog:"
- elog "/usr/share/doc/${PF}/README.bz2"
- elog "/usr/share/doc/${PF}/ChangeLog.bz2"
- elog "There are also pretty html docs available"
- elog "on Conky's site or in /usr/share/doc/${PF}"
- elog
- elog "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
- elog
- elog "Vim syntax highlighting for conkyrc now enabled with"
- elog "USE=vim-syntax, for Nano with USE=nano-syntax"
- elog
-}
diff --git a/app-admin/conky/conky-1.8.0.ebuild b/app-admin/conky/conky-1.8.0.ebuild
index bcca4a4b8820..77041c91bcc0 100644
--- a/app-admin/conky/conky-1.8.0.ebuild
+++ b/app-admin/conky/conky-1.8.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.0.ebuild,v 1.1 2010/03/30 19:04:29 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.0.ebuild,v 1.2 2010/04/07 19:05:02 billie Exp $
EAPI="2"
+inherit base
+
DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="http://conky.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -49,6 +51,8 @@ DEPEND="
dev-util/pkgconfig
"
+PATCHES=( "${FILESDIR}/conky-1.8.0-ncurses.patch" )
+
src_configure() {
local myconf
if use X; then
diff --git a/app-admin/conky/files/conky-1.6.1-stdio.patch b/app-admin/conky/files/conky-1.6.1-stdio.patch
deleted file mode 100644
index 3b0d2820dea5..000000000000
--- a/app-admin/conky/files/conky-1.6.1-stdio.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: src/conky.h
-===================================================================
---- src/conky.h (revision 1237)
-+++ src/conky.h (working copy)
-@@ -43,6 +43,7 @@
-
- #include "config.h"
- #include <sys/utsname.h>
-+#include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
- #include <locale.h>
diff --git a/app-admin/conky/files/conky-1.7.1.1-comment.patch b/app-admin/conky/files/conky-1.7.1.1-comment.patch
deleted file mode 100644
index ef206cac06f8..000000000000
--- a/app-admin/conky/files/conky-1.7.1.1-comment.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/conky.c.old 2009-07-19 22:27:18.514288448 +0300
-+++ src/conky.c 2009-07-19 23:12:27.905568398 +0300
-@@ -3264,6 +3264,8 @@
- append_object(retval, obj);
- }
- }
-+ } else if (*p == '\\' && *(p+1) == '#') {
-+ strfold(p, 1);
- } else if (*p == '#') {
- remove_comment(p);
- }
diff --git a/app-admin/conky/files/conky-1.8.0-ncurses.patch b/app-admin/conky/files/conky-1.8.0-ncurses.patch
new file mode 100644
index 000000000000..3340faf9936b
--- /dev/null
+++ b/app-admin/conky/files/conky-1.8.0-ncurses.patch
@@ -0,0 +1,129 @@
+From: Brenden Matthews <brenden@diddyinc.com>
+Date: Wed, 7 Apr 2010 16:34:33 +0000 (-0700)
+Subject: Fix build failure with ncurses disabled.
+X-Git-Url: http://git.omp.am/?p=conky.git;a=commitdiff_plain;h=c8e687406502be8c6f4e75b077113591823405f0
+
+Fix build failure with ncurses disabled.
+
+Ref: http://bugs.gentoo.org/show_bug.cgi?id=313081
+---
+
+diff --git a/configure.ac.in b/configure.ac.in
+index ebef3f8..5cda4b8 100644
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -1011,6 +1011,7 @@ dnl OpenMP: $want_openmp
+ ALSA mixer: $want_alsa
+ apcupsd: $want_apcupsd
+ I/O stats: $want_iostats
++ ncurses: $want_ncurses
+
+ * Lua ($want_lua) bindings:
+ Cairo: $want_lua_cairo
+diff --git a/src/conky.c b/src/conky.c
+index 500261b..7e61f51 100644
+--- a/src/conky.c
++++ b/src/conky.c
+@@ -3119,36 +3119,49 @@ int draw_each_line_inner(char *s, int special_index, int last_special_applied)
+ if (seconds != 0) {
+ timeunits = seconds / 86400; seconds %= 86400;
+ if (timeunits > 0) {
+- asprintf(&tmp_day_str, "%dd", timeunits);
++ if (asprintf(&tmp_day_str, "%dd", timeunits) < 0) {
++ tmp_day_str = 0;
++ }
+ } else {
+ tmp_day_str = strdup("");
+ }
+ timeunits = seconds / 3600; seconds %= 3600;
+ if (timeunits > 0) {
+- asprintf(&tmp_hour_str, "%dh", timeunits);
++ if (asprintf(&tmp_hour_str, "%dh", timeunits) < 0) {
++ tmp_day_str = 0;
++ }
+ } else {
+ tmp_hour_str = strdup("");
+ }
+ timeunits = seconds / 60; seconds %= 60;
+ if (timeunits > 0) {
+- asprintf(&tmp_min_str, "%dm", timeunits);
++ if (asprintf(&tmp_min_str, "%dm", timeunits) < 0) {
++ tmp_min_str = 0;
++ }
+ } else {
+ tmp_min_str = strdup("");
+ }
+ if (seconds > 0) {
+- asprintf(&tmp_sec_str, "%ds", seconds);
++ if (asprintf(&tmp_sec_str, "%ds", seconds) < 0) {
++ tmp_sec_str = 0;
++ }
+ } else {
+ tmp_sec_str = strdup("");
+ }
+- asprintf(&tmp_str, "%s%s%s%s", tmp_day_str, tmp_hour_str, tmp_min_str, tmp_sec_str);
+- free(tmp_day_str); free(tmp_hour_str); free(tmp_min_str); free(tmp_sec_str);
++ if (asprintf(&tmp_str, "%s%s%s%s", tmp_day_str,
++ tmp_hour_str, tmp_min_str, tmp_sec_str) < 0) {
++ tmp_str = 0;
++ }
++#define FREE(a) if ((a)) free((a));
++ FREE(tmp_day_str); FREE(tmp_hour_str); FREE(tmp_min_str); FREE(tmp_sec_str);
+ } else {
+- asprintf(&tmp_str, "Range not possible"); // should never happen, but better safe then sorry
++ tmp_str = strdup("Range not possible"); /* should never happen, but better safe then sorry */
+ }
+ cur_x += (w / 2) - (font_ascent() * (strlen(tmp_str) / 2));
+ cur_y += font_h / 2;
+ draw_string(tmp_str);
+- free(tmp_str);
++ FREE(tmp_str);
++#undef FREE
+ cur_x = tmp_x;
+ cur_y = tmp_y;
+ }
+@@ -4518,13 +4531,13 @@ void setalignment(int* ltext_alignment, unsigned int windowtype, const char* val
+ int a = string_to_alignment(value);
+
+ if (a <= 0) {
+- if(setbyconffile == true) {
++ if (setbyconffile) {
+ CONF_ERR;
+ } else NORM_ERR("'%s' is not a alignment setting", value);
+ } else {
+ *ltext_alignment = a;
+ }
+- } else if(setbyconffile == true) {
++ } else if (setbyconffile) {
+ CONF_ERR;
+ }
+ }
+@@ -4573,7 +4586,7 @@ char load_config_file(const char *f)
+ }
+ }
+ CONF("alignment") {
+- setalignment(&text_alignment, window.type, value, f, line, true);
++ setalignment(&text_alignment, window.type, value, f, line, 1);
+ }
+ CONF("background") {
+ fork_to_background = string_to_bool(value);
+@@ -5696,7 +5709,7 @@ void initialisation(int argc, char **argv) {
+ set_first_font(optarg);
+ break;
+ case 'a':
+- setalignment(&text_alignment, window.type, optarg, NULL, 0, false);
++ setalignment(&text_alignment, window.type, optarg, NULL, 0, 0);
+ break;
+
+ #ifdef OWN_WINDOW
+@@ -5895,7 +5908,9 @@ int main(int argc, char **argv)
+ current_config = strndup(optarg, max_user_text);
+ break;
+ case 'q':
+- freopen("/dev/null", "w", stderr);
++ if (!freopen("/dev/null", "w", stderr)) {
++ NORM_ERR("unable to redirect stderr to /dev/null");
++ }
+ break;
+ case 'h':
+ print_help(argv[0]);
diff --git a/app-admin/conky/files/conky_no_x11.conf b/app-admin/conky/files/conky_no_x11.conf
deleted file mode 100644
index 29216dc3e731..000000000000
--- a/app-admin/conky/files/conky_no_x11.conf
+++ /dev/null
@@ -1,53 +0,0 @@
-# Conky, a system monitor, based on torsmo
-#
-# Any original torsmo code is licensed under the BSD license
-#
-# All code written since the fork of torsmo is licensed under the GPL
-#
-# Please see COPYING for details
-#
-# Copyright (c) 2004, Hannu Saransaari and Lauri Hakkarainen
-# Copyright (c) 2005-2009 Brenden Matthews, Philip Kovacs, et. al. (see AUTHORS)
-# All rights reserved.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-
-background no
-cpu_avg_samples 2
-net_avg_samples 2
-no_buffers yes
-out_to_console no
-out_to_stderr no
-update_interval 1.0
-uppercase no
-use_spacer none
-
-TEXT
-${scroll 16 $nodename - $sysname $kernel on $machine | }
-Uptime: $uptime
-Frequency (in MHz): $freq
-Frequency (in GHz): $freq_g
-RAM Usage: $mem/$memmax - $memperc% ${membar 4}
-Swap Usage: $swap/$swapmax - $swapperc% ${swapbar 4}
-CPU Usage: $cpu% ${cpubar 4}
-Processes: $processes Running: $running_processes
-File systems:
- / ${fs_used /}/${fs_size /} ${fs_bar 6 /}
-Networking:
-Up: ${upspeed eth0} - Down: ${downspeed eth0}
-Name PID CPU% MEM%
- ${top name 1} ${top pid 1} ${top cpu 1} ${top mem 1}
- ${top name 2} ${top pid 2} ${top cpu 2} ${top mem 2}
- ${top name 3} ${top pid 3} ${top cpu 3} ${top mem 3}
- ${top name 4} ${top pid 4} ${top cpu 4} ${top mem 4}
diff --git a/app-admin/conky/metadata.xml b/app-admin/conky/metadata.xml
index 824a2100939f..9bbf5953df57 100644
--- a/app-admin/conky/metadata.xml
+++ b/app-admin/conky/metadata.xml
@@ -24,7 +24,6 @@
<flag name='apcupsd'>enable support for <pkg>sys-power/apcupsd</pkg></flag>
<flag name='audacious'>enable monitoring of music played by <pkg>media-sound/audacious</pkg></flag>
<flag name='eve'>enable support for the eve-online skill monitor</flag>
- <flag name='ipv6'>disable support for tcp (ip4) port monitoring</flag>
<flag name='iostats'>enable support for per-task I/O statistics</flag>
<flag name='lua'>enable if you want Lua scripting support</flag>
<flag name='lua-cairo'>enable if you want Lua Cairo bindings for Conky (also enables lua support)</flag>
@@ -35,7 +34,6 @@
<flag name='nano-syntax'>enable syntax highlighting for <pkg>app-editors/nano</pkg></flag>
<flag name='nvidia'>enable reading of nvidia card temperature sensors via <pkg>media-video/nvidia-settings</pkg></flag>
<flag name='portmon'>enable support for tcp (ip4) port monitoring</flag>
- <flag name='smapi'>enable support for smapi</flag>
<flag name='thinkpad'>enable support for IBM/Lenovo notebooks</flag>
<flag name='weather-metar'>enable support for metar weather service</flag>
<flag name='weather-xoap'>enable support for metar and xoap weather service</flag>