summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2012-04-29 13:15:44 +0000
committerBenedikt Boehm <hollow@gentoo.org>2012-04-29 13:15:44 +0000
commit2e17c5ad42e69f4fe9a46d1f871baded1aa5867c (patch)
treeab50eda29a4520ac3f33757a093cb348636adfd6 /app-admin/chef
parentinitial version (required dependency of chef-0.10.10) (diff)
downloadgentoo-2-2e17c5ad42e69f4fe9a46d1f871baded1aa5867c.tar.gz
gentoo-2-2e17c5ad42e69f4fe9a46d1f871baded1aa5867c.tar.bz2
gentoo-2-2e17c5ad42e69f4fe9a46d1f871baded1aa5867c.zip
version bump to resolve dependency conflicts (see #410385)
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/chef')
-rw-r--r--app-admin/chef/ChangeLog7
-rw-r--r--app-admin/chef/chef-0.10.10_beta1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-admin/chef/ChangeLog b/app-admin/chef/ChangeLog
index fe98e0c4c6ab..d055bb987759 100644
--- a/app-admin/chef/ChangeLog
+++ b/app-admin/chef/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/chef
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/ChangeLog,v 1.9 2012/02/21 07:49:31 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/ChangeLog,v 1.10 2012/04/29 13:15:44 hollow Exp $
+
+*chef-0.10.10_beta1 (29 Apr 2012)
+
+ 29 Apr 2012; Benedikt Böhm <hollow@gentoo.org> +chef-0.10.10_beta1.ebuild:
+ version bump to resolve dependency conflicts (see #410385)
21 Feb 2012; Benedikt Böhm <hollow@gentoo.org> chef-0.10.8.ebuild:
"fix" dependencies wrt #403047
diff --git a/app-admin/chef/chef-0.10.10_beta1.ebuild b/app-admin/chef/chef-0.10.10_beta1.ebuild
new file mode 100644
index 000000000000..92a7273de23d
--- /dev/null
+++ b/app-admin/chef/chef-0.10.10_beta1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/chef-0.10.10_beta1.ebuild,v 1.1 2012/04/29 13:15:44 hollow Exp $
+
+EAPI="4"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_VERSION=${PV/_beta/.beta.}
+
+inherit ruby-fakegem
+
+DESCRIPTION="Chef is a systems integration framework"
+HOMEPAGE="http://wiki.opscode.com/display/chef"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/bunny-0.6.0
+ dev-ruby/erubis
+ dev-ruby/highline
+ >=dev-ruby/json-1.4.4
+ <=dev-ruby/json-1.6.1
+ >=dev-ruby/mixlib-authentication-1.1.0
+ >=dev-ruby/mixlib-cli-1.1.0
+ >=dev-ruby/mixlib-config-1.1.2
+ >=dev-ruby/mixlib-log-1.3.0
+ >=dev-ruby/mixlib-shellout-1.0.0
+ dev-ruby/moneta
+ >=dev-ruby/net-ssh-2.2.2
+ >=dev-ruby/net-ssh-multi-1.1
+ >=dev-ruby/ohai-0.6.0
+ >=dev-ruby/rest-client-1.0.4
+ dev-ruby/ruby-shadow
+ >=dev-ruby/treetop-1.4.9
+ dev-ruby/uuidtools"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ keepdir /etc/chef /var/lib/chef /var/log/chef /var/run/chef
+
+ doinitd "${FILESDIR}/initd/chef-client"
+ doconfd "${FILESDIR}/confd/chef-client"
+
+ insinto /etc/chef
+ doins "${FILESDIR}/client.rb"
+ doins "${FILESDIR}/solo.rb"
+}
+
+pkg_setup() {
+ enewgroup chef
+ enewuser chef -1 -1 /var/lib/chef chef
+}
+
+pkg_postinst() {
+ elog
+ elog "You should edit /etc/chef/client.rb before starting the service with"
+ elog "/etc/init.d/chef-client start"
+ elog
+}