summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-19 10:53:45 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-19 10:53:45 +0000
commitf562cd289d77ba29ee851a90701c3a8daefd84e5 (patch)
tree6291d6aea15cbf411a5831710215345e7bc769f5 /app-admin/apache-tools
parentVersion bump (bug #206053). (diff)
downloadgentoo-2-f562cd289d77ba29ee851a90701c3a8daefd84e5.tar.gz
gentoo-2-f562cd289d77ba29ee851a90701c3a8daefd84e5.tar.bz2
gentoo-2-f562cd289d77ba29ee851a90701c3a8daefd84e5.zip
version bump
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/ChangeLog8
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.8.ebuild92
-rw-r--r--app-admin/apache-tools/files/digest-apache-tools-2.2.83
3 files changed, 102 insertions, 1 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 6df7e54f536a..311843d52a90 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.25 2008/01/06 20:59:53 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.26 2008/01/19 10:53:44 hollow Exp $
+
+*apache-tools-2.2.8 (19 Jan 2008)
+
+ 19 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
+ +apache-tools-2.2.8.ebuild:
+ version bump
06 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
-apache-tools-2.2.4-r4.ebuild:
diff --git a/app-admin/apache-tools/apache-tools-2.2.8.ebuild b/app-admin/apache-tools/apache-tools-2.2.8.ebuild
new file mode 100644
index 000000000000..2b8e25b01d25
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.8.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.8.ebuild,v 1.1 2008/01/19 10:53:44 hollow Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply these patches:
+ # (1) apache-tools-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ local myconf=""
+ cd "${S}"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ # Thanks to Harald van Dijk
+ append-ldflags -Wl,--no-as-needed
+
+ if use ssl ; then
+ myconf="${myconf} --with-ssl=/usr --enable-ssl"
+ append-flags -DHAVE_OPENSSL -DUSE_SSL -I/usr/include/openssl
+ append-ldflags -lssl
+ fi
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+
+ econf \
+ --sbindir=/usr/sbin \
+ --with-perl=/usr/bin/perl \
+ --with-expat=/usr \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf} || die "econf failed!"
+
+ cd support
+ emake || die "emake support/ failed!"
+}
+
+src_install () {
+ cd "${S}"/support
+
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+
+ for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+
+ # Provide a symlink for ab-ssl
+ if use ssl ; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ dodoc "${S}"/CHANGES
+}
diff --git a/app-admin/apache-tools/files/digest-apache-tools-2.2.8 b/app-admin/apache-tools/files/digest-apache-tools-2.2.8
new file mode 100644
index 000000000000..6326fa2b7da8
--- /dev/null
+++ b/app-admin/apache-tools/files/digest-apache-tools-2.2.8
@@ -0,0 +1,3 @@
+MD5 76d2598a4797163d07cd50e5304aa7cd httpd-2.2.8.tar.bz2 4799055
+RMD160 0736ea9617bafaa1c8cd34ce4fc1c7a659afea57 httpd-2.2.8.tar.bz2 4799055
+SHA256 2ad8d0db1e478838ba88a0ddaf538c7150027d937b017739fdcb3fabb96ebd39 httpd-2.2.8.tar.bz2 4799055