summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-02 03:19:38 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-02 03:19:38 +0000
commitdb5f8a5b2732159a74db2a515a928eccf801bb1a (patch)
tree76ffcf9aa50eba2e11f38464d853fd7d9fa60329 /app-admin/analog
parentdigests everywhere (diff)
downloadgentoo-2-db5f8a5b2732159a74db2a515a928eccf801bb1a.tar.gz
gentoo-2-db5f8a5b2732159a74db2a515a928eccf801bb1a.tar.bz2
gentoo-2-db5f8a5b2732159a74db2a515a928eccf801bb1a.zip
Updated to latest version. Fixed up LANGDIR and CONFIGDIR.
Now including a default configuration file. Tidied up the documentation, dohtml rocks :)
Diffstat (limited to 'app-admin/analog')
-rw-r--r--app-admin/analog/analog-5.1.ebuild40
-rw-r--r--app-admin/analog/files/analog-5.1-gentoo.diff21
-rw-r--r--app-admin/analog/files/analog.cfg101
-rw-r--r--app-admin/analog/files/digest-analog-5.11
4 files changed, 163 insertions, 0 deletions
diff --git a/app-admin/analog/analog-5.1.ebuild b/app-admin/analog/analog-5.1.ebuild
new file mode 100644
index 000000000000..28ea38257c9c
--- /dev/null
+++ b/app-admin/analog/analog-5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/analog/analog-5.1.ebuild,v 1.1 2002/01/02 03:19:38 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The most popular logfile analyser in the world"
+HOMEPAGE="http://www.analog.cx/"
+SRC_URI="http://www.analog.cx/${P}.tar.gz"
+DEPEND="virtual/glibc >=dev-libs/libpcre-3.4 >=media-libs/libgd-1.8.3 >=sys-libs/zlib-1.1.3"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv src/Makefile src/Makefile.orig
+ sed -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS}:" \
+ -e 's:^DEFS.*:DEFS = -DHAVE_GD -DHAVE_PCRE:' \
+ -e 's:^LIBS.*:LIBS = -lgd -lpng -ljpeg -lz -lpcre -lm:' \
+ src/Makefile.orig > src/Makefile
+ patch -p1 < ${FILESDIR}/${PN}-${PV}-gentoo.diff
+}
+
+src_compile() {
+ make -C src || die
+}
+
+src_install() {
+ dobin analog ; newman analog.man analog.1
+
+ dodoc README.txt Licence.txt analog.cfg
+ dohtml -a html,gif,css,ico docs/*
+ docinto examples ; dodoc examples/*
+ docinto cgi ; dodoc anlgform.html anlgform.pl
+ cp -a how-to ${D}/usr/share/doc/${PF}
+
+ insinto /usr/share/analog/images ; doins images/*
+ insinto /usr/share/analog/lang ; doins lang/*
+ dodir /var/log/analog
+ dosym /usr/share/analog/images /var/log/analog/images
+ insinto /etc/analog ; doins ${FILESDIR}/analog.cfg
+}
diff --git a/app-admin/analog/files/analog-5.1-gentoo.diff b/app-admin/analog/files/analog-5.1-gentoo.diff
new file mode 100644
index 000000000000..29edb25313b3
--- /dev/null
+++ b/app-admin/analog/files/analog-5.1-gentoo.diff
@@ -0,0 +1,21 @@
+diff -ur analog-5.1.orig/src/anlghead.h analog-5.1/src/anlghead.h
+--- analog-5.1.orig/src/anlghead.h Wed Nov 7 06:06:46 2001
++++ analog-5.1/src/anlghead.h Mon Dec 31 16:47:43 2001
+@@ -81,15 +81,11 @@
+ and use that directory; or the current directory if it couldn't deduce a
+ directory. This may or may not work, so it's better to specify a location
+ explicitly here if you know where the files will be kept. */
+-#ifndef LANGDIR
+-#define LANGDIR NULL
+-#endif
++#define LANGDIR "/usr/share/analog/lang/"
+ /* Directory where the language files live. Actually, if this one is defined
+ to be NULL, they will be looked for inside the "lang" subdirectory of the
+ directory containing the analog binary. */
+-#ifndef CONFIGDIR
+-#define CONFIGDIR NULL
+-#endif
++#define CONFIGDIR "/etc/analog/"
+ /* Directory containing configuration files. */
+ #ifndef LOGSDIR
+ #define LOGSDIR NULL
diff --git a/app-admin/analog/files/analog.cfg b/app-admin/analog/files/analog.cfg
new file mode 100644
index 000000000000..99e452b36e3d
--- /dev/null
+++ b/app-admin/analog/files/analog.cfg
@@ -0,0 +1,101 @@
+# Configuration file for analog 5.1
+# See http://www.analog.cx/
+#
+# This is a simple default configuration file which works when you run
+# analog with no command line parameters. There are much more extensive
+# configuration examples included with the documentation.
+# See the big.cfg example file.
+#
+# If you need a LOGFORMAT command (most people don't -- try it without first!),
+# it must go here, above the LOGFILE commands.
+LOGFILE /var/log/apache/access_log
+OUTFILE /var/log/analog/index.html
+LANGUAGE ENGLISH
+IMAGEDIR images/
+# HOSTNAME "[my organisation]"
+REQLINKINCLUDE pages
+REFLINKINCLUDE *
+REDIRREFLINKINCLUDE *
+FAILREFLINKINCLUDE *
+UNCOMPRESS *.gz,*.Z "gzip -cd"
+BROWOUTPUTALIAS IWENG AOL
+SUBBROW */*
+SUBTYPE *.gz,*.Z
+# Add whichever of these types of pages you have on your server, or others.
+# PAGEINCLUDE *.shtml
+# PAGEINCLUDE *.asp
+# PAGEINCLUDE *.jsp
+# PAGEINCLUDE *.cfm
+# PAGEINCLUDE *.pl
+# PAGEINCLUDE *.php
+SEARCHENGINE http://*altavista.*/* q
+SEARCHENGINE http://*yahoo.*/* p
+SEARCHENGINE http://*google.*/* q
+SEARCHENGINE http://*lycos.*/* query
+SEARCHENGINE http://*aol.*/* query
+SEARCHENGINE http://*excite.*/* search
+SEARCHENGINE http://*go2net.*/* general
+SEARCHENGINE http://*metacrawler.*/* general
+SEARCHENGINE http://*msn.*/* MT
+SEARCHENGINE http://*hotbot.com/* MT
+SEARCHENGINE http://*netscape.*/* search
+SEARCHENGINE http://*looksmart.*/* key
+SEARCHENGINE http://*infoseek.*/* qt
+SEARCHENGINE http://*webcrawler.*/* search,searchText
+SEARCHENGINE http://*goto.*/* Keywords
+SEARCHENGINE http://*snap.*/* keyword
+SEARCHENGINE http://*dogpile.*/* q
+SEARCHENGINE http://*askjeeves.*/* ask
+SEARCHENGINE http://*ask.*/* ask
+SEARCHENGINE http://*aj.*/* ask
+SEARCHENGINE http://*directhit.*/* qry
+SEARCHENGINE http://*alltheweb.*/* query
+SEARCHENGINE http://*northernlight.*/* qr
+SEARCHENGINE http://*nlsearch.*/* qr
+SEARCHENGINE http://*dmoz.*/* search
+SEARCHENGINE http://*newhoo.*/* search
+SEARCHENGINE http://*netfind.*/* query,search,s
+SEARCHENGINE http://*/netfind* query
+SEARCHENGINE http://*/pursuit query
+ROBOTINCLUDE REGEXPI:robot
+ROBOTINCLUDE REGEXPI:spider
+ROBOTINCLUDE REGEXPI:crawler
+ROBOTINCLUDE Googlebot*
+ROBOTINCLUDE Infoseek*
+ROBOTINCLUDE Scooter*
+ROBOTINCLUDE Slurp*
+ROBOTINCLUDE Ultraseek*
+TYPEOUTPUTALIAS .html ".html [Hypertext Markup Language]"
+TYPEOUTPUTALIAS .htm ".htm [Hypertext Markup Language]"
+TYPEOUTPUTALIAS .shtml ".shtml [Server-parsed HTML]"
+TYPEOUTPUTALIAS .ps ".ps [PostScript]"
+TYPEOUTPUTALIAS .gz ".gz [Gzip compressed files]"
+TYPEOUTPUTALIAS .tar.gz ".tar.gz [Compressed archives]"
+TYPEOUTPUTALIAS .jpg ".jpg [JPEG graphics]"
+TYPEOUTPUTALIAS .jpeg ".jpeg [JPEG graphics]"
+TYPEOUTPUTALIAS .gif ".gif [GIF graphics]"
+TYPEOUTPUTALIAS .png ".png [PNG graphics]"
+TYPEOUTPUTALIAS .txt ".txt [Plain text]"
+TYPEOUTPUTALIAS .cgi ".cgi [CGI scripts]"
+TYPEOUTPUTALIAS .pl ".pl [Perl scripts]"
+TYPEOUTPUTALIAS .css ".css [Cascading Style Sheets]"
+TYPEOUTPUTALIAS .class ".class [Java class files]"
+TYPEOUTPUTALIAS .pdf ".pdf [Adobe Portable Document Format]"
+TYPEOUTPUTALIAS .zip ".zip [Zip archives]"
+TYPEOUTPUTALIAS .hqx ".hqx [Macintosh archives]"
+TYPEOUTPUTALIAS .exe ".exe [Executables]"
+TYPEOUTPUTALIAS .wav ".wav [WAV sound files]"
+TYPEOUTPUTALIAS .avi ".avi [AVI movies]"
+TYPEOUTPUTALIAS .arc ".arc [Compressed archives]"
+TYPEOUTPUTALIAS .mid ".mid [MIDI sound files]"
+TYPEOUTPUTALIAS .mp3 ".mp3 [MP3 sound files]"
+TYPEOUTPUTALIAS .doc ".doc [Microsoft Word document]"
+TYPEOUTPUTALIAS .rtf ".rtf [Rich Text Format]"
+TYPEOUTPUTALIAS .mov ".mov [Quick Time movie]"
+TYPEOUTPUTALIAS .mpg ".mpg [MPEG movie]"
+TYPEOUTPUTALIAS .mpeg ".mpeg [MPEG movie]"
+TYPEOUTPUTALIAS .asp ".asp [Active Server Pages]"
+TYPEOUTPUTALIAS .jsp ".jsp [Java Server Pages]"
+TYPEOUTPUTALIAS .cfm ".cfm [Cold Fusion]"
+TYPEOUTPUTALIAS .php ".php [PHP]"
+TYPEOUTPUTALIAS .js ".js [JavaScript code]"
diff --git a/app-admin/analog/files/digest-analog-5.1 b/app-admin/analog/files/digest-analog-5.1
new file mode 100644
index 000000000000..21f50c6f7a90
--- /dev/null
+++ b/app-admin/analog/files/digest-analog-5.1
@@ -0,0 +1 @@
+MD5 5e84eaca93a2de5c305e0da0e20e9e42 analog-5.1.tar.gz 856064