summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-03-12 00:22:39 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-03-12 00:22:39 +0000
commitf485f1f31ac471956eb03f37f071b2665328b2df (patch)
tree33a2531aff82d7c47dc2890a017238ab824210b2 /app-accessibility
parentphase out old kpowersave powersave daemon (diff)
downloadgentoo-2-f485f1f31ac471956eb03f37f071b2665328b2df.tar.gz
gentoo-2-f485f1f31ac471956eb03f37f071b2665328b2df.tar.bz2
gentoo-2-f485f1f31ac471956eb03f37f071b2665328b2df.zip
Fixed the ebuild so that the correct options are passed to make if no audio output option is in the use flags.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak/ChangeLog6
-rw-r--r--app-accessibility/espeak/espeak-1.36.ebuild45
2 files changed, 30 insertions, 21 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index 6b0dd7839095..b4e2bc0555fb 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.35 2008/03/10 01:01:41 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.36 2008/03/12 00:22:39 williamh Exp $
+
+ 12 Mar 2008; William Hubbs <williamh@gentoo.org> espeak-1.36.ebuild:
+ Updated the ebuild to pass the correct options to make if neither portaudio
+ nor pulseaudio is in the use flags.
*espeak-1.36 (10 Mar 2008)
diff --git a/app-accessibility/espeak/espeak-1.36.ebuild b/app-accessibility/espeak/espeak-1.36.ebuild
index ae5b01fb3527..85a6b900151c 100644
--- a/app-accessibility/espeak/espeak-1.36.ebuild
+++ b/app-accessibility/espeak/espeak-1.36.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.36.ebuild,v 1.1 2008/03/10 01:01:41 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.36.ebuild,v 1.2 2008/03/12 00:22:39 williamh Exp $
inherit eutils
@@ -18,15 +18,29 @@ DEPEND="portaudio? ( >=media-libs/portaudio-18.1-r5 )
S=${WORKDIR}/${MY_P}
+get_audio() {
+ local MY_AUDIO
+
+ MY_AUDIO=none
+ if use portaudio; then
+ MY_AUDIO=portaudio
+ elif use pulseaudio; then
+ MY_AUDIO=pulseaudio
+ fi
+ echo ${MY_AUDIO}
+}
+
pkg_setup() {
- if ! use portaudio -a ! ! use pulseaudio; then
- ewarn
- ewarn Since portaudio and pulseaudio are not in your use flags, espeak
- ewarn will only bbe able to create wav files.
- ewarn If this is not what you want, press ctrl-c and put either
- ewarn portaudio or pulseaudio in your use flags.
- ebeep
- epause 10
+ if ! use portaudio; then
+ if ! use pulseaudio; then
+ ewarn
+ ewarn Since portaudio and pulseaudio are not in your use flags, espeak
+ ewarn will only bbe able to create wav files.
+ ewarn If this is not what you want, press ctrl-c and put either
+ ewarn portaudio or pulseaudio in your use flags.
+ ebeep
+ epause 10
+ fi
fi
}
@@ -43,17 +57,8 @@ src_unpack() {
}
src_compile() {
- local MY_AUDIO
-
cd src
-
- if use portaudio; then
- MY_AUDIO=portaudio
- elif use pulseaudio; then
- MY_AUDIO=pulseaudio
- fi
-
- emake AUDIO="${MY_AUDIO}" CXXFLAGS="${CXXFLAGS}" || die "Compilation failed"
+ emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
einfo "Fixing byte order of phoneme data files"
cd "${S}/platforms/big_endian"
@@ -64,7 +69,7 @@ src_compile() {
src_install() {
cd src
- make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die "Installation failed"
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
cd ..
dodoc ChangeLog ReadMe