summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-14 00:53:54 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-14 00:53:54 +0000
commitbc09baad0681fc359f10d7a5efaf923af1637577 (patch)
tree23c51b3a2f117949a9fadd70e2b7cc074d20a3b8 /app-accessibility
parentBump, translation updates only. (diff)
downloadgentoo-2-bc09baad0681fc359f10d7a5efaf923af1637577.tar.gz
gentoo-2-bc09baad0681fc359f10d7a5efaf923af1637577.tar.bz2
gentoo-2-bc09baad0681fc359f10d7a5efaf923af1637577.zip
Version bump, mostly translation updates.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/caribou/ChangeLog8
-rw-r--r--app-accessibility/caribou/caribou-0.4.2.ebuild81
2 files changed, 88 insertions, 1 deletions
diff --git a/app-accessibility/caribou/ChangeLog b/app-accessibility/caribou/ChangeLog
index 16b66719d4f7..71aadb2f2dd6 100644
--- a/app-accessibility/caribou/ChangeLog
+++ b/app-accessibility/caribou/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/caribou
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/caribou/ChangeLog,v 1.7 2012/02/25 00:42:47 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/caribou/ChangeLog,v 1.8 2012/05/14 00:53:54 tetromino Exp $
+
+*caribou-0.4.2 (14 May 2012)
+
+ 14 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +caribou-0.4.2.ebuild:
+ Version bump, mostly translation updates.
25 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
caribou-0.4.1-r1.ebuild:
diff --git a/app-accessibility/caribou/caribou-0.4.2.ebuild b/app-accessibility/caribou/caribou-0.4.2.ebuild
new file mode 100644
index 000000000000..d434a36f5da6
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/caribou/caribou-0.4.2.ebuild,v 1.1 2012/05/14 00:53:54 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="xml"
+
+inherit gnome2 python
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://live.gnome.org/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-python/pygobject-2.90.3:3
+ >=x11-libs/gtk+-3.0.0:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7
+ dev-libs/libgee:0
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ dev-python/dbus-python
+ >=dev-python/pyatspi-2.1.90
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus"
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ --enable-gtk3-module
+ --enable-gtk2-module
+ PYTHON=${EPREFIX}/usr/bin/python2
+ VALAC=$(type -P valac-0.14)" # harmless even if valac-0.14 not found
+ # PYTHON is substituted into several installed shell scripts
+ # vala is not needed for tarball builds, but configure checks for it...
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ sed -e '/export PYTHONPATH=.*python/ d' \
+ -i bin/{antler-keyboard,caribou,caribou-preferences}.in ||
+ die "sed failed"
+
+ python_clean_py-compile_files
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize caribou
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup caribou
+}