summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-11-07 03:07:42 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-11-07 03:07:42 +0000
commit92612552579ea8f70e8e439c946a27e69bf32849 (patch)
tree871ca9e9725d9ad4e52cd5bce3cec35cb8e144b4 /app-accessibility
parentAdd 'keepdir /var/lib/xkb'. (Bug #154287, Chuck Wegrzyn for the report and (diff)
downloadgentoo-2-92612552579ea8f70e8e439c946a27e69bf32849.tar.gz
gentoo-2-92612552579ea8f70e8e439c946a27e69bf32849.tar.bz2
gentoo-2-92612552579ea8f70e8e439c946a27e69bf32849.zip
New release: 4.2.1. Pruning old ebuilds.
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog9
-rw-r--r--app-accessibility/dasher/dasher-4.2.1.ebuild75
-rw-r--r--app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch25
-rw-r--r--app-accessibility/dasher/files/dasher-4.2.1-sk_conditional_fix.patch14
-rw-r--r--app-accessibility/dasher/files/digest-dasher-4.2.13
5 files changed, 100 insertions, 26 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 64d63e770234..2987beaf3c77 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.73 2006/10/21 02:03:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.74 2006/11/07 03:07:42 leonardop Exp $
+
+*dasher-4.2.1 (07 Nov 2006)
+
+ 07 Nov 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +files/dasher-4.2.1-sk_conditional_fix.patch, +dasher-4.2.1.ebuild:
+ Version bump. Updated dependencies. Added patch to fix compilation with
+ USE=-gnome.
21 Oct 2006; Aron Griffis <agriffis@gentoo.org> dasher-4.0.2.ebuild:
Mark 4.0.2 stable on alpha
diff --git a/app-accessibility/dasher/dasher-4.2.1.ebuild b/app-accessibility/dasher/dasher-4.2.1.ebuild
new file mode 100644
index 000000000000..041d7a709932
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.2.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.2.1.ebuild,v 1.1 2006/11/07 03:07:42 leonardop Exp $
+
+WANT_AUTOMAKE=1.8
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility cairo gnome"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1
+ dev-libs/atk )
+ cairo? (
+ >=x11-libs/gtk+-2.8 )
+
+ x11-libs/libX11"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome? (
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper )
+
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable accessibility a11y) \
+ $(use_enable accessibility speech) \
+ $(use_with cairo) \
+ $(use_with gnome)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am
+
+ epatch "${FILESDIR}"/${PN}-4.1.10-as-needed.patch
+
+ # Patch to fix compilation when USE=-gnome is used
+ epatch "${FILESDIR}"/${P}-sk_conditional_fix.patch
+
+ eautoreconf
+}
diff --git a/app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch b/app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch
index 0d2b15ce969a..76859a61816d 100644
--- a/app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch
+++ b/app-accessibility/dasher/files/dasher-4.1.10-as-needed.patch
@@ -23,28 +23,3 @@ diff --exclude-from=/home/dang/.diffrc -u -ruN dasher-4.1.10.orig/Src/Makefile.a
endif
if DOQTE
-diff --exclude-from=/home/dang/.diffrc -u -ruN dasher-4.1.10.orig/Src/Makefile.in dasher-4.1.10/Src/Makefile.in
---- dasher-4.1.10.orig/Src/Makefile.in 2006-08-21 17:25:30.000000000 -0400
-+++ dasher-4.1.10/Src/Makefile.in 2006-09-04 22:41:26.000000000 -0400
-@@ -299,16 +299,16 @@
- @DOGTK2_TRUE@ -DPACKAGE_LOCALE_DIR=\"$(datadir)/locale\"
-
- @DOGTK2_TRUE@dasher_LDADD = \
--@DOGTK2_TRUE@ $(GTK2BUILD_LIBS) \
--@DOGTK2_TRUE@ -lexpat \
--@DOGTK2_TRUE@ $(POPT_LIBS) \
--@DOGTK2_TRUE@ $(GPELIB) \
- @DOGTK2_TRUE@ Common/libdashermisc.a \
- @DOGTK2_TRUE@ Gtk2/libdashergtk.a \
- @DOGTK2_TRUE@ Gtk2/libdashercontrol.a \
- @DOGTK2_TRUE@ DasherCore/libdashercore.a \
- @DOGTK2_TRUE@ DasherCore/LanguageModelling/libdasherlm.a \
--@DOGTK2_TRUE@ DasherCore/Alphabet/libdasheralphabet.a
-+@DOGTK2_TRUE@ DasherCore/Alphabet/libdasheralphabet.a \
-+@DOGTK2_TRUE@ $(GTK2BUILD_LIBS) \
-+@DOGTK2_TRUE@ -lexpat \
-+@DOGTK2_TRUE@ $(POPT_LIBS) \
-+@DOGTK2_TRUE@ $(GPELIB)
-
- @DOQTE_TRUE@QTDIR = /usr/share/qte2
- all: all-recursive
diff --git a/app-accessibility/dasher/files/dasher-4.2.1-sk_conditional_fix.patch b/app-accessibility/dasher/files/dasher-4.2.1-sk_conditional_fix.patch
new file mode 100644
index 000000000000..8793b77ffdc8
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.2.1-sk_conditional_fix.patch
@@ -0,0 +1,14 @@
+diff -NurdB dasher-4.2.1/configure.in dasher-4.2.1-patched/configure.in
+--- dasher-4.2.1/configure.in 2006-10-24 14:52:52.000000000 -0500
++++ dasher-4.2.1-patched/configure.in 2006-11-06 20:24:10.000000000 -0500
+@@ -325,7 +325,9 @@
+ AC_SUBST(GTK2BUILD_LIBS)
+
+ if [[ x"$WITHGNOME" = xtrue ]]; then
+-GNOME_DOC_INIT
++ GNOME_DOC_INIT
++else
++ AM_CONDITIONAL(ENABLE_SK, test "x$enable_scrollkeeper" = "xyes")
+ fi
+
+ AC_CONFIG_FILES([Makefile
diff --git a/app-accessibility/dasher/files/digest-dasher-4.2.1 b/app-accessibility/dasher/files/digest-dasher-4.2.1
new file mode 100644
index 000000000000..3f848159aee8
--- /dev/null
+++ b/app-accessibility/dasher/files/digest-dasher-4.2.1
@@ -0,0 +1,3 @@
+MD5 bb231a7afb424ad97264da67e5d24620 dasher-4.2.1.tar.bz2 5624904
+RMD160 93e219bda543d8efd295ca5ca161c06be529368a dasher-4.2.1.tar.bz2 5624904
+SHA256 96c529316f877ff0bd55be487af5d629d84eaf212d8587b2a583822121e1b4fc dasher-4.2.1.tar.bz2 5624904