summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-11 13:44:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-11 13:44:18 +0000
commit8354fee35136e0feab5cec17f26a37c06314a548 (patch)
tree913c044369e14d927ec74f4b457aaf0de35591ae /app-accessibility
parent... and included some changes by Davide Pesavento (diff)
downloadgentoo-2-8354fee35136e0feab5cec17f26a37c06314a548.tar.gz
gentoo-2-8354fee35136e0feab5cec17f26a37c06314a548.tar.bz2
gentoo-2-8354fee35136e0feab5cec17f26a37c06314a548.zip
fix compilation with -cairo, bug #216050. fix compilation with -gnome, bug #218011. direct to stable because the patches are trivial enough and already upstream.
(Portage version: 2.2_rc6/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog9
-rw-r--r--app-accessibility/dasher/dasher-4.7.3.ebuild10
-rw-r--r--app-accessibility/dasher/files/dasher-4.7.3-cairo.patch12
-rw-r--r--app-accessibility/dasher/files/dasher-4.7.3-no-gnome.patch26
4 files changed, 54 insertions, 3 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 28b30c1cfc11..753eb728a8cb 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.127 2008/08/10 12:09:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.128 2008/08/11 13:44:17 eva Exp $
+
+ 11 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/dasher-4.7.3-cairo.patch, +files/dasher-4.7.3-no-gnome.patch,
+ dasher-4.7.3.ebuild:
+ fix compilation with -cairo, bug #216050
+ fix compilation with -gnome, bug #218011
+ direct to stable because the patches are trivial enough and already upstream.
10 Aug 2008; Markus Meier <maekke@gentoo.org> dasher-4.7.3.ebuild:
x86 stable, bug #229709
diff --git a/app-accessibility/dasher/dasher-4.7.3.ebuild b/app-accessibility/dasher/dasher-4.7.3.ebuild
index 6fbc755b80e5..dc5e2d682c24 100644
--- a/app-accessibility/dasher/dasher-4.7.3.ebuild
+++ b/app-accessibility/dasher/dasher-4.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.7.3.ebuild,v 1.5 2008/08/10 12:09:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.7.3.ebuild,v 1.6 2008/08/11 13:44:17 eva Exp $
WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="1.8"
@@ -75,6 +75,12 @@ src_unpack() {
# https://bugzilla.gnome.org/522121
epatch "${FILESDIR}"/${P}-gcc-4.3.patch
- eautomake
+ # Fix compilation with -gnome, upstream bug #398103
+ epatch "${FILESDIR}/${P}-no-gnome.patch"
+
+ # Fix compilation with -cairo, from upstream bug #490876
+ epatch "${FILESDIR}/${P}-cairo.patch"
+
intltoolize --force || die "intltoolize failed"
+ eautoreconf
}
diff --git a/app-accessibility/dasher/files/dasher-4.7.3-cairo.patch b/app-accessibility/dasher/files/dasher-4.7.3-cairo.patch
new file mode 100644
index 000000000000..04df957cb524
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.7.3-cairo.patch
@@ -0,0 +1,12 @@
+--- a/Src/Gtk2/Canvas.cpp
++++ b/Src/Gtk2/Canvas.cpp
+@@ -88,7 +88,9 @@
+ g_object_unref(m_pOnscreenBuffer);
+ #endif
+
++#if WITH_CAIRO
+ delete[] cairo_colours;
++#endif
+ delete m_pPangoInk;
+ }
+
diff --git a/app-accessibility/dasher/files/dasher-4.7.3-no-gnome.patch b/app-accessibility/dasher/files/dasher-4.7.3-no-gnome.patch
new file mode 100644
index 000000000000..341667e9792d
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.7.3-no-gnome.patch
@@ -0,0 +1,26 @@
+Index: configure.in
+===================================================================
+--- configure.in (revision 3450)
++++ configure.in (working copy)
+@@ -412,13 +412,16 @@
+ AC_SUBST(GTK2BUILD_CFLAGS)
+ AC_SUBST(GTK2BUILD_LIBS)
+
+-if [[ x"$WITHGNOME" = xtrue ]]; then
+- GNOME_DOC_INIT
+-else
+- # Allows compilation if --without-gnome is passed
+- AM_CONDITIONAL(ENABLE_SK, test "x$enable_scrollkeeper" = "xyes")
++AC_MSG_CHECKING([for gnome-doc-utils])
++GNOME_DOC_INIT([0.9.0],[have_gdu=yes],[have_gdu=no])
++AC_MSG_RESULT($have_gdu)
++
++if [[ x"$WITHGNOME" = xtrue ]] && [[ "$have_gdu" = xno ]]; then
++ AC_MSG_ERROR([gnome-doc-utils not found!])
+ fi
+
++AM_CONDITIONAL(ENABLE_SK, test x"$WITHGNOME" = xfalse -a "x$enable_scrollkeeper" = "xyes")
++
+ AC_CONFIG_FILES([Data/dasher.desktop.in
+ Data/Makefile
+ Data/training/Makefile