summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-05-10 02:16:59 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-05-10 02:16:59 +0000
commit7b428df8ba9ae834ce9957bed5d3f5084825b8ab (patch)
tree936a84f0326dccca1b11892af01985ae14942639 /app-accessibility
parentfix selinux patch (diff)
downloadgentoo-2-7b428df8ba9ae834ce9957bed5d3f5084825b8ab.tar.gz
gentoo-2-7b428df8ba9ae834ce9957bed5d3f5084825b8ab.tar.bz2
gentoo-2-7b428df8ba9ae834ce9957bed5d3f5084825b8ab.zip
New release: 4.0.2. Added patch to fix compilation with USE=-gnome (bug #132510).
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog10
-rw-r--r--app-accessibility/dasher/dasher-4.0.2.ebuild70
-rw-r--r--app-accessibility/dasher/files/dasher-4.0.2-without_gnome.patch23
-rw-r--r--app-accessibility/dasher/files/digest-dasher-4.0.23
4 files changed, 105 insertions, 1 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 32ec37fde80a..ca7decc116c1 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.60 2006/04/09 04:34:56 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.61 2006/05/10 02:16:59 leonardop Exp $
+
+*dasher-4.0.2 (10 May 2006)
+
+ 10 May 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +files/dasher-4.0.2-without_gnome.patch, -dasher-4.0.0.ebuild,
+ +dasher-4.0.2.ebuild:
+ New version. Includes a patch to fix compilation with USE=-gnome (bug
+ #132510).
09 Apr 2006; Mark Loeser <halcy0n@gentoo.org>
+files/dasher-3.2.18-gcc41.patch, dasher-3.2.18.ebuild:
diff --git a/app-accessibility/dasher/dasher-4.0.2.ebuild b/app-accessibility/dasher/dasher-4.0.2.ebuild
new file mode 100644
index 000000000000..ea8be62bc5f3
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.0.2.ebuild,v 1.1 2006/05/10 02:16:59 leonardop Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility gnome cairo"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND="dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=dev-libs/glib-2
+ >=x11-libs/libwnck-1
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXtst )
+ virtual/x11 )
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1 )
+ cairo? ( >=x11-libs/gtk+-2.8 )"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt )
+ virtual/x11 )
+ >=dev-util/intltool-0.28
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+
+pkg_setup() {
+ G2CONF="$(use_with gnome) \
+ $(use_enable accessibility a11y) \
+ $(use_enable accessibility speech) \
+ $(use_with cairo)"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Fix compilation with USE=-gnome (bug #132510)
+ epatch "${FILESDIR}"/${P}-without_gnome.patch
+
+ gnome2_omf_fix
+ sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am ./Data/Makefile.in
+}
diff --git a/app-accessibility/dasher/files/dasher-4.0.2-without_gnome.patch b/app-accessibility/dasher/files/dasher-4.0.2-without_gnome.patch
new file mode 100644
index 000000000000..3f6dceb6ebd9
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.0.2-without_gnome.patch
@@ -0,0 +1,23 @@
+diff -NurdB dasher-4.0.2/Src/Gtk2/Menu.cc dasher-4.0.2-patched/Src/Gtk2/Menu.cc
+--- dasher-4.0.2/Src/Gtk2/Menu.cc 2006-03-05 14:26:47.000000000 -0500
++++ dasher-4.0.2-patched/Src/Gtk2/Menu.cc 2006-05-09 20:10:15.000000000 -0500
+@@ -469,7 +469,7 @@
+ GtkWidget *label, *button;
+ char *tmp;
+
+- about = gtk_dialog_new();
++ GtkWidget *about = gtk_dialog_new();
+
+ gtk_dialog_set_has_separator(GTK_DIALOG(about), FALSE);
+ gtk_window_set_title(GTK_WINDOW(about), "About Dasher");
+diff -NurdB dasher-4.0.2/Src/main.cc dasher-4.0.2-patched/Src/main.cc
+--- dasher-4.0.2/Src/main.cc 2006-02-25 16:19:10.000000000 -0500
++++ dasher-4.0.2-patched/Src/main.cc 2006-05-09 20:10:45.000000000 -0500
+@@ -1,6 +1,7 @@
+ #include "Common/Common.h"
+ #include "AppSettings.h"
+
++#include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkx.h>
+ #include <glade/glade.h>
diff --git a/app-accessibility/dasher/files/digest-dasher-4.0.2 b/app-accessibility/dasher/files/digest-dasher-4.0.2
new file mode 100644
index 000000000000..5d2f082884b2
--- /dev/null
+++ b/app-accessibility/dasher/files/digest-dasher-4.0.2
@@ -0,0 +1,3 @@
+MD5 47cf27594abb51ea97f3a8fdb276736d dasher-4.0.2.tar.bz2 5802684
+RMD160 90d54eca8474bc46cd2f11d76b56e3d62811b598 dasher-4.0.2.tar.bz2 5802684
+SHA256 4a4adb18ca80641319ffdb63c8cbd69f2faa0698b4d275a2b3ccae467de8d73c dasher-4.0.2.tar.bz2 5802684