summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-04-20 19:30:49 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-04-20 19:30:49 +0000
commit1ca586abdf04a3549ccfcd7af73ec10e2aa18905 (patch)
tree8735c827cc27848b1e3f42e9d4c13ac3f841e929 /app-accessibility
parentVersion bump #218457 by Peter Simons. (diff)
downloadgentoo-2-1ca586abdf04a3549ccfcd7af73ec10e2aa18905.tar.gz
gentoo-2-1ca586abdf04a3549ccfcd7af73ec10e2aa18905.tar.bz2
gentoo-2-1ca586abdf04a3549ccfcd7af73ec10e2aa18905.zip
Version bump, and also do not allow both portaudio and pulseaudio in use.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak/ChangeLog8
-rw-r--r--app-accessibility/espeak/espeak-1.37.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index aab7f71b965f..339c7b657ecc 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.42 2008/04/15 16:32:07 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.43 2008/04/20 19:30:49 williamh Exp $
+
+*espeak-1.37 (20 Apr 2008)
+
+ 20 Apr 2008; William Hubbs <williamh@gentoo.org> +espeak-1.37.ebuild:
+ Version bump. Also, for #218597, do not allow both portaudio and
+ pulseaudio in the use flags.
15 Apr 2008; Jeroen Roovers <jer@gentoo.org> espeak-1.36.02.ebuild:
Stable for HPPA (bug #217235).
diff --git a/app-accessibility/espeak/espeak-1.37.ebuild b/app-accessibility/espeak/espeak-1.37.ebuild
new file mode 100644
index 000000000000..d5e3124c19ce
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.37.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.37.ebuild,v 1.1 2008/04/20 19:30:49 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="portaudio pulseaudio"
+DEPEND="portaudio? ( >=media-libs/portaudio-18.1-r5 )
+ pulseaudio? ( media-sound/pulseaudio )
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+get_audio() {
+ local MY_AUDIO
+
+ MY_AUDIO=none
+ if use portaudio; then
+ MY_AUDIO=portaudio
+ elif use pulseaudio; then
+ MY_AUDIO=pulseaudio
+ fi
+ echo ${MY_AUDIO}
+}
+
+pkg_setup() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn
+ ewarn Since portaudio and pulseaudio are not in your use flags,
+ ewarn espeak will only bbe able to create wav files.
+ ewarn If this is not what you want, press ctrl-c and put either
+ ewarn portaudio or pulseaudio in your use flags.
+ ebeep
+ epause 10
+ elif use portaudio && use pulseaudio; then
+ die "You must choose either portaudio or pulseaudio, but not both."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if use portaudio; then
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+ fi
+}
+
+src_compile() {
+ cd src
+ emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
+
+ cd ..
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}