summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2013-08-15 05:21:58 +0000
committerChristopher Brannon <teiresias@gentoo.org>2013-08-15 05:21:58 +0000
commit4c683925df13962e1a7d4d94da1773a8d18bc89f (patch)
tree4f5ff88b10c3fa3b708f4865094c62d46bdb6a5b /app-accessibility/yasr
parentVersion bump. (diff)
downloadgentoo-2-4c683925df13962e1a7d4d94da1773a8d18bc89f.tar.gz
gentoo-2-4c683925df13962e1a7d4d94da1773a8d18bc89f.tar.bz2
gentoo-2-4c683925df13962e1a7d4d94da1773a8d18bc89f.zip
Fix bug #422621 and bug #467522.
Added a patch to replace the AM_CONFIG_HEADER and remove the AM_PROG_CC_STDC macro calls. Fixes bug #467522. Also fixed bug #422621 (build failure due to autotools issue) by patching the call to AM_GNU_GETTEXT_VERSION. This was a reccurrence of bug #330879 (build fails with gettext 0.18). (Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility/yasr')
-rw-r--r--app-accessibility/yasr/ChangeLog13
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-automake113.patch17
-rw-r--r--app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch13
-rw-r--r--app-accessibility/yasr/yasr-0.6.9-r1.ebuild8
4 files changed, 46 insertions, 5 deletions
diff --git a/app-accessibility/yasr/ChangeLog b/app-accessibility/yasr/ChangeLog
index 157b2327f8a1..085e0f6de17b 100644
--- a/app-accessibility/yasr/ChangeLog
+++ b/app-accessibility/yasr/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-accessibility/yasr
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/yasr/ChangeLog,v 1.27 2010/09/29 06:29:06 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/yasr/ChangeLog,v 1.28 2013/08/15 05:21:58 teiresias Exp $
+
+ 15 Aug 2013; Christopher Brannon <teiresias@gentoo.org> yasr-0.6.9-r1.ebuild,
+ +files/yasr-0.6.9-automake113.patch, +files/yasr-0.6.9-gettext018.patch:
+ Added a patch to replace the AM_CONFIG_HEADER
+ and remove the AM_PROG_CC_STDC macro calls.
+ Fixes bug #467522.
+ Also fixed bug #422621 (build failure due to autotools issue) by
+ patching the call to AM_GNU_GETTEXT_VERSION.
+ This was a reccurrence of bug #330879 (build fails with gettext 0.18).
29 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> yasr-0.6.9-r1.ebuild:
Replace po/Makefile.in.in with a system copy wrt #330879 by Diego E.
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch b/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch
new file mode 100644
index 000000000000..2fbc32c2e986
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-automake113.patch
@@ -0,0 +1,17 @@
+diff --git a/configure.in b/configure.in
+index d78e8b2..15e8666 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2,11 +2,10 @@ dnl Process this file with autoconf to produce a configure script.
+
+ AC_INIT(yasr, 0.6.9, mgorse@alum.wpi.edu)
+ AM_INIT_AUTOMAKE()
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ AC_ISC_POSIX
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AC_HEADER_STDC
+ AC_PROG_INSTALL
+ dnl Checks for libraries.
diff --git a/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch b/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch
new file mode 100644
index 000000000000..26337dbc6735
--- /dev/null
+++ b/app-accessibility/yasr/files/yasr-0.6.9-gettext018.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.in b/configure.in
+index c26f577..d78e8b2 100644
+--- a/configure.in
++++ b/configure.in
+@@ -57,7 +57,7 @@ fi
+ changequote([,])dnl
+
+ AM_GNU_GETTEXT(external)
+-AM_GNU_GETTEXT_VERSION([0.17])
++AM_GNU_GETTEXT_VERSION([0.18.1])
+
+ AC_OUTPUT([ m4/Makefile
+ Makefile
diff --git a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
index 3bbecc93f5a9..0c8db2e3232d 100644
--- a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
+++ b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/yasr/yasr-0.6.9-r1.ebuild,v 1.5 2010/09/29 06:29:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/yasr/yasr-0.6.9-r1.ebuild,v 1.6 2013/08/15 05:21:58 teiresias Exp $
EAPI=2
inherit autotools eutils
@@ -21,7 +21,9 @@ src_prepare() {
local x=/usr/share/gettext/po/Makefile.in.in
[[ -e $x ]] && cp -f $x po/ #330879
- epatch "${FILESDIR}"/${P}-gcc43.patch \
+ epatch "${FILESDIR}"/${P}-automake113.patch \
+ "${FILESDIR}"/${P}-gettext018.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-remove-m4.patch
rm -r "${S}"/m4