summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-09-22 15:46:03 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-09-22 15:46:03 +0000
commit27c6133311e5066bf25a7081c521a57d37c2a9f7 (patch)
treedb4f468eecad1ceea119134f4a02996ee9889b49 /app-accessibility/sphinx2
parentStable for HPPA (bug #285975). (diff)
downloadgentoo-2-27c6133311e5066bf25a7081c521a57d37c2a9f7.tar.gz
gentoo-2-27c6133311e5066bf25a7081c521a57d37c2a9f7.tar.bz2
gentoo-2-27c6133311e5066bf25a7081c521a57d37c2a9f7.zip
fixed --as-needed issues.
(Portage version: 2.2_rc41/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/sphinx2')
-rw-r--r--app-accessibility/sphinx2/ChangeLog9
-rw-r--r--app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch25
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6.ebuild11
3 files changed, 42 insertions, 3 deletions
diff --git a/app-accessibility/sphinx2/ChangeLog b/app-accessibility/sphinx2/ChangeLog
index b07fd460c09b..7e98dc217d05 100644
--- a/app-accessibility/sphinx2/ChangeLog
+++ b/app-accessibility/sphinx2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/sphinx2
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/ChangeLog,v 1.17 2009/04/01 17:52:38 williamh Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/ChangeLog,v 1.18 2009/09/22 15:46:02 williamh Exp $
+
+ 22 Sep 2009; William Hubbs <williamh@gentoo.org> sphinx2-0.6.ebuild,
+ +files/sphinx2-0.6-as-needed.patch:
+ Fixed --as-needed issues for bug #246719.
+ Thanks to xarthisius.kk@gmail.com for the patch.
01 Apr 2009; William Hubbs <williamh@gentoo.org> -sphinx2-0.4.ebuild:
Removed old version.
diff --git a/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch b/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
new file mode 100644
index 000000000000..0520d4d987e4
--- /dev/null
+++ b/app-accessibility/sphinx2/files/sphinx2-0.6-as-needed.patch
@@ -0,0 +1,25 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 05a4f8a..23d0309 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,5 @@
+-SUBDIRS = libsphinx2 \
+- libsphinx2fe \
++SUBDIRS = libsphinx2fe \
+ libsphinx2ad \
++ libsphinx2 \
+ examples
+
+diff --git a/src/libsphinx2/Makefile.am b/src/libsphinx2/Makefile.am
+index 66f0ac3..537381c 100644
+--- a/src/libsphinx2/Makefile.am
++++ b/src/libsphinx2/Makefile.am
+@@ -88,7 +88,7 @@ libsphinx2_la_SOURCES = \
+ word_fsg.c
+
+
+-# libsphinx2_la_LIBADD = -lc -lm $(top_srcdir)/src/libsphinx2fe/libsphinx2fe.la
++libsphinx2_la_LIBADD = -lc -lm $(top_srcdir)/src/libsphinx2fe/libsphinx2fe.la
+
+ # hjf@cs.brown.edu - Added for Solaris build
+ # LDADD = -L/usr/demo/SOUND/lib/ -laudio
diff --git a/app-accessibility/sphinx2/sphinx2-0.6.ebuild b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
index 8ccfcb013fd1..f4a6571ee187 100644
--- a/app-accessibility/sphinx2/sphinx2-0.6.ebuild
+++ b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/sphinx2-0.6.ebuild,v 1.6 2009/08/21 19:28:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/sphinx2-0.6.ebuild,v 1.7 2009/09/22 15:46:02 williamh Exp $
+
+EAPI="2"
+
+inherit autotools eutils
MY_P=${P/_/}
S=${WORKDIR}/${MY_P}
@@ -14,6 +18,11 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old