summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2013-07-30 03:31:46 +0000
committerChristopher Brannon <teiresias@gentoo.org>2013-07-30 03:31:46 +0000
commit73adc0351df528ca0f94887fa8a352d3a07e872d (patch)
tree0a85ca926369f98f4dccbd4579c756c27b243fd3 /app-accessibility/speechd-el/speechd-el-2.5.ebuild
parentAdd upstream CPE tag (security info) from ChromiumOS. (diff)
downloadgentoo-2-73adc0351df528ca0f94887fa8a352d3a07e872d.tar.gz
gentoo-2-73adc0351df528ca0f94887fa8a352d3a07e872d.tar.bz2
gentoo-2-73adc0351df528ca0f94887fa8a352d3a07e872d.zip
Version bump (bug 451836). Also, removed an old version.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility/speechd-el/speechd-el-2.5.ebuild')
-rw-r--r--app-accessibility/speechd-el/speechd-el-2.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-accessibility/speechd-el/speechd-el-2.5.ebuild b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
new file mode 100644
index 000000000000..a5b04d37750a
--- /dev/null
+++ b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speechd-el/speechd-el-2.5.ebuild,v 1.1 2013/07/30 03:31:46 teiresias Exp $
+
+EAPI="4"
+NEED_EMACS=23
+inherit elisp
+
+DESCRIPTION="Emacs speech support"
+HOMEPAGE="http://www.freebsoft.org/speechd-el"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd-el/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="brltty"
+
+DEPEND=""
+RDEPEND=">=app-accessibility/speech-dispatcher-0.7
+ brltty? ( app-accessibility/brltty )"
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ dobin speechd-log-extractor
+ dodoc ANNOUNCE NEWS README speechd-speak.pdf
+ doinfo speechd-el.info
+}
+
+pkg_postinst() {
+ elog "Execute the following commands from within emacs to get it to speak:"
+ elog " M-x load-library RET speechd-speak RET"
+ elog " M-x speechd-speak RET"
+ elog
+ elog "or add the following to your ~/.emacs file:"
+ elog
+ elog "(autoload 'speechd-speak \"speechd-speak\" nil t)"
+ elog '(speechd-speak)'
+}