summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2010-04-23 07:12:38 +0000
committerJesus Rivero <neurogeek@gentoo.org>2010-04-23 07:12:38 +0000
commitb65232f7dccdca5b72e61f9b614a078ce0c63a6b (patch)
tree1d16b2361db627b62a6cd825ebb5e740edaa82a1 /app-accessibility/speech-tools
parentNeeds gtk-doc-am-1.13 (bug #315953) (diff)
downloadgentoo-2-b65232f7dccdca5b72e61f9b614a078ce0c63a6b.tar.gz
gentoo-2-b65232f7dccdca5b72e61f9b614a078ce0c63a6b.tar.bz2
gentoo-2-b65232f7dccdca5b72e61f9b614a078ce0c63a6b.zip
Removed resynth (bug #253556) and fixed soname bug #224915 by adding a patchset
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/speech-tools')
-rw-r--r--app-accessibility/speech-tools/ChangeLog9
-rw-r--r--app-accessibility/speech-tools/speech-tools-1.2.96_beta-r2.ebuild (renamed from app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild)111
2 files changed, 66 insertions, 54 deletions
diff --git a/app-accessibility/speech-tools/ChangeLog b/app-accessibility/speech-tools/ChangeLog
index f948dbed66ad..ce7ec777206e 100644
--- a/app-accessibility/speech-tools/ChangeLog
+++ b/app-accessibility/speech-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/speech-tools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/ChangeLog,v 1.65 2010/03/13 20:32:58 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/ChangeLog,v 1.66 2010/04/23 07:12:38 neurogeek Exp $
+
+*speech-tools-1.2.96_beta-r2 (23 Apr 2010)
+
+ 23 Apr 2010; Jesus Rivero <neurogeek@gentoo.org>
+ -speech-tools-1.2.96_beta-r1.ebuild, +speech-tools-1.2.96_beta-r2.ebuild:
+ Removed resynth (bug #253556) and fixed soname bug #224915 by adding a
+ patchset
*speech-tools-1.2.96_beta-r1 (13 Mar 2010)
diff --git a/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild b/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r2.ebuild
index ce699bbac9ae..81bfa88d5c2b 100644
--- a/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild
+++ b/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r2.ebuild
@@ -1,104 +1,109 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r1.ebuild,v 1.1 2010/03/13 20:32:58 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/speech-tools-1.2.96_beta-r2.ebuild,v 1.1 2010/04/23 07:12:38 neurogeek Exp $
-inherit eutils toolchain-funcs
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
MY_P=${P/speech-/speech_}
MY_P=${MY_P/_beta/-beta}
DESCRIPTION="Speech tools for Festival Text to Speech engine"
HOMEPAGE="http://www.cstr.ed.ac.uk/projects/speech_tools/"
-SRC_URI="http://www.festvox.org/packed/festival/latest/${MY_P}.tar.gz"
+SRC_URI="http://www.festvox.org/packed/festival/latest/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}-patches.tar.gz"
LICENSE="FESTIVAL BSD as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="esd nas X"
-RDEPEND="esd? ( media-sound/esound )
+DEPEND="esd? ( media-sound/esound )
nas? ( media-libs/nas )
X? ( x11-libs/libX11
x11-libs/libXt )
!<app-accessibility/festival-1.96_beta
!sys-power/powerman"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/speech_tools
-
-src_unpack() {
- local CONFIG=${S}/config/config.in
- unpack ${A}
- epatch "${FILESDIR}"/${P}-gcc42.patch \
- "${FILESDIR}"/${P}-gcc43-include.patch \
- "${FILESDIR}"/${P}-gcc44.patch
+S="${WORKDIR}/speech_tools"
-# set compiler flags for base_class
- sed -i -e "s:-O3:\$(OPTIMISE_CXXFLAGS):" "${S}"/base_class/Makefile
-
- # enable building shared libraries
- sed -i -e "s/#.*\(SHARED=2\)/\1/" ${CONFIG}
+src_prepare() {
+ EPATCH_SUFFIX="patch"
+ epatch
+ sed -i -e 's,{{HORRIBLELIBARCHKLUDGE}},"/usr/$(get_libdir)",' main/siod_main.cc
+}
- use esd && sed -i -e "s/#.*\(INCLUDE_MODULES += ESD_AUDIO\)/\1/" ${CONFIG}
- use nas && sed -i -e "s/#.*\(INCLUDE_MODULES += NAS_AUDIO\)/\1/" ${CONFIG}
- use X || sed -i -e "s/-lX11 -lXt//" "${S}"/config/modules/esd_audio.mak
+src_configure() {
+ local CONFIG=config/config.in
+ sed -i -e 's/@COMPILERTYPE@/gcc42/' ${CONFIG}
+ if use esd; then
+ sed -i -e "s/#.*\(INCLUDE_MODULES += ESD_AUDIO\)/\1/" ${CONFIG}
+ fi
+ if use nas; then
+ sed -i -e "s/#.*\(INCLUDE_MODULES += NAS_AUDIO\)/\1/" ${CONFIG}
+ fi
+ if [ ! use X ]; then
+ sed -i -e "s/-lX11 -lXt//" config/modules/esd_audio.mak
+ fi
+ append-ldflags -Wl,--no-as-needed
+ econf || die
}
src_compile() {
- econf || die
- emake -j1 OPTIMISE_CXXFLAGS="${CXXFLAGS}" OPTIMISE_CCFLAGS="${CFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+ emake -j1 CC="$(tc-getCC)" CXX="$(tc-getCXX)" CC_OTHER_FLAGS="${CFLAGS}" \
+ OPTIMISE_LINKFLAGS="${LDFLAGS}" || die "Compile failed"
}
src_install() {
- dolib.so lib/libest*.so.1*
- dosym libestbase.so.1.2.96.1 /usr/$(get_libdir)/libestbase.so
- dosym libestools.so.1.2.96.1 /usr/$(get_libdir)/libestools.so
- dosym libeststring.so.1.2 /usr/$(get_libdir)/libeststring.so
- dolib.a lib/{libestbase.a,libestools.a,libeststring.a}
-
- cd bin
- for file in *; do
- [ "${file}" = "Makefile" ] && continue
- dobin ${file}
- dstfile="/usr/bin/${file}"
- dosed "s:${S}/testsuite/data:/usr/share/speech-tools/testsuite:g" ${dstfile}
- dosed "s:${S}/bin:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
- dosed "s:${S}/main:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
+ dolib.so lib/libest*.so*
- # This just changes LD_LIBRARY_PATH
- dosed "s:${S}/lib:/usr/$(get_libdir):g" ${dstfile}
- done
+ dodoc "${S}"/README
+ dodoc "${S}"/lib/cstrutt.dtd
- cd "${S}"
- exeinto /usr/$(get_libdir)/speech-tools
- for file in `find main -perm +100 -type f`; do
- doexe ${file}
- done
+ insinto /usr/share/doc/${PF}
+ doins -r lib/example_data
insinto /usr/share/speech-tools
- doins -r config
+ doins -r config base_class
insinto /usr/share/speech-tools/lib
doins -r lib/siod
- insinto /usr/share/doc/${PF}
- doins -r lib/example_data
-
cd include
insinto /usr/include/speech-tools
doins -r *
dosym /usr/include/speech-tools /usr/share/speech-tools/include
- cd "${S}"
- dodoc "${S}"/README
- dodoc "${S}"/lib/cstrutt.dtd
+ cd ../bin
+ for file in *; do
+ [ "${file}" = "Makefile" ] && continue
+ dobin ${file}
+ dstfile="${D}/usr/bin/${file}"
+ sed -i -e "s:${S}/testsuite/data:/usr/share/speech-tools/testsuite:g" ${dstfile}
+ sed -i -e "s:${S}/bin:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
+ sed -i -e "s:${S}/main:/usr/$(get_libdir)/speech-tools:g" ${dstfile}
+
+ # This just changes LD_LIBRARY_PATH
+ sed -i -e "s:${S}/lib:/usr/$(get_libdir):g" ${dstfile}
+ done
+
+ cd "${S}"
+ exeinto /usr/$(get_libdir)/speech-tools
+ for file in `find main -perm +100 -type f`; do
+ doexe ${file}
+ done
#Rename to avoid file collisions. See bug #287983
mv "${D}/usr/bin/dp" "${D}/usr/bin/speech-dp"
+ #Remove /usr/bin/resynth as it is broken. See bug #253556
+ rm "${D}/usr/bin/resynth"
}
pkg_postinst() {
elog "The /usr/bin/dp wrapper script has been renamed to /usr/bin/speech-dp"
elog "due to file collision with other programs."
elog "See bug #287983 for more details"
+
+ elog "The /usr/bin/resynth program has been removed since it is broken"
+ elog "See bug #253556 for more details"
}