summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-09-06 19:35:28 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-09-06 19:35:28 +0000
commit76cd0b4ccf31289b4c54c188ecb9196099fad9a7 (patch)
tree08f6c1a3baa5d4a946c46adcdd65a81795180a0f /app-accessibility/speech-dispatcher
parentRemove unused files. (diff)
downloadgentoo-2-76cd0b4ccf31289b4c54c188ecb9196099fad9a7.tar.gz
gentoo-2-76cd0b4ccf31289b4c54c188ecb9196099fad9a7.tar.bz2
gentoo-2-76cd0b4ccf31289b4c54c188ecb9196099fad9a7.zip
update for bug 281130.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/speech-dispatcher')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog8
-rw-r--r--app-accessibility/speech-dispatcher/metadata.xml1
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild32
3 files changed, 30 insertions, 11 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index bee38c24a7d3..1dc6dfe4d918 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.45 2009/09/04 13:56:54 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.46 2009/09/06 19:35:28 williamh Exp $
+
+ 06 Sep 2009; William Hubbs <williamh@gentoo.org>
+ speech-dispatcher-0.6.7.ebuild, metadata.xml:
+ Update for bug #281130.
+ - I added -D_GNU_SOURCE to the cppflags as suggested by vapier.
+ - I also added support for the espeak use flag.
04 Sep 2009; William Hubbs <williamh@gentoo.org>
-files/speech-dispatcher-0.6.7-glibc-2.10.patch:
diff --git a/app-accessibility/speech-dispatcher/metadata.xml b/app-accessibility/speech-dispatcher/metadata.xml
index b9b5ca12307f..64fdbe0bae0d 100644
--- a/app-accessibility/speech-dispatcher/metadata.xml
+++ b/app-accessibility/speech-dispatcher/metadata.xml
@@ -7,6 +7,7 @@
<email>williamh@gentoo.org</email>
</maintainer>
<use>
+ <flag name='espeak'>Adds support for espeak speech engine</flag>
<flag name='flite'>Adds support for flite speech engine</flag>
</use>
</pkgmetadata>
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
index 9365de6d18b3..7833b2977f75 100644
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild,v 1.5 2009/09/04 13:54:51 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild,v 1.6 2009/09/06 19:35:28 williamh Exp $
-inherit eutils
+EAPI="2"
+
+inherit eutils flag-o-matic
DESCRIPTION="speech-dispatcher speech synthesis interface"
HOMEPAGE="http://www.freebsoft.org/speechd"
@@ -11,31 +13,34 @@ SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc x86"
-IUSE="alsa flite nas pulseaudio python"
+IUSE="alsa +espeak flite nas pulseaudio python"
RDEPEND="dev-libs/dotconf
>=dev-libs/glib-2
alsa? ( media-libs/alsa-lib )
+ espeak? ( app-accessibility/espeak )
flite? ( app-accessibility/flite )
nas? ( media-libs/nas )
pulseaudio? ( media-sound/pulseaudio )
- python? ( dev-lang/python )
- app-accessibility/espeak"
+ python? ( dev-lang/python )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e 's/\(SUBDIRS.*\)python/\1/' src/Makefile.in || die
+src_prepare() {
+ sed -i -e 's/\(SUBDIRS.*\)python/\1/' src/Makefile.in
+ epatch "${FILESDIR}"/${P}-getline-ss.patch
}
-src_compile() {
+src_configure() {
econf \
$(use_with alsa) \
$(use_with flite) \
$(use_with pulseaudio pulse) \
$(use_with nas) || die "configure failed"
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
make all || die "make failed"
}
@@ -56,5 +61,12 @@ src_install() {
}
pkg_postinst() {
+ if ! use espeak; then
+ ewarn
+ ewarn "You have disabled espeak, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn "You must edit ${ROOT}etc/speechd/speechd.conf"
+ fi
+ elog
elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
}