summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-14 22:40:16 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-14 22:40:16 +0000
commit7e8f2bf927ce1a2d2e988c1c566bdea52f0651b7 (patch)
treeaa159f7ed4b16d939defa2f0205f479b5ea7ec0a /app-accessibility/orca
parentBump to 2.24.1. Code cleanups, bug fixes and translation updates. (diff)
downloadgentoo-2-7e8f2bf927ce1a2d2e988c1c566bdea52f0651b7.tar.gz
gentoo-2-7e8f2bf927ce1a2d2e988c1c566bdea52f0651b7.tar.bz2
gentoo-2-7e8f2bf927ce1a2d2e988c1c566bdea52f0651b7.zip
Bump to 2.24.3. Lots of bug fixes.
(Portage version: 2.2_rc20/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/ChangeLog9
-rw-r--r--app-accessibility/orca/orca-2.24.3.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/app-accessibility/orca/ChangeLog b/app-accessibility/orca/ChangeLog
index feaa5dcc0895..3fe227a5560b 100644
--- a/app-accessibility/orca/ChangeLog
+++ b/app-accessibility/orca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/orca
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.54 2008/11/24 19:44:14 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.55 2009/01/14 22:40:16 eva Exp $
+
+*orca-2.24.3 (14 Jan 2009)
+
+ 14 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org> +orca-2.24.3.ebuild:
+ Bump to 2.24.3. Lots of bug fixes.
*orca-2.24.2 (24 Nov 2008)
diff --git a/app-accessibility/orca/orca-2.24.3.ebuild b/app-accessibility/orca/orca-2.24.3.ebuild
new file mode 100644
index 000000000000..b450823f0e39
--- /dev/null
+++ b/app-accessibility/orca/orca-2.24.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-2.24.3.ebuild,v 1.1 2009/01/14 22:40:16 eva Exp $
+
+inherit gnome2 python
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="http://www.gnome.org/projects/orca/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+RDEPEND=">=dev-libs/glib-2.10
+ >=gnome-base/orbit-2
+ >=gnome-extra/at-spi-1.7.6
+ >=gnome-base/libbonobo-2.14
+ >=dev-lang/python-2.4
+ >=dev-python/pygtk-2.12
+ >=dev-python/gnome-python-2.14
+ >=dev-python/pyorbit-2.14
+ >=app-accessibility/gnome-speech-0.3.10
+ >=app-accessibility/gnome-mag-0.12.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-liblouis"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/orca
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/orca
+}