summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2014-02-12 21:21:11 +0000
committerChristopher Brannon <teiresias@gentoo.org>2014-02-12 21:21:11 +0000
commita840820212aa9741b61b9224cc4d510e6c49efa4 (patch)
tree025c34eab7caa700b5ac045d96767786983c72ca /app-accessibility/flite/flite-1.3-r1.ebuild
parentUpdate to python-any-r1. Respect $EPREFIX. Fix path to regulatory.bin. Mov... (diff)
downloadgentoo-2-a840820212aa9741b61b9224cc4d510e6c49efa4.tar.gz
gentoo-2-a840820212aa9741b61b9224cc4d510e6c49efa4.tar.bz2
gentoo-2-a840820212aa9741b61b9224cc4d510e6c49efa4.zip
Bugfixes.
For flite 1.2, 1.3, and 1.4, add a patch to prevent the use of a temporary file. (bug #498020). For flite 1.3, respect LDFLAGS (bug #476810). For flite 1.3, fix build failure (bug #456986). For flite 1.3, allow static flite to be built. USE=static has been broken for a long time. No bug was ever opened, and I just found the problem today. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility/flite/flite-1.3-r1.ebuild')
-rw-r--r--app-accessibility/flite/flite-1.3-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/app-accessibility/flite/flite-1.3-r1.ebuild b/app-accessibility/flite/flite-1.3-r1.ebuild
new file mode 100644
index 000000000000..633d902112c2
--- /dev/null
+++ b/app-accessibility/flite/flite-1.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.3-r1.ebuild,v 1.1 2014/02/12 21:21:11 teiresias Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Flite text to speech engine"
+HOMEPAGE="http://www.speech.cs.cmu.edu/flite/index.html"
+SRC_URI="http://www.speech.cs.cmu.edu/flite/packed/${P}/${P}-release.tar.gz"
+
+LICENSE="BSD freetts public-domain regexp-UofT BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa static"
+
+S=${WORKDIR}/${P}-release
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tempfile.patch
+ if use alsa; then
+ epatch "${FILESDIR}"/${P}-alsa-support.patch
+ fi
+ epatch "${FILESDIR}"/${P}-shared-libs.patch
+ epatch "${FILESDIR}"/${P}-fix-static.patch
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+ epatch "${FILESDIR}"/${P}-libm.patch
+}
+
+src_configure() {
+ local myconf
+ if ! use static ; then
+ myconf="--enable-shared"
+ fi
+ myconf="${myconf} --with-vox=cmu_us_kal16"
+
+ econf ${myconf}
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dobin bin/*
+ dodoc ACKNOWLEDGEMENTS README
+
+ if use static ; then
+ dolib.a lib/*.a
+ else
+ for lib in lib/*.so*; do
+ if [ -f ${lib} ]; then
+ dolib.so ${lib}
+ lib=`basename ${lib}`
+ majlib=`echo ${lib} | sed 's:\(\.so\.[0-9]\)\(\.[0-9]*\)*$:\1:'`
+ noverlib=`echo ${lib} | sed 's:\(\.so\)\(\.[0-9]*\)*$:\1:'`
+
+ dosym ${lib} /usr/lib/${majlib}
+ dosym ${lib} /usr/lib/${noverlib}
+ fi
+ done
+ fi
+
+ insinto /usr/include/flite
+ cd "${S}"/include
+ for file in *.h; do
+ doins ${file}
+ sed -i -e 's:#include "\(.*\)":#include <flite/\1>:g' \
+ "${D}"/usr/include/flite/${file} || die "sed failed"
+ done
+
+ dosym flite/flite.h /usr/include/flite.h
+}