summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-05-08 05:57:14 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-05-08 05:57:14 +0000
commitda0172bf8ce954d026efa35b513512e613013411 (patch)
tree3c3a40c1ff04c7f0ea2837cf8fb78d5bcb4253df /app-accessibility/festival-fi/festival-fi-20041119.ebuild
parentFix h2ph to handle system headers with quotes (diff)
downloadgentoo-2-da0172bf8ce954d026efa35b513512e613013411.tar.gz
gentoo-2-da0172bf8ce954d026efa35b513512e613013411.tar.bz2
gentoo-2-da0172bf8ce954d026efa35b513512e613013411.zip
Initial commit. Closes bug #141113
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/festival-fi/festival-fi-20041119.ebuild')
-rw-r--r--app-accessibility/festival-fi/festival-fi-20041119.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-accessibility/festival-fi/festival-fi-20041119.ebuild b/app-accessibility/festival-fi/festival-fi-20041119.ebuild
new file mode 100644
index 000000000000..742d30592fd5
--- /dev/null
+++ b/app-accessibility/festival-fi/festival-fi-20041119.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival-fi/festival-fi-20041119.ebuild,v 1.1 2009/05/08 05:57:13 neurogeek Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Finnish diphones and text to speech script for festival"
+HOMEPAGE="http://www.ling.helsinki.fi/suopuhe"
+SRC_URI="http://www.ling.helsinki.fi/suopuhe/download/hy_fi_mv_diphone-${PV}.tgz
+ http://phon.joensuu.fi/suopuhe/tulosaineisto/suo_fi_lj-1.0g-20051204.tgz
+ http://www.ling.helsinki.fi/suopuhe/download/lavennin-${PV}.tgz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="perl"
+
+RDEPEND=">=app-accessibility/festival-1.96_beta"
+DEPEND=""
+
+src_prepare(){
+ unpack ${A}
+ cd "${WORKDIR}/lavennin/bin"
+ epatch "${FILESDIR}/${P}_lavennin_path.patch"
+}
+
+src_install() {
+ cd "${WORKDIR}"
+ dodoc festival/lib/voices/finnish/hy_fi_mv_diphone/README.mv
+ rm festival/lib/voices/finnish/hy_fi_mv_diphone/{README.mv,LICENSE}
+ insinto /usr/share/festival/
+ cd festival/lib/
+ doins -r voices/
+ cd "${WORKDIR}/lavennin/"
+ newdoc README.txt README.lavennin
+ dodoc man/*.shtml
+
+ if use perl; then
+
+ newbin bin/lavennin suopuhe-lavennin
+ dodir /usr/share/suopuhe/data/
+ insinto /usr/share/suopuhe
+ doins -r data
+
+ elog "TTS perl script installed as suopuhe-lavennin"
+ fi
+}