summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-05-17 19:52:26 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-05-17 19:52:26 +0000
commit8e6c36643e09e01332a0e79d27af0550236cde29 (patch)
tree0925b3319e5ab3e447eb22d442776a04ef4d692f /app-accessibility/emacspeak
parentRemoving gxslib as it is very experimental in nature and should be developed ... (diff)
downloadgentoo-2-8e6c36643e09e01332a0e79d27af0550236cde29.tar.gz
gentoo-2-8e6c36643e09e01332a0e79d27af0550236cde29.tar.bz2
gentoo-2-8e6c36643e09e01332a0e79d27af0550236cde29.zip
Version bump and fixed quoting.
(Portage version: 2.1.5)
Diffstat (limited to 'app-accessibility/emacspeak')
-rw-r--r--app-accessibility/emacspeak/ChangeLog10
-rw-r--r--app-accessibility/emacspeak/emacspeak-27.0.ebuild4
-rw-r--r--app-accessibility/emacspeak/emacspeak-28.0.ebuild36
-rw-r--r--app-accessibility/emacspeak/files/emacspeak-28.0-espeak.patch26
-rw-r--r--app-accessibility/emacspeak/files/emacspeak-28.0-makefile.patch27
-rw-r--r--app-accessibility/emacspeak/files/emacspeak-28.0-tcl84.patch126
6 files changed, 226 insertions, 3 deletions
diff --git a/app-accessibility/emacspeak/ChangeLog b/app-accessibility/emacspeak/ChangeLog
index 6c8867587d58..68b5efb03cbc 100644
--- a/app-accessibility/emacspeak/ChangeLog
+++ b/app-accessibility/emacspeak/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-accessibility/emacspeak
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.26 2008/01/19 21:30:56 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/ChangeLog,v 1.27 2008/05/17 19:52:25 williamh Exp $
+
+*emacspeak-28.0 (17 May 2008)
+
+ 17 May 2008; William Hubbs <williamh@gentoo.org>
+ +files/emacspeak-28.0-espeak.patch, +files/emacspeak-28.0-makefile.patch,
+ +files/emacspeak-28.0-tcl84.patch, emacspeak-27.0.ebuild,
+ +emacspeak-28.0.ebuild:
+ Version bump and fixed quoting.
19 Jan 2008; William Hubbs <williamh@gentoo.org>
+files/emacspeak-27.0-espeak.patch, files/emacspeak-27.0-tcl84.patch,
diff --git a/app-accessibility/emacspeak/emacspeak-27.0.ebuild b/app-accessibility/emacspeak/emacspeak-27.0.ebuild
index d3cbb0ead4a9..f30c7aa48de7 100644
--- a/app-accessibility/emacspeak/emacspeak-27.0.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-27.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-27.0.ebuild,v 1.2 2008/01/19 21:30:56 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-27.0.ebuild,v 1.3 2008/05/17 19:52:25 williamh Exp $
inherit eutils
@@ -17,7 +17,7 @@ RDEPEND="${DEPEND}
>=dev-tcltk/tclx-8.4"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
epatch "${FILESDIR}"/${P}-espeak.patch
epatch "${FILESDIR}"/${P}-makefile.patch
epatch "${FILESDIR}"/${P}-tcl84.patch
diff --git a/app-accessibility/emacspeak/emacspeak-28.0.ebuild b/app-accessibility/emacspeak/emacspeak-28.0.ebuild
new file mode 100644
index 000000000000..108d24f778e1
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-28.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-28.0.ebuild,v 1.1 2008/05/17 19:52:25 williamh Exp $
+
+inherit eutils
+
+DESCRIPTION="the emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/emacs-22"
+RDEPEND="${DEPEND}
+ >=dev-tcltk/tclx-8.4"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-espeak.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-tcl84.patch
+}
+
+src_compile() {
+ make config || die
+ make emacspeak || die
+}
+
+src_install() {
+ make prefix="${D}"/usr install || die
+ dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+ dohtml -r install-guide user-guide
+ dosed "s:/.*image/::" /usr/bin/emacspeak
+}
diff --git a/app-accessibility/emacspeak/files/emacspeak-28.0-espeak.patch b/app-accessibility/emacspeak/files/emacspeak-28.0-espeak.patch
new file mode 100644
index 000000000000..428ad437bae3
--- /dev/null
+++ b/app-accessibility/emacspeak/files/emacspeak-28.0-espeak.patch
@@ -0,0 +1,26 @@
+--- emacspeak-28.0/servers/linux-espeak/tclespeak.cpp.orig 2008-05-17 12:34:21.000000000 -0500
++++ emacspeak-28.0/servers/linux-espeak/tclespeak.cpp 2008-05-17 12:38:41.000000000 -0500
+@@ -593,20 +593,18 @@
+ continue;
+ }
+
+- char* aLangCode = 1 + voices[i]->languages;
+-
+ snprintf(buffer_i, 3, "%d", aLang);
+ snprintf(buffer_j, 3, "%d", j++);
+ Tcl_SetVar2(interp, "langsynth", buffer_j, buffer_i, 0);
+
+- if (strncmp(aDefaultLang, aLangCode, 2) == 0)
++ if (strncmp(aDefaultLang, (1 + voices[i]->languages), 2) == 0)
+ {
+ Tcl_SetVar2(interp, "langsynth", "current", buffer_i, 0);
+- Tcl_SetVar2(interp, "langcode", "current", aLangCode, 0);
++ Tcl_SetVar2(interp, "langcode", "current", (1 + voices[i]->languages), 0);
+ }
+
+ Tcl_SetVar2(interp, "langlabel", buffer_j, voices[i]->name, 0);
+- Tcl_SetVar2(interp, "langcode", buffer_j, aLangCode, 0);
++ Tcl_SetVar2(interp, "langcode", buffer_j, (1 + voices[i]->languages), 0);
+ Tcl_SetVar2(interp, "langsynth", "top", buffer_j, 0);
+ }
+ }
diff --git a/app-accessibility/emacspeak/files/emacspeak-28.0-makefile.patch b/app-accessibility/emacspeak/files/emacspeak-28.0-makefile.patch
new file mode 100644
index 000000000000..349b85cefda1
--- /dev/null
+++ b/app-accessibility/emacspeak/files/emacspeak-28.0-makefile.patch
@@ -0,0 +1,27 @@
+--- emacspeak-28.0/Makefile.orig 2008-05-16 08:49:54.000000000 -0500
++++ emacspeak-28.0/Makefile 2008-05-16 08:52:53.000000000 -0500
+@@ -149,7 +149,6 @@
+ FORMS =etc/forms/*.el
+ REALAUDIO=realaudio
+ SHOUTCAST=shoutcast
+-HTTPD=servers/httpd
+ ECI=servers/linux-outloud
+ PYLIB=servers/python
+ PYFILES=servers/python/*.py
+@@ -161,7 +160,6 @@
+ servers/software-dtk/DTK \
+ servers/software-dtk/Makefile
+ JS=js/*.js js/jsl.conf js/Makefile
+-TCLHTTPD=${HTTPD}/tts.tcl
+ OUTLOUD=${ECI}/eci.ini \
+ ${ECI}/*.h \
+ ${ECI}/*.cpp \
+@@ -285,8 +283,6 @@
+ $(INSTALL) -m 644 ${JS} $(libdir)/js
+ $(INSTALL) -d $(libdir)/servers
+ $(INSTALL) -d $(libdir)/servers/python
+- $(INSTALL) -d $(libdir)/servers/httpd
+- $(INSTALL) -m 644 ${TCLHTTPD} $(libdir)/servers/tts.tcl
+ $(INSTALL) -d $(libdir)/servers/linux-outloud
+ $(INSTALL) -m 755 ${OUTLOUD} $(libdir)/servers/linux-outloud
+ cp ${PYFILES} $(libdir)/servers/python
diff --git a/app-accessibility/emacspeak/files/emacspeak-28.0-tcl84.patch b/app-accessibility/emacspeak/files/emacspeak-28.0-tcl84.patch
new file mode 100644
index 000000000000..28dd61f92bc5
--- /dev/null
+++ b/app-accessibility/emacspeak/files/emacspeak-28.0-tcl84.patch
@@ -0,0 +1,126 @@
+--- emacspeak-28.0.orig/servers/dtk-exp 2008-03-14 21:06:51.000000000 -0500
++++ emacspeak-28.0/servers/dtk-exp 2008-05-15 22:05:50.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ # $Id: emacspeak-28.0-tcl84.patch,v 1.1 2008/05/17 19:52:26 williamh Exp $
+ # Description: Interfacing to a Dectalk via TCL.
+ # Keywords: Emacspeak, Dectalk, TCL
+@@ -364,13 +364,13 @@
+ fconfigure $tts(write) -encoding ascii
+
+ # Emacspeak sends utf-8
+-fconfigure file0 -encoding utf-8
++fconfigure stdin -encoding utf-8
+
+ tts_initialize
+ set tts(speech_rate) 225
+ set tts(say_rate) [round \
+ [expr $tts(speech_rate) * $tts(char_factor)]]
+-set tts(input) file0
++set tts(input) stdin
+ if {[info exists server_p]} {
+ set tts(input) sock0
+ }
+--- emacspeak-28.0.orig/servers/dtk-soft 2007-06-23 23:12:04.000000000 -0500
++++ emacspeak-28.0/servers/dtk-soft 2008-05-15 21:51:09.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ # Keywords: Emacspeak, Software Dectalk , TCL
+ # {{{ LCD Entry:
+
+--- emacspeak-28.0.orig/servers/espeak 2008-03-14 21:04:31.000000000 -0500
++++ emacspeak-28.0/servers/espeak 2008-05-15 22:06:14.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ # Keywords: Emacspeak, eSpeak , TCL
+ # {{{ LCD Entry:
+
+@@ -504,7 +504,7 @@
+ signal ignore {sigint}
+
+ # Set input encoding to utf-8
+-fconfigure file0 -encoding utf-8
++fconfigure stdin -encoding utf-8
+
+ #initialize eSpeak
+ tts_initialize
+--- emacspeak-28.0.orig/servers/outloud 2008-04-08 22:31:52.000000000 -0500
++++ emacspeak-28.0/servers/outloud 2008-05-15 22:06:39.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ # Keywords: Emacspeak, ViaVoice Outloud , TCL
+ # {{{ LCD Entry:
+
+@@ -471,13 +471,13 @@
+ signal ignore {sigint}
+
+ # Set input encoding to utf-8
+-fconfigure file0 -encoding utf-8
++fconfigure stdin -encoding utf-8
+
+ #initialize outloud
+ tts_initialize
+ set tts(speech_rate) 75
+ beep_initialize
+-set tts(input) file0
++set tts(input) stdin
+ if {[info exists server_p]} {
+ set tts(input) sock0
+ }
+--- emacspeak-28.0.orig/servers/speech-server 2007-07-01 21:12:27.000000000 -0500
++++ emacspeak-28.0/servers/speech-server 2008-05-15 22:08:03.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ # $Id: emacspeak-28.0-tcl84.patch,v 1.1 2008/05/17 19:52:26 williamh Exp $
+ # Description: Speech server
+ #Usage: tcl speech-server port device-specific-script
+--- emacspeak-28.0.orig/servers/ssh-dtk-exp 2008-01-05 14:24:47.000000000 -0600
++++ emacspeak-28.0/servers/ssh-dtk-exp 2008-05-15 22:11:31.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ #$Id: emacspeak-28.0-tcl84.patch,v 1.1 2008/05/17 19:52:26 williamh Exp $
+ #Description: Launch a TTS server on a remote host.
+ #Copyright (C) 1995 -- 2007, T. V. Raman
+@@ -37,7 +37,7 @@
+ set user [lindex $user_host 0]
+ set host [lindex $user_host 1]
+ if {$user == ""} {set user env($USER)}
+-set tcl /usr/bin/tcl
++set tcl /usr/bin/tclsh
+ regsub {/ssh-} $argv0 {/} tts
+ puts stderr "Running <ssh $host -l $user -p $port $tcl $tts>"
+ exec ssh -o StrictHostKeyChecking=no $host \
+--- emacspeak-28.0.orig/servers/ssh-outloud 2007-06-23 22:00:42.000000000 -0500
++++ emacspeak-28.0/servers/ssh-outloud 2008-05-15 22:11:52.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/tcl
++#!/usr/bin/tclsh
+ #$Id: emacspeak-28.0-tcl84.patch,v 1.1 2008/05/17 19:52:26 williamh Exp $
+ #Description: Launch a TTS server on a remote host.
+ #Copyright (C) 1995 -- 2007, T. V. Raman
+@@ -35,7 +35,7 @@
+ set user [lindex $user_host 0]
+ set host [lindex $user_host 1]
+ if {$user == ""} {set user env($USER)}
+-set tcl /usr/bin/tcl
++set tcl /usr/bin/tclsh
+ regsub {/ssh-} $argv0 {/} tts
+ puts stderr "Running <ssh $host -l $user -p $port $tcl $tts>"
+ exec ssh -o StrictHostKeyChecking=no $host \
+--- emacspeak-28.0.orig/servers/tts-lib.tcl 2007-06-23 23:12:04.000000000 -0500
++++ emacspeak-28.0/servers/tts-lib.tcl 2008-05-15 22:57:16.000000000 -0500
+@@ -35,6 +35,8 @@
+ # the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
+ #
+
++package require Tclx
++
+ # }}}
+ # {{{ sync state
+ proc tts_sync_state {punct capitalize allcaps splitcaps rate} {