summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2013-12-11 01:20:33 +0000
committerChristopher Brannon <teiresias@gentoo.org>2013-12-11 01:20:33 +0000
commit44911e10ba6b480c46d121f37c31eae8b7ac734d (patch)
tree783e70d6a84fb96d9bca9fb034d08a4c2885eb7a /app-accessibility/emacspeak/emacspeak-9999.ebuild
parentSecurity cleanup wrt bug 462458 (diff)
downloadgentoo-2-44911e10ba6b480c46d121f37c31eae8b7ac734d.tar.gz
gentoo-2-44911e10ba6b480c46d121f37c31eae8b7ac734d.tar.bz2
gentoo-2-44911e10ba6b480c46d121f37c31eae8b7ac734d.zip
Upgrade and bug fixes.
Add ebuild for emacspeak 39.0. Move servers/ out of /usr/share, since it can contain ELF files (closes bug #298012). Remove the /usr/bin/emacspeak script downstream, since it is known to be broken. Emacspeak's author consistently recommends against its use. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'app-accessibility/emacspeak/emacspeak-9999.ebuild')
-rw-r--r--app-accessibility/emacspeak/emacspeak-9999.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/app-accessibility/emacspeak/emacspeak-9999.ebuild b/app-accessibility/emacspeak/emacspeak-9999.ebuild
index 6f55decd9357..7b8b3bda3df0 100644
--- a/app-accessibility/emacspeak/emacspeak-9999.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-9999.ebuild,v 1.6 2013/07/09 02:25:08 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/emacspeak/emacspeak-9999.ebuild,v 1.7 2013/12/11 01:20:33 teiresias Exp $
EAPI=5
@@ -49,14 +49,28 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install
+ rm "${D}/usr/bin/emacspeak"
if use espeak; then
pushd servers/linux-espeak > /dev/null || die
emake DESTDIR="${D}" install
popd > /dev/null || die
fi
+ install -dm755 "${D}/usr/$(get_libdir)/emacspeak" || die
+ mv "${D}/usr/share/emacs/site-lisp/emacspeak/servers" \
+ "${D}/usr/$(get_libdir)/emacspeak/servers" || die
+ dosym "/usr/$(get_libdir)/emacspeak/servers" \
+ /usr/share/emacs/site-lisp/emacspeak/servers
dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
dohtml -r install-guide user-guide
cd "${D}/usr/share/emacs/site-lisp/${PN}"
rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
user-guide || die
}
+
+pkg_postinst() {
+ elog "As of version 39.0 and later, the /usr/bin/emacspeak"
+ elog "shell script has been removed downstream in Gentoo."
+ elog "You should launch emacspeak by another method, for instance"
+ elog " by adding the following to your ~/.emacs file:"
+ elog '(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")'
+}