summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-07-05 07:26:14 +0000
committerPacho Ramos <pacho@gentoo.org>2014-07-05 07:26:14 +0000
commit8c3687c22937929183c8809340869189ba9b25b1 (patch)
tree2abb786ac5a0712269ccb3db73ca54b8ed200147 /app-accessibility/eflite
parentupdate test phase (diff)
downloadgentoo-2-8c3687c22937929183c8809340869189ba9b25b1.tar.gz
gentoo-2-8c3687c22937929183c8809340869189ba9b25b1.tar.bz2
gentoo-2-8c3687c22937929183c8809340869189ba9b25b1.zip
Make it compatible with flite-1.4 (#463556 by Chris Brannon)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-accessibility/eflite')
-rw-r--r--app-accessibility/eflite/ChangeLog11
-rw-r--r--app-accessibility/eflite/eflite-0.4.1-r1.ebuild46
-rw-r--r--app-accessibility/eflite/files/eflite-0.4.1-flite14.patch12
3 files changed, 66 insertions, 3 deletions
diff --git a/app-accessibility/eflite/ChangeLog b/app-accessibility/eflite/ChangeLog
index 3a6c73c79f16..8cc52005ffe5 100644
--- a/app-accessibility/eflite/ChangeLog
+++ b/app-accessibility/eflite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/eflite
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/eflite/ChangeLog,v 1.34 2012/05/23 22:57:36 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/eflite/ChangeLog,v 1.35 2014/07/05 07:26:14 pacho Exp $
+
+*eflite-0.4.1-r1 (05 Jul 2014)
+
+ 05 Jul 2014; Pacho Ramos <pacho@gentoo.org> +eflite-0.4.1-r1.ebuild,
+ +files/eflite-0.4.1-flite14.patch:
+ Make it compatible with flite-1.4 (#463556 by Chris Brannon)
23 May 2012; Mike Frysinger <vapier@gentoo.org> eflite-0.4.1.ebuild:
Inherit user eclass for enewuser/etc...
@@ -128,4 +134,3 @@
21 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> eflite-0.3.8.ebuild,
metadata.xml, files/eflite-0.3.8-shared_flite.patch:
Initial import. Ebuild by dmwaters and me. Closes bug #45178.
-
diff --git a/app-accessibility/eflite/eflite-0.4.1-r1.ebuild b/app-accessibility/eflite/eflite-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..cdbecdbdae5b
--- /dev/null
+++ b/app-accessibility/eflite/eflite-0.4.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/eflite/eflite-0.4.1-r1.ebuild,v 1.1 2014/07/05 07:26:14 pacho Exp $
+
+EAPI="5"
+inherit autotools eutils user
+
+DESCRIPTION="A speech server that allows emacspeak and other screen readers to interact with festival lite."
+HOMEPAGE="http://eflite.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+16k_voice"
+
+DEPEND=">=app-accessibility/flite-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's:/etc/es.conf:/etc/eflite/es.conf:g' *
+ epatch "${FILESDIR}"/${PN}-0.4.1-flite14.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use 16k_voice; then
+ myconf='--with-vox=cmu_us_kal16'
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ einstall
+ dodoc ChangeLog README INSTALL eflite_test.txt
+
+ insinto /etc/eflite
+ doins "${FILESDIR}"/es.conf
+
+ newinitd "${FILESDIR}"/eflite.rc eflite
+}
+
+pkg_postinst() {
+ enewgroup speech
+}
diff --git a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
new file mode 100644
index 000000000000..4628ca89cca1
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
@@ -0,0 +1,12 @@
+diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
+--- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
++++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
+@@ -34,7 +34,7 @@
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
+
+ fs.o: fs.c
+- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
++ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
+
+ tone.o: tone.c
+ $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<