summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-06-09 03:50:08 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-06-09 03:50:08 +0000
commitc0bf7dd86a7bdb3dc2ae89c28900dd69c6346834 (patch)
treeb3220a8b206a23b50c41381c093f094cb562211e /app-accessibility/dasher
parentWe need libbeagle instead of beagle, and starting from version 0.3.0. Thanks ... (diff)
downloadgentoo-2-c0bf7dd86a7bdb3dc2ae89c28900dd69c6346834.tar.gz
gentoo-2-c0bf7dd86a7bdb3dc2ae89c28900dd69c6346834.tar.bz2
gentoo-2-c0bf7dd86a7bdb3dc2ae89c28900dd69c6346834.zip
Add patch to fix build w/ GCC 4.3. Bug #211589.
(Portage version: 2.2_pre7-r1/cvs/Linux 2.6.25-gentoo-r3 Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz)
Diffstat (limited to 'app-accessibility/dasher')
-rw-r--r--app-accessibility/dasher/ChangeLog6
-rw-r--r--app-accessibility/dasher/dasher-4.7.3.ebuild6
-rw-r--r--app-accessibility/dasher/files/dasher-4.7.3-gcc-4.3.patch10
3 files changed, 20 insertions, 2 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 5e2f6a700afc..286372ffdca7 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.123 2008/04/09 22:03:44 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.124 2008/06/09 03:50:07 dirtyepic Exp $
+
+ 09 Jun 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/dasher-4.7.3-gcc-4.3.patch, dasher-4.7.3.ebuild:
+ Add patch to fix build w/ GCC 4.3. Bug #211589.
*dasher-4.7.3 (09 Apr 2008)
diff --git a/app-accessibility/dasher/dasher-4.7.3.ebuild b/app-accessibility/dasher/dasher-4.7.3.ebuild
index 89eebc4c6c56..02149172b905 100644
--- a/app-accessibility/dasher/dasher-4.7.3.ebuild
+++ b/app-accessibility/dasher/dasher-4.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.7.3.ebuild,v 1.1 2008/04/09 22:03:44 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.7.3.ebuild,v 1.2 2008/06/09 03:50:07 dirtyepic Exp $
WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="1.8"
@@ -71,6 +71,10 @@ src_unpack() {
# Fix build with --as-needed (upstream bug #525028)
epatch "${FILESDIR}/${PN}-4.7.0-as-needed.patch"
+ # https://bugs.gentoo.org/211589
+ # https://bugzilla.gnome.org/522121
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+
eautomake
intltoolize --force || die "intltoolize failed"
}
diff --git a/app-accessibility/dasher/files/dasher-4.7.3-gcc-4.3.patch b/app-accessibility/dasher/files/dasher-4.7.3-gcc-4.3.patch
new file mode 100644
index 000000000000..32a49491b936
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.7.3-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- dasher-4.7.3/Src/Gtk2/dasher_action_speech.cpp.old 2008-06-06 20:54:34.098275404 +0200
++++ dasher-4.7.3/Src/Gtk2/dasher_action_speech.cpp 2008-06-06 20:55:38.331005219 +0200
+@@ -8,6 +8,7 @@
+ #include <glib/gi18n.h>
+ #include <gnome-speech/gnome-speech.h>
+ #include <libbonobo.h>
++#include <cstring>
+ //#include <libintl.h>
+ //#include <string.h>
+