summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-09-25 01:50:20 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-09-25 01:50:20 +0000
commit2bb15399b08d8c41f864b4a994d019abedbfdda2 (patch)
treeeda4480f71ed846341a7729afb6f8a060f7641c0 /app-accessibility/brltty
parentVersion bump. Includes ABI compatible fix for CVE-2008-3281, security fix for... (diff)
downloadgentoo-2-2bb15399b08d8c41f864b4a994d019abedbfdda2.tar.gz
gentoo-2-2bb15399b08d8c41f864b4a994d019abedbfdda2.tar.bz2
gentoo-2-2bb15399b08d8c41f864b4a994d019abedbfdda2.zip
Various build fixes - gcc 4.3, autoconf-2.62, parallel build. Patches from
Fedora. Fix X and bluetooth USE flags. (Portage version: 2.2_rc9/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-accessibility/brltty')
-rw-r--r--app-accessibility/brltty/ChangeLog9
-rw-r--r--app-accessibility/brltty/brltty-3.10.ebuild32
-rw-r--r--app-accessibility/brltty/files/brltty-3.10-api-socket-dir.patch26
-rw-r--r--app-accessibility/brltty/files/brltty-3.9-autoconf.patch31
-rw-r--r--app-accessibility/brltty/files/brltty-3.9-gnusource.patch17
-rw-r--r--app-accessibility/brltty/files/brltty-3.9-parallel.patch20
6 files changed, 127 insertions, 8 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index aeeb686f5f2d..9e620fa55134 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/brltty
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.77 2008/09/06 19:52:16 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.78 2008/09/25 01:50:19 dirtyepic Exp $
+
+ 25 Sep 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/brltty-3.9-autoconf.patch, +files/brltty-3.9-gnusource.patch,
+ +files/brltty-3.9-parallel.patch, +files/brltty-3.10-api-socket-dir.patch,
+ brltty-3.10.ebuild:
+ Various build fixes - gcc 4.3, autoconf-2.62, parallel build. Patches from
+ Fedora. Fix X and bluetooth USE flags.
*brltty-3.10 (06 Sep 2008)
diff --git a/app-accessibility/brltty/brltty-3.10.ebuild b/app-accessibility/brltty/brltty-3.10.ebuild
index 757bb2c7dd97..02c8dee81950 100644
--- a/app-accessibility/brltty/brltty-3.10.ebuild
+++ b/app-accessibility/brltty/brltty-3.10.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.10.ebuild,v 1.1 2008/09/06 19:52:16 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.10.ebuild,v 1.2 2008/09/25 01:50:19 dirtyepic Exp $
FINDLIB_USE="ocaml"
-inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic
+inherit autotools findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic
DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
HOMEPAGE="http://mielke.cc/brltty/"
@@ -29,14 +29,32 @@ DEPEND="java? ( >=virtual/jdk-1.4 )
RDEPEND="java? ( >=virtual/jre-1.4 )
${COMMON_DEP}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3.9-gnusource.patch
+ epatch "${FILESDIR}"/${PN}-3.9-parallel.patch
+ epatch "${FILESDIR}"/${PN}-3.9-autoconf.patch
+ epatch "${FILESDIR}"/${PN}-3.10-api-socket-dir.patch
+
+ eautoconf
+}
+
src_compile() {
local JAVAC_CONF=""
if use java; then
append-flags "$(java-pkg_get-jni-cflags)"
JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
fi
- econf --prefix=/ \
- $(use_enable bluetooth) \
+
+ # override prefix in order to install into /
+ # braille terminal needs to be available as soon in the boot process as
+ # possible
+ econf \
+ --prefix=/ \
+ --includedir=/usr/include \
+ $(use_enable bluetooth bluetooth-support) \
$(use_enable gpm) \
$(use_enable iconv) \
$(use_enable icu) \
@@ -46,8 +64,8 @@ src_compile() {
$(use_enable python python-bindings) \
$(use_enable usb usb-support) \
$(use_enable tcl tcl-bindings) \
- $(use_with X x) \
- --includedir=/usr/include || die
+ $(use_enable X x) \
+ || die
emake JAVAC="${JAVAC_CONF}" || die
}
@@ -55,7 +73,7 @@ src_install() {
if use ocaml; then
findlib_src_preinst
fi
- make INSTALL_PROGRAM="\${INSTALL_SCRIPT}" INSTALL_ROOT="${D}" install || die
+ emake INSTALL_PROGRAM="\${INSTALL_SCRIPT}" INSTALL_ROOT="${D}" install || die
if use java; then
# make install puts the _java.so there, and no it's not $(get_libdir)
diff --git a/app-accessibility/brltty/files/brltty-3.10-api-socket-dir.patch b/app-accessibility/brltty/files/brltty-3.10-api-socket-dir.patch
new file mode 100644
index 000000000000..65b08bc162f0
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-3.10-api-socket-dir.patch
@@ -0,0 +1,26 @@
+diff -Naur brltty-3.10-orig/common.mk brltty-3.10/common.mk
+--- brltty-3.10-orig/common.mk 2008-07-16 16:19:54.000000000 -0600
++++ brltty-3.10/common.mk 2008-09-22 21:53:19.000000000 -0600
+@@ -73,8 +73,9 @@
+ install-apihdr-directory:
+ $(INSTALL_DIRECTORY) $(INSTALL_APIHDR_DIRECTORY)
+
++INSTALL_API_SOCKET_DIRECTORY = $(INSTALL_ROOT)$(API_SOCKET_DIRECTORY)
+ install-apisoc-directory:
+- -$(INSTALL_DIRECTORY) -m 1777 $(API_SOCKET_DIRECTORY)
++ -$(INSTALL_DIRECTORY) -m 1777 $(INSTALL_API_SOCKET_DIRECTORY)
+
+ clean::
+ -rm -f *.$O *.auto.h *.auto.c core implib.a
+diff -Naur brltty-3.10-orig/configure.ac brltty-3.10/configure.ac
+--- brltty-3.10-orig/configure.ac 2008-09-22 21:36:40.000000000 -0600
++++ brltty-3.10/configure.ac 2008-09-22 21:52:11.000000000 -0600
+@@ -535,7 +535,7 @@
+ api_dynamic_library="api-dynamic-library"
+ install_api_libraries="install-api-libraries"
+ uninstall_api_libraries="uninstall-api-libraries"
+- api_socket_path="${localstatedir}/lib/BrlAPI"
++ api_socket_path="${localstatedir}/BrlAPI"
+
+ case "${host_os}"
+ in
diff --git a/app-accessibility/brltty/files/brltty-3.9-autoconf.patch b/app-accessibility/brltty/files/brltty-3.9-autoconf.patch
new file mode 100644
index 000000000000..56a506a57ccc
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-3.9-autoconf.patch
@@ -0,0 +1,31 @@
+2008-09-12 Stepan Kasal <skasal@redhat.com>
+
+ * aclocal.m4 (BRLTTY_HELP_STRING, BRLTTY_TEXT_TABLE,
+ BRLTTY_ATTRIBUTES_TABLE): Expand parameters to AC_HELP_STRING
+ and m4_text_wrap, to be compatible with Autoconf 2.62+.
+
+--- brltty-3.9.orig/aclocal.m4.orig 2007-10-17 17:19:31.000000000 +0200
++++ brltty-3.9.orig/aclocal.m4 2008-09-12 18:05:21.000000000 +0200
+@@ -144,7 +144,7 @@
+
+ AC_DEFUN([BRLTTY_HELP_STRING], [dnl
+ AC_HELP_STRING([$1], patsubst([$2], [
+-.*$]), [brltty_help_prefix])dnl
++.*$]), m4_defn([brltty_help_prefix]))dnl
+ patsubst(patsubst([$2], [\`[^
+ ]*]), [
+ ], [\&brltty_help_prefix])[]dnl
+@@ -384,11 +384,11 @@
+
+ AC_DEFUN([BRLTTY_TEXT_TABLE], [dnl
+ define([brltty_tables_text], ifdef([brltty_tables_text], [brltty_tables_text])[
+-m4_text_wrap([$2], [ ], [- m4_format([%-8s ], [$1])], brltty_help_width)])])
++m4_text_wrap([$2], [ ], [- ]m4_format([%-8s ], [$1]), brltty_help_width)])])
+
+ AC_DEFUN([BRLTTY_ATTRIBUTES_TABLE], [dnl
+ define([brltty_tables_attributes], ifdef([brltty_tables_attributes], [brltty_tables_attributes])[
+-m4_text_wrap([$2], [ ], [- m4_format([%-10s ], [$1])], brltty_help_width)])])
++m4_text_wrap([$2], [ ], [- ]m4_format([%-10s ], [$1]), brltty_help_width)])])
+
+ AC_DEFUN([BRLTTY_SUMMARY_BEGIN], [dnl
+ brltty_summary_lines="Options Summary:"
diff --git a/app-accessibility/brltty/files/brltty-3.9-gnusource.patch b/app-accessibility/brltty/files/brltty-3.9-gnusource.patch
new file mode 100644
index 000000000000..b80508c00ac7
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-3.9-gnusource.patch
@@ -0,0 +1,17 @@
+2008-09-17 Stepan Kasal <skasal@redhat.com>
+
+ * configure.ac: Add -D_GNU_SOURCE to get struct ucred from
+ socket.h.
+
+diff -up brltty-3.10/configure.ac.gnusource brltty-3.10/configure.ac
+--- brltty-3.10/configure.ac.gnusource 2008-07-17 00:19:54.000000000 +0200
++++ brltty-3.10/configure.ac 2008-09-17 12:44:28.000000000 +0200
+@@ -779,7 +779,7 @@ AC_CACHE_CHECK([for system-dependent com
+ case "${host_os}"
+ in
+ linux*|gnu*|kfreebsd*)
+- brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_XOPEN_SOURCE_EXTENDED"
++ brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_XOPEN_SOURCE_EXTENDED -D_GNU_SOURCE"
+ ;;
+ solaris*)
+ brltty_cv_prog_cc_sysflags="-D_XOPEN_SOURCE=500 -D__EXTENSIONS__"
diff --git a/app-accessibility/brltty/files/brltty-3.9-parallel.patch b/app-accessibility/brltty/files/brltty-3.9-parallel.patch
new file mode 100644
index 000000000000..e10b9683a5cb
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-3.9-parallel.patch
@@ -0,0 +1,20 @@
+2008-09-17 Stepan Kasal <skasal@redhat.com>
+
+ * Programs/Makefile.in (braille-drivers): Add
+ prerequisity `all' to prevent race of this make with nested
+ "make brlapi" when parallel make is used. Recursive make is
+ harmful.
+
+diff -up brltty-3.10/Makefile.in.parallel brltty-3.10/Makefile.in
+diff -up brltty-3.10/Programs/Makefile.in.parallel brltty-3.10/Programs/Makefile.in
+--- brltty-3.10/Programs/Makefile.in.parallel 2008-07-17 00:19:08.000000000 +0200
++++ brltty-3.10/Programs/Makefile.in 2008-09-17 11:24:35.000000000 +0200
+@@ -399,7 +399,7 @@ apitest.$O:
+
+ ###############################################################################
+
+-braille-drivers: txt2hlp
++braille-drivers: txt2hlp api
+ for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
+ do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-all) || exit 1; \
+ done