summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-25 15:57:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-25 15:57:07 +0000
commitcb8baea0ee8c83a52191a737b7a5c7a3d7788c9d (patch)
tree7c6edc3f7ba67997f526c514e3863e57a579bfd9 /app-accessibility/SphinxTrain
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-cb8baea0ee8c83a52191a737b7a5c7a3d7788c9d.tar.gz
gentoo-2-cb8baea0ee8c83a52191a737b7a5c7a3d7788c9d.tar.bz2
gentoo-2-cb8baea0ee8c83a52191a737b7a5c7a3d7788c9d.zip
love thy libc
Diffstat (limited to 'app-accessibility/SphinxTrain')
-rw-r--r--app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
index 1c3b37f51a2b..899c4a60be8b 100644
--- a/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
+++ b/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
@@ -1,44 +1,37 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild,v 1.4 2004/06/24 21:25:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild,v 1.5 2004/06/25 15:53:10 vapier Exp $
inherit eutils
-S=${WORKDIR}/${PN}
-DESCRIPTION="SphinxTrain - Speech Recognition (Training Module)"
+DESCRIPTION="Speech Recognition (Training Module)"
HOMEPAGE="http://www.speech.cs.cmu.edu/SphinxTrain/"
SRC_URI="http://www.speech.cs.cmu.edu/${PN}/${P}-beta.tar.gz"
-SLOT="0"
+
LICENSE="BSD as-is"
+SLOT="0"
KEYWORDS="x86 ~ppc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-accessibility/sphinx2
app-accessibility/festival"
+S=${WORKDIR}/${PN}
+
src_unpack() {
unpack ${A}
cd ${S}
-
epatch ${FILESDIR}/gcc.patch
}
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- dodoc etc/*cfg
- dobin bin.*/*
- dodoc README
+src_install() {
+ dobin bin.*/* || die
+ dodoc README etc/*cfg
dohtml doc/*[txt html sgml]
}
pkg_postinst() {
- einfo
einfo "Detailed usage and training instructions can be found at"
einfo "http://www.speech.cs.cmu.edu/SphinxTrain/"
- einfo
}