summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-24 22:33:37 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-24 22:33:37 +0000
commitfdbc4d79b00e4d4827615afcdc3178b7b227e4c4 (patch)
tree21cb351416856c8e122300cd36e2f5d46addcc59
parentVersion bump with improvements from Bugs Bunny <anarchpenguin@gmail.com>, clo... (diff)
downloadgentoo-2-fdbc4d79b00e4d4827615afcdc3178b7b227e4c4.tar.gz
gentoo-2-fdbc4d79b00e4d4827615afcdc3178b7b227e4c4.tar.bz2
gentoo-2-fdbc4d79b00e4d4827615afcdc3178b7b227e4c4.zip
Version bump.
(Portage version: 2.1.2.7)
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-4.21.ebuild58
-rw-r--r--sys-apps/file/files/digest-file-4.213
3 files changed, 67 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index ab2c588677f4..f902776751fe 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.136 2007/04/07 10:04:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.137 2007/05/24 22:33:37 vapier Exp $
+
+*file-4.21 (24 May 2007)
+
+ 24 May 2007; Mike Frysinger <vapier@gentoo.org> +file-4.21.ebuild:
+ Version bump.
*file-4.20-r1 (07 Apr 2007)
diff --git a/sys-apps/file/file-4.21.ebuild b/sys-apps/file/file-4.21.ebuild
new file mode 100644
index 000000000000..efa3f9e45292
--- /dev/null
+++ b/sys-apps/file/file-4.21.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.21.ebuild,v 1.1 2007/05/24 22:33:37 vapier Exp $
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/digest-file-4.21 b/sys-apps/file/files/digest-file-4.21
new file mode 100644
index 000000000000..b206200b67af
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.21
@@ -0,0 +1,3 @@
+MD5 9e3503116f4269a1be70220ee2234b0e file-4.21.tar.gz 549938
+RMD160 c8cfee27ba7a033bae355e458921eac39913b1e0 file-4.21.tar.gz 549938
+SHA256 6f5644d56cc603138533158076a6cb41cd33c33d27e5310cb76cb6576151ca67 file-4.21.tar.gz 549938