summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-12 18:34:05 +0000
committerJustin Lecher <jlec@gentoo.org>2012-11-12 18:34:05 +0000
commitfd7681431b2c90da2395ba999e3b68abbee8eff3 (patch)
treef82bc9715188cf0673e1cd608efd1ba79f392c10
parentCorrecting sys-libs/ldb version, bug #442416 (diff)
downloadgentoo-2-fd7681431b2c90da2395ba999e3b68abbee8eff3.tar.gz
gentoo-2-fd7681431b2c90da2395ba999e3b68abbee8eff3.tar.bz2
gentoo-2-fd7681431b2c90da2395ba999e3b68abbee8eff3.zip
net-analyzer/linkchecker: Version Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
-rw-r--r--net-analyzer/linkchecker/ChangeLog7
-rw-r--r--net-analyzer/linkchecker/linkchecker-8.2.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 377dddf006ca..f7e24385da3f 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.81 2012/10/14 14:23:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.82 2012/11/12 18:34:05 jlec Exp $
+
+*linkchecker-8.2 (12 Nov 2012)
+
+ 12 Nov 2012; Justin Lecher <jlec@gentoo.org> +linkchecker-8.2.ebuild:
+ Version Bump
*linkchecker-8.1 (14 Oct 2012)
diff --git a/net-analyzer/linkchecker/linkchecker-8.2.ebuild b/net-analyzer/linkchecker/linkchecker-8.2.ebuild
new file mode 100644
index 000000000000..63be0de82e1f
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-8.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-8.2.ebuild,v 1.1 2012/11/12 18:34:05 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 2.6 3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion-r1 distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/ http://pypi.python.org/pypi/linkchecker/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login nagios syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND="
+ doc? ( x11-libs/qt-assistant:4 )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/8.0-missing-files.patch \
+ "${FILESDIR}"/7.0-unbundle.patch \
+ "${FILESDIR}"/${PN}-8.0-desktop.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ delete_gui() {
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ }
+ python_execute_function -q delete_gui
+ fi
+ if use doc; then
+ dohtml doc/html/*
+ fi
+ use bash-completion && dobashcomp config/linkchecker-completion
+ insinto /usr/$(get_libdir)/nagios/plugins
+ use nagios && doins linkchecker-nagios
+}