summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-07 15:08:00 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-07 15:08:00 +0000
commitfd3503d430fcd2b3d8d4fece3e52896466aca8e0 (patch)
treeaa5e72b55baf30adbc36c58251b653955f5c1a96
parentStable on sparc (diff)
downloadgentoo-2-fd3503d430fcd2b3d8d4fece3e52896466aca8e0.tar.gz
gentoo-2-fd3503d430fcd2b3d8d4fece3e52896466aca8e0.tar.bz2
gentoo-2-fd3503d430fcd2b3d8d4fece3e52896466aca8e0.zip
Revision bump; new gentoo-bashcomp release including bug fixes, as well as new webapp-config and portageq completion. Also emerge -C and equery now support completion on package names only.
(Portage version: 2.0.51.16)
-rw-r--r--app-shells/bash-completion/ChangeLog10
-rw-r--r--app-shells/bash-completion/Manifest14
-rw-r--r--app-shells/bash-completion/bash-completion-20050121-r2.ebuild83
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-20050121-r22
4 files changed, 97 insertions, 12 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index b36bb049ad69..77914909cc7f 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.104 2005/02/04 12:51:46 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.105 2005/02/07 15:08:00 ka0ttic Exp $
+
+*bash-completion-20050121-r2 (07 Feb 2005)
+
+ 07 Feb 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +bash-completion-20050121-r2.ebuild:
+ Revision bump; new gentoo-bashcomp release including bug fixes, as well as
+ new webapp-config and portageq completion. Also emerge -C and equery now
+ support completion on package names only.
*bash-completion-20050121-r1 (04 Feb 2005)
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 20cda68b7df7..35c33176faee 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,21 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 966a1b97060ac3708d22d088e3cf49d6 bash-completion-20041017-r3.ebuild 2621
MD5 d40377e38750d274590de97e86b57783 bash-completion-20050121-r1.ebuild 2705
-MD5 bf330d4b08959722d3be5a8f42aa4c83 ChangeLog 16894
+MD5 fafc5847fbeb0e18b6763e9138095d7f ChangeLog 17223
MD5 00e8cae3d9ece63e4be61f4a2b3afd5e metadata.xml 930
+MD5 7544b0ab12cff56db3bae0568efe5a19 bash-completion-20050121-r2.ebuild 2720
MD5 4406981db9a6c4f413d3f9f4b14eae91 files/gentoo-bashcomp-20050117-equery.diff 3329
MD5 9aca91cdcddd5454ebc4f17efe465d71 files/digest-bash-completion-20041017-r3 152
MD5 b6b11ab0684a97cfd9a9ba78f5fa9f9a files/20041017-rcs.diff 574
MD5 35fc8232b26ca995623692bea7df2e5d files/digest-bash-completion-20050121-r1 152
+MD5 7a421855615dce0df4bb65ce82852a0e files/digest-bash-completion-20050121-r2 152
MD5 3b7f1d6155d6deff5812264ef6bc4c07 files/bash-completion 724
MD5 64ca0b5063d0874c6104a4b174cb0d40 files/20050121-gentoo.diff 1894
MD5 61eddfb92948b070333a59498edf5266 files/20041017-gentoo.diff 2032
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCA3BTEZCkKN40op4RAgqzAKDByxVptmyUeXSI2NS5E92JOa0XGgCggPAB
-ehbzw1Xt5M8cKZ79hrDoCJI=
-=exeS
------END PGP SIGNATURE-----
diff --git a/app-shells/bash-completion/bash-completion-20050121-r2.ebuild b/app-shells/bash-completion/bash-completion-20050121-r2.ebuild
new file mode 100644
index 000000000000..720377f7621b
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20050121-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20050121-r2.ebuild,v 1.1 2005/02/07 15:08:00 ka0ttic Exp $
+
+inherit eutils
+
+GENCOMP_VERS="20050207"
+
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2
+ http://download.berlios.de/gentoo-bashcomp/gentoo-bashcomp-${GENCOMP_VERS}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+RDEPEND="|| (
+ >=app-shells/bash-2.05a
+ app-shells/zsh
+ )"
+
+S="${WORKDIR}/${PN/-/_}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo.diff
+# cd ${WORKDIR}/gentoo-bashcomp-${GENCOMP_VERS}
+# epatch ${FILESDIR}/gentoo-bashcomp-${GENCOMP_VERS}-XXX.diff
+}
+
+src_install() {
+ insinto /etc
+ doins bash_completion || die "failed to install bash_completion"
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/bash-completion || die "failed to install profile.d"
+
+ # dev-util/subversion provides an extremely superior completion
+ rm contrib/subversion
+ insinto /usr/share/bash-completion
+ doins contrib/* || die "failed to install contrib completions"
+
+ dodoc Changelog README
+
+ # gentoo-bashcomp
+ cd ${WORKDIR}/gentoo-bashcomp-${GENCOMP_VERS}
+ doins gentoo || die "failed to install gentoo completions"
+ dodir /etc/bash_completion.d
+ dosym ../../usr/share/bash-completion/gentoo /etc/bash_completion.d/gentoo \
+ || die "dosym gentoo-bashcomp failed"
+ docinto gentoo
+ dodoc AUTHORS TODO ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && . /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional complete functions can be enabled by symlinking them from"
+ einfo "/usr/share/bash-completion to /etc/bash_completion.d"
+
+ local g="${ROOT}/etc/bash_completion.d/gentoo"
+ if [[ -e "${g}" && ! -L "${g}" ]] ; then
+ echo
+ ewarn "The gentoo completion functions have moved to /usr/share/bash-completion."
+ ewarn "Please run etc-update to replace /etc/bash_completion.d/gentoo with a symlink."
+ fi
+ echo
+
+ if has_version 'app-shells/zsh' ; then
+ einfo "If you are interested in using the provided bash completion functions with"
+ einfo "zsh, valuable tips on the effective use of bashcompinit are available:"
+ einfo " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ einfo " http://zshwiki.org/ZshSwitchingTo"
+ echo
+ fi
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20050121-r2 b/app-shells/bash-completion/files/digest-bash-completion-20050121-r2
new file mode 100644
index 000000000000..5574bbf415d5
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20050121-r2
@@ -0,0 +1,2 @@
+MD5 fafeed562b01a8dee079eb851579f2d2 bash-completion-20050121.tar.bz2 90140
+MD5 38ee47358b278c7b0253fc444a39c544 gentoo-bashcomp-20050207.tar.bz2 17068