summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-03-28 11:18:21 +0000
committerYixun Lan <dlan@gentoo.org>2015-03-28 11:18:21 +0000
commitfcc0a21c8cca414a060adbdc115a269247c1789d (patch)
treef5a275de0985f102079f033c17055d677b7fde0e
parentVersion BUmp; fix live ebuild for latest changes (diff)
downloadgentoo-2-fcc0a21c8cca414a060adbdc115a269247c1789d.tar.gz
gentoo-2-fcc0a21c8cca414a060adbdc115a269247c1789d.tar.bz2
gentoo-2-fcc0a21c8cca414a060adbdc115a269247c1789d.zip
version bump, proxy for Simone
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
-rw-r--r--net-misc/logmein-hamachi/ChangeLog9
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.1.0.139.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/net-misc/logmein-hamachi/ChangeLog b/net-misc/logmein-hamachi/ChangeLog
index 7e225f5c9d7b..719728ca8f28 100644
--- a/net-misc/logmein-hamachi/ChangeLog
+++ b/net-misc/logmein-hamachi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/logmein-hamachi
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.16 2014/12/23 19:52:00 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.17 2015/03/28 11:18:21 dlan Exp $
+
+*logmein-hamachi-2.1.0.139 (28 Mar 2015)
+
+ 28 Mar 2015; Yixun Lan <dlan@gentoo.org> +logmein-hamachi-2.1.0.139.ebuild:
+ version bump, proxy for Simone
*logmein-hamachi-2.1.0.136 (23 Dec 2014)
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.139.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.139.ebuild
new file mode 100644
index 000000000000..4ae31aae8094
--- /dev/null
+++ b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.139.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.139.ebuild,v 1.1 2015/03/28 11:18:21 dlan Exp $
+
+EAPI=5
+inherit eutils linux-info systemd
+
+DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
+HOMEPAGE="https://secure.logmein.com/products/hamachi"
+SRC_URI="x86? ( https://secure.logmein.com/labs/${P}-x86.tgz )
+ amd64? ( https://secure.logmein.com/labs/${P}-x64.tgz )"
+
+LICENSE="LogMeIn"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-misc/hamachi"
+
+RESTRICT="mirror"
+
+QA_PREBUILT="/opt/${PN}/bin/hamachid"
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
+QA_WX_LOAD="/opt/${PN}/bin/hamachid"
+
+pkg_setup() {
+ einfo "Checking your kernel configuration for TUN/TAP support."
+ CONFIG_CHECK="~TUN"
+ check_extra_config
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${P}-$(use x86 && echo x86 || echo x64)" "${S}" || die
+}
+
+src_install() {
+ into /opt/${PN}
+ dobin hamachid dnsup dnsdown
+ dosym /opt/${PN}/bin/hamachid /usr/bin/hamachi
+
+ # Config and log directory
+ dodir /var/lib/${PN}
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodoc CHANGES README
+}
+
+pkg_postinst() {
+ elog "LogMeIn Hamachi2 is installed."
+ elog "Consult the README file on how to configure your client."
+ elog "You can run the client 'hamachi' as root,"
+ elog "or as a user if you add a newline terminated line:"
+ elog "Ipc.User <login name>"
+ elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
+ elog "and restart the daemon with"
+ elog "/etc/init.d/${PN} restart"
+ elog "or:"
+ elog "systemctl restart ${PN}"
+ elog "To enable auto-login when the service starts set a nickname in"
+ elog "/etc/conf.d/${PN} (only supported using openRC)"
+}