summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-09-24 14:24:42 +0000
committerMatt Turner <mattst88@gentoo.org>2011-09-24 14:24:42 +0000
commitfc03d2231c4227b1959ea3810a5af0bf991e0f68 (patch)
treeda8b89c571a14d30bdbc8a0cdab10a304bdc9d87
parentMarked ~x64-macos, libnaming fixes, and disable resigning of libs on Darwin, ... (diff)
downloadgentoo-2-fc03d2231c4227b1959ea3810a5af0bf991e0f68.tar.gz
gentoo-2-fc03d2231c4227b1959ea3810a5af0bf991e0f68.tar.bz2
gentoo-2-fc03d2231c4227b1959ea3810a5af0bf991e0f68.zip
Add patch to work-around high pitched sounds produced when compiled with gcc-4.6, bug 377837
(Portage version: 2.1.10.3/cvs/Linux x86_64)
-rw-r--r--media-video/mplayer/ChangeLog8
-rw-r--r--media-video/mplayer/files/mplayer-1.0_rc4_p20110322-gcc46.patch22
-rw-r--r--media-video/mplayer/mplayer-1.0_rc4_p20110322.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 1ac81f967021..a4b9a9a09978 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/mplayer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.798 2011/07/15 06:15:32 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.799 2011/09/24 14:24:42 mattst88 Exp $
+
+ 24 Sep 2011; Matt Turner <mattst88@gentoo.org>
+ mplayer-1.0_rc4_p20110322.ebuild,
+ +files/mplayer-1.0_rc4_p20110322-gcc46.patch:
+ Add patch to work-around high pitched sounds produced when compiled with
+ gcc-4.6, bug 377837
15 Jul 2011; Matt Turner <mattst88@gentoo.org>
mplayer-1.0_rc4_p20110322.ebuild:
diff --git a/media-video/mplayer/files/mplayer-1.0_rc4_p20110322-gcc46.patch b/media-video/mplayer/files/mplayer-1.0_rc4_p20110322-gcc46.patch
new file mode 100644
index 000000000000..bb7240eac0b1
--- /dev/null
+++ b/media-video/mplayer/files/mplayer-1.0_rc4_p20110322-gcc46.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/377837
+http://lists-archives.org/mplayer-dev-eng/34349-compiling-mplayer-with-gcc-4-6-broken-audio-decoding.html
+
+--- a/mp3lib/dct64_sse.c
++++ b/mp3lib/dct64_sse.c
+@@ -112,7 +112,6 @@ void dct64_sse(short *out0,short *out1,real *c)
+ }
+
+ {
+- real *costab = costab_mmx + 24;
+ int i;
+
+ __asm__(
+@@ -121,7 +120,7 @@ void dct64_sse(short *out0,short *out1,real *c)
+ "movaps %1, %%xmm5\n\t"
+ "movaps %%xmm5, %%xmm6\n\t"
+ :
+- :"m"(*costab), "m"(*nnnn)
++ :"m"(costab_mmx[24]), "m"(*nnnn)
+ );
+
+ for (i = 0; i < 0x20; i += 8)
diff --git a/media-video/mplayer/mplayer-1.0_rc4_p20110322.ebuild b/media-video/mplayer/mplayer-1.0_rc4_p20110322.ebuild
index b0ade17adda6..fcb3ef4112b8 100644
--- a/media-video/mplayer/mplayer-1.0_rc4_p20110322.ebuild
+++ b/media-video/mplayer/mplayer-1.0_rc4_p20110322.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_rc4_p20110322.ebuild,v 1.4 2011/07/15 06:15:32 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_rc4_p20110322.ebuild,v 1.5 2011/09/24 14:24:42 mattst88 Exp $
EAPI=4
@@ -196,6 +196,7 @@ fi
REQUIRED_USE="bindist? ( !amr !faac !win32codecs )"
PATCHES=(
+ "${FILESDIR}"/${P}-gcc46.patch
)
pkg_setup() {