summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-09-03 07:16:33 +0000
committerVlastimil Babka <caster@gentoo.org>2010-09-03 07:16:33 +0000
commitfbee38d897c4cd91126dbb06211c7d3d857ec8a4 (patch)
treea7e9d7357acadadccd21fb5710c6e78e2f562610
parentversion bump (diff)
downloadgentoo-2-fbee38d897c4cd91126dbb06211c7d3d857ec8a4.tar.gz
gentoo-2-fbee38d897c4cd91126dbb06211c7d3d857ec8a4.tar.bz2
gentoo-2-fbee38d897c4cd91126dbb06211c7d3d857ec8a4.zip
Version bump.
(Portage version: 2.2_rc72/cvs/Linux x86_64)
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/taskcoach-1.1.2.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index c20375629110..592a921ff96f 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.55 2010/08/31 09:45:17 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.56 2010/09/03 07:16:33 caster Exp $
+
+*taskcoach-1.1.2 (03 Sep 2010)
+
+ 03 Sep 2010; Vlastimil Babka <caster@gentoo.org> +taskcoach-1.1.2.ebuild:
+ Version bump.
31 Aug 2010; Christian Faulhammer <fauli@gentoo.org>
taskcoach-1.0.10.ebuild:
diff --git a/app-office/taskcoach/taskcoach-1.1.2.ebuild b/app-office/taskcoach/taskcoach-1.1.2.ebuild
new file mode 100644
index 000000000000..da88f9af396d
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.1.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.1.2.ebuild,v 1.1 2010/09/03 07:16:33 caster Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_unpack() {
+ default
+
+ einfo "Removing Funambol support, works only on x86 and python 2.5."
+ rm -fv "${S}"/taskcoachlib/bin.in/linux/*.so || die
+}
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}