summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-15 17:40:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-15 17:40:27 +0000
commitfb8bd2c4a711ab3006ddd62903238bdca66583c4 (patch)
tree6ac9d878595ed6378bce7b00b34eb7805c538263
parentSlightly polish the ebuild as it is supposed to be eapi4 so it does not need ... (diff)
downloadgentoo-2-fb8bd2c4a711ab3006ddd62903238bdca66583c4.tar.gz
gentoo-2-fb8bd2c4a711ab3006ddd62903238bdca66583c4.tar.bz2
gentoo-2-fb8bd2c4a711ab3006ddd62903238bdca66583c4.zip
Bump for #408373
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
-rw-r--r--dev-python/virtualenvwrapper/ChangeLog6
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild32
2 files changed, 23 insertions, 15 deletions
diff --git a/dev-python/virtualenvwrapper/ChangeLog b/dev-python/virtualenvwrapper/ChangeLog
index 8011f374de2c..38e6a4fe0927 100644
--- a/dev-python/virtualenvwrapper/ChangeLog
+++ b/dev-python/virtualenvwrapper/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/virtualenvwrapper
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/ChangeLog,v 1.2 2012/03/09 09:06:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/ChangeLog,v 1.3 2012/03/15 17:40:27 patrick Exp $
+
+ 15 Mar 2012; Patrick Lauer <patrick@gentoo.org>
+ virtualenvwrapper-3.0.1.ebuild:
+ Bump for #408373
*virtualenvwrapper-3.0.1 (09 Mar 2012)
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild
index 6be1d4c62bb0..b71a3bcaddad 100644
--- a/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild,v 1.1 2012/03/09 09:06:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenvwrapper/virtualenvwrapper-3.0.1.ebuild,v 1.2 2012/03/15 17:40:27 patrick Exp $
EAPI=4
-PYTHON_DEPEND="*"
+PYTHON_DEPEND="2:2.6 3:3.1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 *-jython 2.7-pypy-*"
-inherit distutils
-inherit python
+inherit distutils python
DESCRIPTION="virtualenvwrapper is a set of extensions to Ian Bicking's virtualenv tool"
HOMEPAGE="http://www.doughellmann.com/projects/virtualenvwrapper http://pypi.python.org/pypi/virtualenvwrapper"
@@ -24,13 +24,17 @@ DEPEND="${DEPEND}
dev-python/setuptools
test? ( dev-python/tox )"
-#src_test() {
-# testing() {
-# PYTHON_MAJOR="$(python_get_version --major)"
-# PYTHON_MINOR="$(python_get_version --minor)"
-# cp ${FILESDIR}/tox.ini .
-# export TMPDIR=${T}
-# tox -e py${PYTHON_MAJOR}${PYTHON_MINOR} tests/test_cp.sh
-# }
-# python_execute_function testing
-#}
+src_prepare() {
+ sed -e 's:-o shwordsplit::' -i tests/run_tests || die
+}
+
+src_test() {
+ testing() {
+ PYTHON_MAJOR="$(python_get_version --major)"
+ PYTHON_MINOR="$(python_get_version --minor)"
+ cp "${FILESDIR}/tox.ini" .
+ export TMPDIR=${T}
+ tox -e py${PYTHON_MAJOR}${PYTHON_MINOR} tests/test_cp.sh
+ }
+ python_execute_function testing
+}