summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-05-28 19:29:05 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-05-28 19:29:05 +0000
commitfb8a2c690cc734d03263a540dbd9c50a05f2a976 (patch)
tree8c4e40c07844417f768e0e83da28c673f85618ef
parentSupport for OPTIONAL_DEPEND in package.env, via new function java-pkg_registe... (diff)
downloadgentoo-2-fb8a2c690cc734d03263a540dbd9c50a05f2a976.tar.gz
gentoo-2-fb8a2c690cc734d03263a540dbd9c50a05f2a976.tar.bz2
gentoo-2-fb8a2c690cc734d03263a540dbd9c50a05f2a976.zip
Version bump.
(Portage version: 2.1.2.7)
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog11
-rw-r--r--app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.23
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak.patch11
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-python.patch11
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2.ebuild47
5 files changed, 82 insertions, 1 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index 78f3ab324328..d5f772b27841 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.21 2007/04/28 16:22:15 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.22 2007/05/28 19:29:05 williamh Exp $
+
+*speech-dispatcher-0.6.2 (28 May 2007)
+
+ 28 May 2007; William Hubbs <williamh@gentoo.org>
+ +files/speech-dispatcher-0.6.2-espeak.patch,
+ +files/speech-dispatcher-0.6.2-python.patch,
+ +speech-dispatcher-0.6.2.ebuild:
+ Version bump.
+ This version makes espeak the default synthesizer.
28 Apr 2007; Sven Wegener <swegener@gentoo.org>
speech-dispatcher-0.3.ebuild, speech-dispatcher-0.4.1.ebuild,
diff --git a/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.2 b/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.2
new file mode 100644
index 000000000000..5491ffa6267e
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.6.2
@@ -0,0 +1,3 @@
+MD5 e8a1d8f5f5a1899f87af4dd3ef9722c8 speech-dispatcher-0.6.2.tar.gz 974300
+RMD160 d0c30282d525c184bc1376e2fa39fd193d133c5f speech-dispatcher-0.6.2.tar.gz 974300
+SHA256 3db16854d65755a76c180271e65a6a29a43cd1f4e5d5eb3ea33b17b0ca58c4ae speech-dispatcher-0.6.2.tar.gz 974300
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak.patch
new file mode 100644
index 000000000000..7c55ae9bc1a2
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-espeak.patch
@@ -0,0 +1,11 @@
+--- speech-dispatcher-0.6.2/config/speechd.conf.in.orig 2007-04-13 22:13:29.000000000 -0500
++++ speech-dispatcher-0.6.2/config/speechd.conf.in 2007-04-13 22:13:48.000000000 -0500
+@@ -153,7 +153,7 @@
+ # DefaultModule selects which output module is the default.
+ # You must use one of the modules loaded with AddModule.
+
+-DefaultModule flite
++DefaultModule espeak-generic
+
+ # LanguageDefaultModule selects which output modules are prefered
+ # for specified languages.
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-python.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-python.patch
new file mode 100644
index 000000000000..207f17b50d40
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.2-python.patch
@@ -0,0 +1,11 @@
+--- speech-dispatcher-0.6.2.orig/src/python/Makefile 2006-08-09 06:00:46.000000000 -0500
++++ speech-dispatcher-0.6.2/src/python/Makefile 2007-04-13 18:31:15.000000000 -0500
+@@ -3,7 +3,7 @@
+
+ install:
+ if test -x /usr/bin/python; then \
+- ./setup.py install --prefix=$(prefix); \
++ ./setup.py install --root $(DESTDIR) --no-compile; \
+ else \
+ echo "Python not found, not installing speechd module"; \
+ fi
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2.ebuild
new file mode 100644
index 000000000000..d38feb5fde8d
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.2.ebuild,v 1.1 2007/05/28 19:29:05 williamh Exp $
+
+inherit eutils
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-accessibility/espeak
+ dev-libs/dotconf
+ >=dev-libs/glib-2
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-espeak.patch
+ epatch ${FILESDIR}/${P}-python.patch
+}
+
+src_compile() {
+ econf || die "configure failed"
+ make all || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ newinitd ${FILESDIR}/speech-dispatcher speech-dispatcher
+
+ dodoc AUTHORS ChangeLog NEWS TODO
+
+ insinto /usr/include
+ doins ${S}/src/c/api/libspeechd.h
+}
+
+pkg_postinst() {
+ elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+}